Problems with xplico with Ubuntu mate 15.10

My computer is Asus A455LJ running Ubuntu Mate 15.10 (Wily Werewolf) 64-bit , Kernel Linux 4.2.0-35-generic x86_64 , Mate 1.10.2

I installed xplico by opening up a terminal and typed :
sudo bash -c ‘echo “deb http://repo.xplico.org/ $(lsb_release -s -c) main” >> /etc/apt/sources.list’
sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys 791C25CE
sudo apt-get update
sudo apt-get install xplico
(as suggested at h t t p : / / wiki.xplico.org/doku.php?id=ubuntu)

when i run " xplico " in terminal i get :
bash: /sbin/xplico: Permission denied

when i run " sudo xplico " i get :
sudo: xplico: command not found

when i enter root and run " xplico " i get :
bash: /sbin/xplico: Permission denied
(i was root and permission denied XD)

when i run " sudo apt-get update " i get not error or problems

when i run " sudo apt-get upgrade " i get :
nikhasan@nikhasan-X455LJ:~$ sudo apt-get upgrade
Reading package lists… Done
Building dependency tree
Reading state information… Done
Calculating upgrade… Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
1 not fully installed or removed.
Need to get 0 B/28.3 MB of archives.
After this operation, 0 B of additional disk space will be used.
Do you want to continue? [Y/n] y
dpkg: error processing package xplico (–configure):
package xplico is not ready for configuration
cannot configure (current status ‘half-installed’)
Errors were encountered while processing:
xplico
E: Sub-process /usr/bin/dpkg returned an error code (1)

when i run " sudo apt-get purge xplico " i get :
Reading package lists… Done
Building dependency tree
Reading state information… Done
The following packages were automatically installed and are no longer required:
libapache2-mod-php5 librecode0 php5-cli php5-common php5-json php5-readline php5-sqlite python3-httplib2
python3-psycopg2 recode
Use ‘apt-get autoremove’ to remove them.
The following packages will be REMOVED:
xplico*
0 upgraded, 0 newly installed, 1 to remove and 0 not upgraded.
1 not fully installed or removed.
After this operation, 61.9 MB disk space will be freed.
Do you want to continue? [Y/n] y
dpkg: error processing package xplico (–purge):
package is in a very bad inconsistent state; you should
reinstall it before attempting a removal
Errors were encountered while processing:
xplico
E: Sub-process /usr/bin/dpkg returned an error code (1)

when i run " sudo apt-get install xplico " i get :
Reading package lists… Done
Building dependency tree
Reading state information… Done
xplico is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
1 not fully installed or removed.
Need to get 0 B/28.3 MB of archives.
After this operation, 0 B of additional disk space will be used.
Do you want to continue? [Y/n] y
dpkg: error processing package xplico (–configure):
package xplico is not ready for configuration
cannot configure (current status ‘half-installed’)
Errors were encountered while processing:
xplico
E: Sub-process /usr/bin/dpkg returned an error code (1)

when i run " sudo apt-get remove xplico " i get :
Reading package lists… Done
Building dependency tree
Reading state information… Done
The following packages were automatically installed and are no longer required:
libapache2-mod-php5 librecode0 php5-cli php5-common php5-json php5-readline php5-sqlite python3-httplib2
python3-psycopg2 recode
Use ‘apt-get autoremove’ to remove them.
The following packages will be REMOVED:
xplico
0 upgraded, 0 newly installed, 1 to remove and 0 not upgraded.
1 not fully installed or removed.
After this operation, 61.9 MB disk space will be freed.
Do you want to continue? [Y/n] y
dpkg: error processing package xplico (–remove):
package is in a very bad inconsistent state; you should
reinstall it before attempting a removal
Errors were encountered while processing:
xplico
E: Sub-process /usr/bin/dpkg returned an error code (1)

when i run " sudo apt-get autoremove " i get :
Reading package lists… Done
Building dependency tree
Reading state information… Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
1 not fully installed or removed.
Need to get 28.3 MB of archives.
After this operation, 0 B of additional disk space will be used.
Get:1 http://repo.xplico.org/ wily/main xplico amd64 1.1.1 [28.3 MB]
Fetched 28.3 MB in 48s (583 kB/s)
dpkg: error processing package xplico (–configure):
package xplico is not ready for configuration
cannot configure (current status ‘half-installed’)
Errors were encountered while processing:
xplico
E: Sub-process /usr/bin/dpkg returned an error code (1)

I really want to use xplico but i cant =(
WHAT IS THE PROBLEM HELP ME PLEASE. Thanks in advance :slight_smile:

Hi,

open a Terminal and type the following commands, pressing the Return or Enter key after each (you may have to type in your password):

sudo dpkg --configure -a

followed by

sudo apt-get install -f

The first of the above commands fixes the “You have held Broken Packages” message, the second command forces the package installer to force an install of the failed package installation by making sure that all dependency requirements are met!.

“sudo dpkg --configure -a” gives nothing (i dont know if that is ok , bad , good, or normal)

" sudo apt-get install -f " gives me an error :
Reading package lists… Done
Building dependency tree
Reading state information… Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
1 not fully installed or removed.
Need to get 0 B/28.3 MB of archives.
After this operation, 0 B of additional disk space will be used.
dpkg: error processing package xplico (–configure):
package xplico is not ready for configuration
cannot configure (current status ‘half-installed’)
Errors were encountered while processing:
xplico
E: Sub-process /usr/bin/dpkg returned an error code (1)

Hi,

try using this PPA:

sudo bash -c 'echo "deb http://repo.xplico.org/ $(lsb_release -s -c) main" >> /etc/apt/sources.list'

sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys 791C25CE

sudo apt-get update && sudo apt-get install xplico

I took the info from here:

http://www.xplico.org/

Try their forum!:

http://forum.xplico.org/

yes that is exactly what i did. that is how i installed xplico

It won’t install here due to the repo 404 messages!:

E: Failed to fetch http://repo.xplico.org/dists/xenial/main/binary-amd64/Packages 404 Not Found
E: Failed to fetch http://repo.xplico.org/dists/xenial/main/binary-i386/Packages 404 Not Found
E: Some index files failed to download. They have been ignored, or old ones used

http://repo.xplico.org/dists/

No xenial package. If you still want it then use the Wily package.

1 Like

I never even thought of saying that!. :smiley: