Random freezes (NOT delays) at shutdown

My machine sometimes freezes at shutdown with drm i915 errors such as these:

It does this with 4.2, 4.4, and 4.5 kernels but it happens the least on 4.2. This is an optimus machine and running bumblebee.

Any idea what might be wrong?

$ inxi -ACDMNSG gives the following:

System: Host: gazp7 Kernel: 4.2.0-35-generic x86_64 (64 bit)
Desktop: MATE 1.12.1 Distro: Ubuntu 16.04 xenial
Machine: System: CLEVO (portable) product: W251ESQ/W270ESQ
Mobo: CLEVO model: W251ESQ/W270ESQ
Bios: American Megatrends v: 4.6.5 date: 09/27/2012
CPU: Quad core Intel Core i7-3610QM (-HT-MCP-) cache: 6144 KB
clock speeds: max: 3300 MHz 1: 1391 MHz 2: 1314 MHz 3: 1295 MHz
4: 1499 MHz 5: 1319 MHz 6: 1231 MHz 7: 1261 MHz 8: 1501 MHz
Graphics: Card-1: Intel 3rd Gen Core processor Graphics Controller
Card-2: NVIDIA GF108M [GeForce GT 630M]
Display Server: X.Org 1.18.3 drivers: intel (unloaded: fbdev,vesa)
Resolution: [email protected]
GLX Renderer: Mesa DRI Intel Ivybridge Mobile
GLX Version: 3.0 Mesa 11.2.0
Audio: Card Intel 7 Series/C210 Series Family High Definition Audio Controller
driver: snd_hda_intel
Sound: Advanced Linux Sound Architecture v: k4.2.0-35-generic
Network: Card-1: Qualcomm Atheros AR93xx Wireless Network Adapter
driver: ath9k
Card-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
driver: r8169
Drives: HDD Total Size: 128.0GB (37.0% used)
ID-1: /dev/sda model: M4 size: 128.0GB

And I should mention this is a new problem since I upgraded from 15.10 to 16.04.

Hi @randomdave,

do you have “bumblebee-nvidia primus” installed?. :smiley:

See also:

https://wiki.ubuntu.com/Bumblebee

Yes.

[email protected]:~$ sudo aptitude versions bumblebee-nvidia primus
[sudo] password for don:
Package bumblebee-nvidia:
i 3.2.1-10 xenial 500

Package bumblebee-nvidia:i386:
p 3.2.1-10 xenial 500

Package primus:
i 0~20150328-1 xenial 500

Have you done a full system update since writing?:

you may want to have a look at this page

The full system update didn’t help. I still get the i915 errors and even the occasional kernel panic at shutdown.

As a test I decided to remove bumblebee and the Nvidia drivers completely, leaving just the bbswitch module set to turn off the Nvidia hardware at boot for power savings. I also blacklisted the Nouveau driver.

Now the system shuts down cleanly every time, but of course the faster graphics is not available.

I think its likely a problem with bumblebee. No big deal but it was nice to have the option in 15.10.

Thanks to you both for your help.

2 Likes