Raspberry Pi 3 Model B Plus, Ubuntu Mate installation error: "driver 'sdhost-bcm2835' already registered, aborting

Hey!

I've just bought me a new Raspberry Pi 3 Model B Plus and wanted to install Ubuntu Mate on it.
So I cleared my SD-Card with the "SD Card Formatter", downloaded Ubuntu Mate from https://ubuntu-mate.org/raspberry-pi/ubuntu-mate-18.04.2-beta1-desktop-armhf+raspi-ext4.img.xz and installed it onto my SD-Card with "Win32DiskImager".
But when I plugged the card in and turned on the power of my Raspberry Pi, I got the following on my screen:

[  Runtime] Driver 'sdhost-bcm2835' already registered, aborting...
[  Runtime] EXT4-fs (mmcblk0p2): error loading journal

BusyBox v1.27.2 (Ubuntu 1:1.27.2-2ubuntu3.1) built-in shell (ash)
Enter 'help' for a list of built-in commands.

(initramfs)_

I've been looking for a solution for hours now and only found one really confusing post, so any help would be appreciated. ; D
Thanks in advance.

1 Like

Hi,
I get also the Driver 'sdhost-bcm2835' already registered, aborting... message after applying the existing published upgrades.
Being a Beta version, I guess that we have to wait and they will manage somehow.
Best regards.

I've had this running since loading it 31 march 2019, with no problems.
Derek

Im getting this same error as well and cannot find a solution...

Driver 'sdhost-bcm2835' already registered, aborting... is a warning not an error, it can be safely ignored.

The kernel is attempting to initialize the device twice and the warning is displayed the second time. There is a bug tracking this and it will get fixed in due course.

1 Like

I am getting the same error. https://raspberrypi.stackexchange.com/questions/98572/raspberry-pi-3-b-error-driver-sdhost-bcm2835-is-already-registered-abortin

The issue is restarting the RaspberryPi in a infinite loop.

Error: Driver 'sdhost-bcm2835' is already registered, aborting...

Unfortunately, it is an error (not just a warning).

I just downloaded the ubuntu-mate-18.04.2 image and installed it on my RP2B today using Etcher. I am also getting this error. It is keeping the GUI from loading and it boots into Emergency Mode.

I am also getting the same error... is there any solution for this error? I am booting an ubuntu mate os on a Rpi 3 b

unfortunately, i also have this problem , i think it's not a warning, it's error.

Anyone figured out the way to fix this issue?My Rpi starts with infinite login loop.can't do it anything to work in it

I had the same error. I still do get it on boot up though. Using SD Card Formatter, developed by TUXERA, and doing a full format on a 64gig Sandisk Ultra.
I was able to reload the image for UBUNTU18.04 Beta. Now the GUI Loads and I have everything running on an RPI3 B+. It took a long time for it to format. Just be patient for it to finish. I then used Win32Diskimager to write the image.
I tried with formatting with Minitool, first, with no luck.
We are now streaming NEXTPVR through VLC Media player without any problems. I have my cable box running and connected using a Hauppage Collossus 2 PCI-E Card on a Windows 10 box which NextPVR sees. This is my fix for not having Kodi installed. We now can Stream TV in the Garage or on the back Patio or anywhere I want to set this up.
I can't wait to a hold of the PI 4. Ubuntu-Mate will really Fly then. The PI4 is on back order everywhere I look. I am in the US though.
The PI4 will run Windows 10 also. I have installed it on a PI3, but it runs real slow. The PI4 with 4gigs of RAM will run it much better. I found information on GITHUB Look for WOA.Deployer and follow the directions. Around 23 or so steps. It does work.
Tyler