Raspberry Pi 4 Model B doesn't boot with Ubuntu Mate

Hi All
I'm using Raspberry Pi 3 since a while and just got the new Pi 4 B with 4GB ram.
I noticed that non of the Ubuntu Mate raspberry images are booting on the Pi 4, while everything seems fine on the Pi 3.
I really tried everything, googled a lot for users with the same or similar issues.
I tried everything what was recommended such as different settings in the config.txt, EEPROM recovery, different screens, etc. Whenever I put in an SD card with ubuntu, the Pi 4 stays still.
One thing I noticed is different in my case compared to others I found:
the green light is not blinking at all. When I remove it and switch on the Pi 4 without SD, the green light is flashing. so all ok with the EEPROM.
When I insert a raspbian card or anything else, everything is fine. When I put Ubuntu, whether it's aarch32 or aarch64, the led's stay red and steady.
I also tried to change the format of the boot partition from fat16 to fat32, as I also read somewhere. But even this didn't help.
Now I'm running out of ideas.
Anybody else made similar experiences?
Thanks already in advance!

AFAICT there is no official release of Ubuntu Mate for Pi4 yet.
I recently followed advice to download the server version of Ubuntu 19.10 and then added the Mate desktop and environment - can seem a bit tedious, but works. I haven't yet got to sorting out sound.
There are relevant threads, if you are prepared to look.

That's great! I just installed ubuntu server and it seems to work well! I will try the mate gui afterwards. Thanks a lot!