(Realtek rtl8125) 2.5GBe ethernet not working on AMD B550 mobo

So, this is a known issue: Realtek 2.5GBe ethernet on B550 mobo does not work with Linux because reasons.

$ lspci -knn | grep Eth -A3

06:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8125 2.5GbE Controller [10ec:8125] (rev 05)
DeviceName: RTL8111E Giga LAN
Subsystem: Gigabyte Technology Co., Ltd RTL8125 2.5GbE Controller [1458:e000]
Kernel modules: r8169

$ dmesg | grep -i r8169

[ 2.931313] r8169 0000:06:00.0: unknown chip XID 641

Arch users have a workaround here which include detailed steps to build the r8125 package, install it and load it up.

I've tried looking for similar solutions in the Ubuntu forums but I couldn't find any with detailed steps to do the same.

I understand that support has been added to the linux-next tree but it'll take a long while before it gets into Ubuntu. (I heard it will be Kernel 5.9, and we're on Kernel 5.4).

Thanks for reading, any help is appreciated.


Here's a solution I found;

  1. Go to the Realtek website

  2. Download the Unix(Linux) r8125 driver. You will need to give an email address.

  3. Go to /Downloads directory. Extract the Tarball.

  4. In Terminal, go into r8125-xxxx folder and run the autorun.sh

$ sudo ./autorun.sh

Everything should run automatically and you should get ethernet connection now.

1 Like

Updates for Ubuntu 20.04 broke this driver. It's now unusable. My Lan connection now can't be used.

I don't know what you guys did, but all I can do is ask why?


Hi ,

After each kernel update , you must re install ethernet driver .

So for removing :

sudo modprobe -rfv r8125
sudo dkms remove -m r8125 -v 9.003.05 --all
sudo rm -r /usr/src/r8125-9.003.05

then reinstall with the initial procedure seen before .

Hi I am new so am not sure if I should post here or ask as a new topic but here goes. I am also not particularly good with Linux.

I have this issue as well and have been able to reinstall in the past when the driver stops working but this time I can't.

I have an Aorus B550 motherboard running Ubuntu 20.04. The ethernet NIC is not listed when I run the command ifconfig. I have connected via usb tethered hotspot and downloaded the driver off of the Realtek website. The version I have downloaded is R8125-9.004.01 but am not sure what version I have installed previously and am unsure how to find out.
When I try to run the "sudo ./autorun.sh" command as stated in the READ ME file for the driver it gives me the error:

sudo ./autorun.sh

Check old driver and unload it.
Build the module and install
make[3]: *** No rule to make target 'information'. Stop.
make[2]: *** [Makefile:340: __build_one_by_one] Error 2
make[1]: *** [Makefile:167: clean] Error 2
make: *** [Makefile:48: clean] Error 2

I did try the "sudo modprobe -rvf r8125" command but got the error:
modprobe: FATAL: Module r8125 not found.

I cannot work out how to resolve this and any help would be very much appreciated.

I have now resolved the issue.

In the end I downloaded the “GBE Ethernet LINUX driver r8168 for kernel up to 5.6” driver from the Realtek website, instead of the 2.5GB driver and running the ./autorun.sh command as root worked.

still having this problem with ubuntu 21.04. tried this since it supposedly had the driver updates. using a strix B450-F with the 2.5 Ghz ethernet.

                  description: Ethernet interface
                  product: I211 Gigabit Network Connection
                  vendor: Intel Corporation
                  physical id: 0
                  bus info: [email protected]:04:00.0
                  logical name: enp4s0
                  version: 03
                  serial: 3c:7c:3f:1e:cb:f3
                  capacity: 1Gbit/susing a strix B450-F
                  width: 32 bits
                  clock: 33MHz
                  capabilities: bus_master cap_list ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd 1000bt-fd autonegotiation
                  configuration: autonegotiation=on broadcast=yes driver=igb driverversion=5.11.0-22-generic firmware=0. 6-1 latency=0 link=no multicast=yes port=twisted pair
                  resources: irq:36 memory:fc900000-fc91ffff ioport:c000(size=32) memory:fc920000-fc923fff