Remote Desktop to Raspberry PI 3 - Some keys fail

I’m trying to connect to my Raspberry PI 3 via xrdp. I have installed xrdp. My Desktop computer is Ubuntu 16.04LTS.

I’m able to connect to it with rdesktop. When I connect to a Windows machine all the keys work fine, the same way it does when working local to the computer. However, when I connect to the Raspberry PI 3, it loads aright. However, some of the keys don’t work. The key l` doesn’t print anything to the screen. The ENTER key acts as if I’m hitting some type of control key. It doesn’t function as expected.

Can someone advise me on what needs to be done on the Raspberry PI 3 device so that the xrdp application functions properly with the keys?


– L. James

What OS is u using the Pi? It could be that the keys are in a different language. The raspberry pi was made in the UK after all and so are some of there OS. I had a problem when the @ symbol was giving me something totally different. Then I notice the keyboard layout was in the UK. What are u really trying to do on the pi tho? I have never herd of xrdp. I have a better way for a remote desktop if thats what u are trying to do. I it on my YT channel.

1 Like

U have Ubuntu right? So do sudo apt-get install putty and go here for vnc
watch the vid if u don’t know what I’m talking about.

The OS I’m using is:

The Raspberry PI 3 Host:


$ cat /etc/lsb-release 

It was downloaded from this site. I used these steps from this site to install and configure the apt:

I have since spent a number of days researching and trying various configurations to fix the problem. I have two Raspberry PI 3 installations, one with a fresh install and the exact steps. Another with my experiments to try to make it work. If you or anyone have any suggestions on how to make it work, I’ll add that to the environment.

At present, it works as expected except that some of the keys fail such as the “ENTER” key an the lower case “L”.

The main host machine is:

Ubuntu 16.04.3 LTS

I have connected from other computers including Microsoft Windows 7 and Microsoft Windows 10. The behavior is the same. It works as expected except for some of the keys such as the “ENTER” key and the lowercase “l”.

I’m trying to use the Raspberry PI 3’s GUI desktop without a monitor or keyboard attached to it.

I had already tried the VNC application in the past and was having similar problems. I’ll follow the steps you have provided and get back with you on the status of the exact problems. I’ll perform it on a fresh ubuntu-mate-16.04.2-desktop-armhf-raspberry-pi.img.xz install to ensure any problems won’t be a result of conflict from some of the other fail attempts.

By the way, I have been using the regular VNC server and viewer for many years on a number of Linux distributions. I have just started working with the Raspberry PI.

While I’ll be glad if I can get the VNC working, I suggest that you consider taking a look at the rdp/xrdp variation of remote access. It has an advantage of allowing multiple users to simultaneously log in. If you can get that working I’m sure it’ll prove to be a great enhancement to your environment. There are other caveats that include remote access time and screen draw exponentially faster.

– L. James

ok im sorry ill look into this and see what I can do thanks.

Ok, how did u connect your Ubuntu machine to your pi? I have a Ubuntu machine too. I installed rdp and xrdp just tell me how to set it up. I want to see if I get the same results when I connect my pi in.

I’m glad for your interest in helping to resolve this problem.

The installing and setting up of xrdp is easy under Ubuntu. You have to just be sure to have a compatible desktop environment such as mate-desktop installed.

Run these two commands and it’ll work immediately from Windows or from Ubuntu.

sudo apt install xrdp
sudo apt install mate-core mate-desktop-environment mate-notification-daemon

The first command will install it and it’ll work. However, the default Ubuntu 16.04 LTS desktop has some issues. The second command resolves the issues by adding an additional desktop environment (mate-desktop).

You can set the perferred desktop by editing the /etc/xrdp/ file and added mate-session to the line just before . /etc/X11/Xsession.

It should look like this:



if [ -r /etc/default/locale ]; then
  . /etc/default/locale

. /etc/X11/Xsession

I’m glad for your interest. After you see it work with Ubuntu you might be able to resolve the problems it has with Ubuntu-mate on the Raspberry PI 3.

By the way, I’m sure your input has cleared up some of the problems I was having with VNC. My Raspberry PI 3 installation is Ubuntu-mate. VNC doesn’t show up in the raspi-config apt as an interface option to enable. I had installed Vino which is another VNC server. It might have some type of conflict with the one from the raspi-config apt. So I’ll have to figure out how to enable that one when it’s not on the menu.

I upvoted your first post. If you can figure out how to make it work under Ubuntu-mate it’d be great and resolve the issue. I’m sure there are others using Ubuntu-mate that are having the same problem. It should be a much-welcomed contribution to this Ubuntu-mate community, for users installing it instead of the default Raspberry OS.

– L. James

IKR I honestly hate the Raspbian OS. Its so limited. So I installed the Mate environment and changed the nano file whats next?

I’m not sure I understand where you are at this time. There are two steps in the setup

Step #1

Install xrdp and the Mate-Desktop.

$ sudo apt install xrdp
$ sudo apt install mate-core mate-desktop-environment mate-notification-daemon

Step #2

Add the line mate.desktop to the /etc/xrdp/ file just above the . /etc/X11/Xsession line.

Now you can use the command rdesktop [host ip of raspberry] to connect to it from your Ubuntu PC or Search for Remote Desktops to connect from your Windows computer.

By the way, I see I miswrote mate.desktop in my previous message. I’ll correct that post. Also, you can see the available desktop environments to choose from with this line:

Check available Desktop environments:

$ ls -l /usr/share/xsessions/

Let me know if you are still having problems. And thanks a bunch for being interested and keeping this issue active. Once you connect you might figure out how to make the ENTER and l keys work.

– L. James

How I connect the pi the Ubuntu Machine now. I did all the steps too. BTW the command u gave me to check available desktop environments. It says no such file in dir.

Sorry about mistyping the command. I usually copy and paste to avoid mistakes. I corrected the command in my post.

Does the ENTER and lower case l keys work for you?

Thanks again for helping with this issue!

– L. James

total 24
-rw-r–r-- 1 root root 138 May 31 2017 kodi.desktop
-rw-r–r-- 1 root root 6915 Nov 9 11:12 mate.desktop
-rw-r–r-- 1 root root 204 Aug 22 2016 ubuntu.desktop
lrwxrwxrwx 1 root root 12 May 31 2017 xbmc.desktop -> kodi.desktop
-rw-r–r-- 1 root root 5465 May 25 2015 xfce.desktop

I don’t understand the significance of your post. Are you able to connect from your Desktop? Does the ENTER and “l” keys work?


– L. James

That is what I got when I did ur command u sent me in the last post. How do connect now does the ubuntu machine appear as wifi when I’m on my pi or something? Do I have to open an app?

You can connect to an RDP client (which this is) from in the following manner:

From a LInux computer run this command:

$ rdesktop [ipaddress of the other computer]

From a Windows computer do these steps:

Start -> (Type in) Remote Desktop Connection -> ENTER
(typin) [ip address of the other computer] -> ENTER

An example of the IP address of the other computer is:

– L. James

Ok I done it. Got to say its pretty neat. Ok so when u press enter or l on the pi itself does it have that problem?

I’m glad you see merit in the app. To perform maintenance on computers remotely it’s invaluable. It’s substantially faster and allows multiple users to be logged in to a GUI at the same time.

There’s no problem with using the PI with any keyboard. I only experience problems when running accessing the rdp (Remote Desktop Protocol).

Does the ENTER key and the lower case “l” key work for you when you log in from remotely?

I experience the same problem from multiple computers and multiple OS’s.

If the ENTER key and the lowercase “l” key works for you when logging in to the RDP session, then I’d have to try to explore what is different from your environment and mine.

– L. James

Yes they worked lets see what I have that u dont so we can sum up and solve your problem.

This is what I have and tell me if any of these is diff.

Ubuntu 16.04
Ubuntu mate 16.04 on raspberry pi 3
laptop with Ubuntu
Wireless keyborad
Wired keyborad
Defects on Pi
droped pi
languge for ubuntu mate is english keyborad
ssh is enabled

Also im getting a diff linux for my pi just because I found a better linux for the pi that i like. Plus for me it works so whats the point. I will be able to help u still. I am familiar
with Ubuntu mate anyways so win win.

Thanks for the diagnosis. Sorry for the late response, but I was out of town most of the day.

I don’t know which OS you’re looking into getting, but give ubuntu-mate-16.04.2-desktop-armhf-raspberry-pi.img a try. This is the official support site for it.

– L. James