Right Click not working

i installed Ubunthu mate (17.10 64bit) in my laptop but Right click is not working…
Pls help to solve this…
thank you…

Hi, are you using your touchpad?

You could take a look if there are propietary drivers available:

You could try installing the syntapics touchpad driver. (Ubuntu MATE 17.10 is the first version to use the libinput touchpad driver by default instead of the older synaptics.)

sudo apt install xserver-xorg-input-synaptics

and reboot to use it.

1 Like

thanks you very much :smile:
I will try :sunglasses:

thanks you very much :smile:
its working

1 Like

I don’t recommend installing the Synaptic input driver. Instead open the Mouse control panel, switch to the Touchpad tab and set both the Two finger and Three finger emulation to Disabled.

It appears there maybe a logic error where these options are being used when libinput is in use. For 18.04 I’ll override the defaults so they are both disabled.


I’ve encountered on various Thinkpads that the Touchpad tab is altogether absent from the Mouse settings until Synaptics driver is installed. Hope someone can offer an alternative workaround.

Thanks a lot .
It worked for me.

it worked also for me
thank you!

Right click is working everywhere for me except on the desktop. I’m running 18.04 B1. Right click on the desktop does absolutely nothing. No context menu or anything. I figure it is some kind of Beta 1 bug. Currently at work doing nothing so doing a little looking for the cause.

Edit: Read below. It explains the cause and cure. :slight_smile:

Got my issue with the right click fixed. I wasn’t exactly sure what the problem was so here’s what I did.

I created a root password from cmd “sudo passwd root” Then I opened Caja from a root terminal and deleted ./cache from my home directory, I closed Caja and rebooted from the terminal. After log in the right click option on the desk top was working. I wasn’t exactly sure what the problem was.

At this point I was basically back to a default system with the apps I had installed. So I went back to setting things up the way I like them. I deleted the bottom panel, switched the menus out, I pinned browser, email, and Caja shortcuts next to the menu, added a windows list and switcher. I opened up Tweaks and enabled Keyboard LED since my laptop doesn’t have indicators and enabled the drop down terminal. At this point all was good and I still had desktop right click capabilities.

Next I clicked on Desktop in Tweaks and unticked everything because I don’t like icons on my desktop. I closed Tweaks and checked and right click option on the desktop was gone. I opened Tweaks back up and ticked Show Desktop Icons back on but left everything else unticked and the right click option was back.

So I guess that the desktop right click is an icon.lol … or it at least thinks it is.

With “show desktop icons” on the desktop is like a big folder, so you can right click to create folders, open it in the terminal, and so on. With it disabled the desktop is just the background color or image, not part of the file manager, so there’s nothing for right click to respond for.

I understand the folder structure. Just kind of figure when you are ticking something that says Desktop Icons then that is what the tweak should encompass, not the full functionality of the desktop folder. I can simply turn off the desktop icons in XFCE and still retain the rest of the desktop folder functionality.

Leaves me wondering why it is like that. No big deal. Now I know it is just one of those Mate quirks. Every windows manager or desktop environment has a few of them.

Thank you for the tip Wimpy, I simply switch both off and it automatically worked like a charm!
I must admit, aesthetically wise, I was not impressed at first, but the fact you can disable the top border on the apps maximized windows in such an easy way and after a few customization tricks, I must confess, I’m In love with Ubuntu Mate and quite happy to use it as my primary driver from now on!
Really impressive and massive work, please keep it up!

Fairly new to UM and have installed 18.10.

My wife has RA and because of that uses a touchpad as it’s easier for her than any mouse (other than an Apple Magic Mouse).

I have looked high and low and tried several solutions but cannot get any scrolling or the right click to work for her Apple Trackpad 2. It’s hard wired via USB and we can get the left click to work. Likely the battery is charging as I cannot see it in bluetooth either.

Once again reaching out to the Community for assistance and since you are a project leader, asking for some guidance.

I have:

  1. Gone into Control Center>mouse but it does not give me any options there. Only options are for a basic mouse (left and right buttons).
  2. I realize you don’t recommend installing the Synaptic input driver however it was my last resort. Installed it and rebooted, still nothing although honestly not even sure where to go to look for mouse options using that driver.

Please advise in a simple, easy to understand way how to get this operational. I have installed UM 18.10 on an iMac and everything else has pretty much worked out of the box. In fact, my wife who was a huge Apple fan is so impressed she’s been telling people she knows that " they really need to change their operating system"…:grin:

Thanks for the quick reply.