Root partition isn't unmounting correctly


I’m new user to Ubuntu MATE (but not to Linux at all) and I really like this distro. But, anyway…

I’ve got a little problem. Sometimes, when I shut down/restart my computer, Ubuntu MATE may boot me into Busy Box, because it probably can’t mount my / partition. So, I run fsck /dev/sdb2 and everything is fine after reboot (fsck says, that this partition wasn’t clearly unmounted). It can be really annoying, when you need to do something really fast, but you need to type this command in… Is there a way to prevent this for happening? I’m using Ubuntu MATE 17.04.


i think that’s systemd suckage. i’m in the middle of updating my 16.04 install to all the latest stuff. i’m thinking if it isn’t any better, i’ll just say screw the whole deal and go buy a MacBook in hopes of getting something that is a little more solid. but i don’t like Apple at all. so it goes.

If you’re rebooting / shutting down via menu, try shutting down via terminal to see if it still happens:

sudo shutdown -P now

Just keep using that for a while to see if the problem persists when using that. If it does not, we know that something in the shutdown script of the MATE desktop is messing things up and even though I’m typically not overly fond of blaming systemd for everything, in this case I’m actually inclined to agree with @crankypuss if indeed the MATE desktop is having trouble shutting down cleanly.

1 Like

This morning I turned on my computer and it booted me into BusyBox, so I’ve ran fsck /dev/sdb2, as always. Note, that I turned off computer through shutdown applet.

So, today I’ve tried to shutdown/reboot my computer through shutdown applet and shutdown now and reboot commands. Everything went fine… I didn’t install any updates.

That’s the only thing about Ubuntu-MATE that i don’t like-very-much, the fact that upstream Ubuntu seems to have some serious issues. Every time you power up your box the OS should start up just ike it does every other time, not all this hit-and-miss stuff. I think systemd is the culprit, since it’s running the startup process, but others seem to think the emperor’s clothes are quite pretty. I’m old so i don’t understand things anymore.