Scaling In Mate

To make the change permanent, I created an .xprofile file in my home folder with the following content:

xrandr --output eDP-1 --scale 1.5x1.5

Where eDP-1 is the screen ID

I found another solution:

My laptop has a NVIDIA plus Intel GPU. When i properly configured the NVIDIA GPU Optimus support through proprietary driver, the resolution was fixed without any other configuration.

I followed the following guides:


Dear Mate team, please give us fractional per-monitor scaling. Google it and you will see that people are leaving Mate because of lack of fractional scaling. It's 2022, not 1998 or something. People have laptops these days, and plug them into different monitors. All other major distros seem to have fractional scaling by now.


Yeah, it's about time.

Hi Rand,

Your feature request should be directed here:

1 Like

I made some experiments with these suggestions and unfortunately did not find THE good solution.
I have a couple of 4k screens driven by a GTX1060 on an i7 machine.
Here are my understandings :

  • org.mate.interface window-scaling-factor adapts the whole OS interface size (text, bars, tabs, panels...) with no resolution change.
  • xrandr --scale alters the full display resolution with no OS interface change.
    So indeed, the best would be to have a couple of values inbetween 1 and 2 for window-scaling-factor, but it's an integer so far...

Examples :

  • window-scaling-factor 1 and xrandr --scale 1x1 gives a clean full size image but with small GUI.
  • window-scaling-factor 2 and xrandr --scale 1.5x1.5 gives a clean small image with descent GUI size.
  • window-scaling-factor 1 and xrandr --scale 0.8x0.8 gives a blured big image with descent GUI size.

So finally I stayed with factor 1 and scale 1x1, compensating with 134dpi font. Although the buttons and other GUI items are still very small.
Is there a way we can configure them?

Side note : I got absolutely no result with gsettings set org.ArcticaProject.arctica-greeter xft-dpi 134, it remains tiny (even combined with enable-hidpi).


Welcome @maximator to the community!

Those are bitmaps so scaling is not ideal. Better find a theme with large buttons. Try the following link:

This works for everything except some GNOME apps, so you probably want to replace those GNOME apps with their MATE or KDE/QT counterparts.