Scanner not recognised

A friend of mine got the canon pixma MG5750 printer, the problem is the scanner is not getting detected either in simple scan or in the canon scanner program.

First time I’ve had to try this so my approach was a bit scattered. Anyway the printer itself works with the inbuilt drivers. The oem software scannergearmp didn’t work.

sudo sane-find-drivers shows pics up the scanner, take out sudo and its not seen. I followed a tutorial which I can’t seem to find at the moment. It said to add, “usb company number model number” in a printer config file.

Next I used this to install the needed software via synaptic.

After that I installed the oem printer driver and that it when the scan gear program appeared, but even though it will print, it wont see the scanner.

It seems strange that I can only see the scanner while an admin.

Since then I have found advice to install the nightly sane software via ppa.

I need as many things to try when I go back next to sort the issue. It seems to be a printer lots of people have had an issue with and have got to work.

Hopefully I’ve been clear, if not ask away.

My advice, if it isn’t too late for your friend to do so, is to return the printer and get an HP that is supported. You’ve already had to go to way too much trouble to get his printer working, in my opinion. I’ve been there, and you may eventually get it to work, but why not use a printer made by a company that supports Linux?

If it’s too late to return the printer, then I’d do what you’re doing. :smile:

I did suggest he bring the printer back, but he said it probably wouldn’t work because its a small company and it would work fine if on windows. Before he got the printer I suggested he get a HP because they have worked for me, but he took the shops advice over mine because they are the professionals, even though they had never heard of Ubuntu. There was three other issues that I hadn’t been told about, which I can easily fix. I’m fighting a loosing battle here, but I’ll keep going till the bitter end.

I don’t believe they have a package for this type of printer. Looking here, it’s an RPM package:

The other option, which may or may not work, is to use WINE to get it working with the included Windows Software and driver that came with the printer. Perhaps others in the forum may have a better solution to getting this printer up and running if you’re not able to return it.

Perhaps this link will help -


If you look at this post:

… it explains how to use the tool “alien” to convert an rpm-package into a deb-package. Be warned - it is not foolproof and may or may not work on any given rpm. But if you don’t have access to the source code it may be the best you can do. If you try it, could you let us all know if it worked? :slight_smile:


If there’s some money left to spend you might want to consider the buying a licence for the software “VueScan”.

It has been mentioned before in this forum e.g.

At work I have an old canoscan lide scanner. The only way to get it to work thesedays is with VueScan (windoze version).
VueScan software has a solid reputation, it may be worth taking a look at, if there’s still some money left in the budget. :slight_smile:

@qaztacos They have a deb package on the main canon site.
@mdooley I’ve already tried that one.

A few more links here and I would try Canon Asia first!:


I’ve got same issue with Canon MG7751. I installed the driver directly from Canon. To scan I use the terminal command:


That works well. I can’t configure special settings, but for a simple scan, it works.

@wolfman Thanks, will look at that.
@Atreju That is good to know, but my friend is not technical, so that wont work.



Perhaps, this could help your friend:

I have copy of the command (scangearmp2) in a text file. If I have to print something I open a terminal with

ctrl +alt + T and copy the text scangearmp2 with shift + ctrl + V in the Terminal and press enter.
First you will see a window with an info, that no scanner has been found. You should klick on searching for scanner (or something like this, my language setting is german). Then it should show your scanner/Canon Printer. Next, you click on scan. Thats all.

@Atreju I’ll show him that, as a stopgap, but anything that doesn’t work like Windows, like the scanner didn’t create a folder in Documents making it harder to find them makes him want to go back to Windows.

On the Asian support site, the file version number is the same on the local site. On the third party support drivers site the MG5750 is not listed.

Not strange at all. The scanner device is probably NOT owned by the user. See my thread over on

I spent the better part of a week playing with this and worked through a lot of issues - except that in the end it was a hardware incompatibility between the scanner and the usb port on the test PC. I documented my findings re. permissions. Perhaps they will help. If not, feel free to ask. I will keep an eye on this thread.


1 Like

@taylorkh When you say an [quote=“taylorkh, post:15, topic:11126”]
incompatibility between the scanner and the usb port[/quote] was that due to the dirty contacts at the back. I mostly kind of follow the steps you take, except for why you need to tigervnc to check a group on a local machine. I’ll have to play around with it to see what works. I’ll try the last step first since I know the id and vendor number already.

I do not believe the issue was due to dirty contacts. The test PC is relatively new and the physical post is much used for various other purposes - flash drives etc. - and has not shown any issues. Perhaps I should have said an issue with the usb controller. Note that a VMWare virtual machine with the scanner installed did not work on the test PC but worked fine when moved back to my main PC. No changes to the VM nor scanner configuration.

As to tigervnc… the older than ancient Pentium 4 PC has been repurposed as a data server and thus does not have a monitor. I have seen strange things when working over vnc and if the “fix” worked over vnc I am sure it would work if I connected a monitor and keyboard to the physical box.

Bottom line - the issue revolved around permissions. The account running the scanner needed to be a member of group “lp” or the permissions on the scanner had to be opened up to all with the entry in the udev rule.