Screen Definitions for a legacy monitor

Total monitor resets did not work. Manual adjustments only worked after applying new screen mode as I outlined above. Using the new screen mode and manual monitor settings gives a perfect screen, but only automatically after the login screen (using the above /usr/sbin/lightdm-session approach).
I want to be able to embed the definition as early as possible in the boot process. Oddly enough grey GRUB boot screens have always filled the screen, whereas the GUI green screens with UMate logos revert to 1024x768 and fills vertically, but leaves a huge black gap on the right hand side. (ie CPU delivers 1024 wide, but monitor scans 1280!)
Much of the www advice is outdated and does not apply to modern UMate setup, so I need help. The login/logout screens are ultimately not critical, but it is an intensely annoying start/end to a session!

Hi Rob,

so what GPU drivers do you have installed (if any)?. Could that be the problem?.

See also:

Thanks for your interest Wolfman, you are great resource.
I have read the article and this is what I got from the ‘lspci’ command that the web page recommended.

00:02.0 VGA compatible controller: Intel Corporation Mobile 945GSE Express Integrated Graphics Controller (rev 03)
00:02.1 Display controller: Intel Corporation Mobile 945GM/GMS/GME, 943/940GML Express Integrated Graphics Controller (rev 03)

That web page said Ubuntu already had the best drivers for Intel. So I think that part is OK?
I did the first major apt-get upgrade last night and rebooted this morning and my alterations to /usr/sbin/lightdm-session were overwritten confirming my fears that this was a bad place to add things into.
Other advice I have read refer to files or folders that do not exist on the U-Mate system, so I guess I am out on the fringes of the Ubuntu system and needs some pretty specific U-Mate advice.
Cheers, Rob

Hi Rob,

are you using a 32 or 64 Bit version of UM?.

How did you create your bootable media?, DVD or USB and did you follow this advice? (It may be a faulty install causing the problem as I have an Intel GPU on my mini notebook and that runs fine!):

Hi, Wolfman,
32 bit install, and off a USB stick. No hiccups, went in first time.
Thanks, again. Rob

Hi Rob,

try taking a look at the update guide and the first 3 pics about using Welcome and possible fixes?, you could also try changing your software sources update location and try updating again?. it may be a case of missing dependencies?:

Sorry just on further reflection Wolfman, I am thinking maybe the real
cause is the Philips monitor not reporting successfully to the eeeBox.
The eeeBox has a DVI connector and I use the DVI->VGA connector that
comes with the eeeBox to feed VGA to the monitor. This maybe
non-standard? However I can’t recall having these problems running
XUbuntu on it previously. I am pretty sure I did not have this problem
with it. U-Mate just says the monitor is “Unknown”, and just presents
the default 1024x768 alternative as the highest res available. How can
I test what monitor definitions it does hold and how the Philips
compares against them. Or does it get all that from a dialogue directly
with the monitor? Once the new screen mode is in, it does appear in the
Control Center Displays Application as a valid choice. If I could add
that definition permanently to the default list in Displays, I would be
right?

Cheers, Rob

Hi Rob,

the adapter may well be the cause of the problem but I cannot really say as I don’t use such things!.

If Xubuntu ran okay then I would first try updating as I said above first, if that doesn’t help, play around with the adapter and see if you can get a result that way?.

Have you run a live CD test to see if it happens when running in live mode?. Try it out and see what the res is and if it is higher, then I can only assume that something isn’t quite right with your system?. :smiley:

if by initial U-Mate screen you ment “Boot Splash” (plymouth) , then you have to edit the bootloader config file.
Just do in terminal

sudo nano /etc/default/grub

And change line

GRUB_GFXPAYLOAD_LINUX={Your resolution}

if the line is commented out with “#” then remove the “#” sign

The thing is that everything before the login-manager is not handled by the X server.
For that part there is no dynamic way to change the settings at runtime.

And for after that i found a tool called “autorandr” wich detects monitors and diffirent configs can be activated for them.
see : https://github.com/wertarbyte/autorandr for more information

Hi Wolfman,

I have triple checked the cables are all firm etc and then discovered
the Philips has a DVI socket, so I can try DVI -> DVI if I can
source/borrow a cable (I am not buying another cable unless I am
guaranteed it works!). The eeeBox does not have a CD-ROM drive, just USB
ports, audio, RJ45 and built in wifi. However I do have the USB stick I
installed from, I can try that. Or maybe I could down load the latest
XUbuntu ISO and do a live one with it??

Cheers, Rob

You can change the resolution in grub using the video= kernel command line parameter. It’s not massively well documented but something like this would do it:

video=VGA-1:[email protected]

Hi Rob,

this might help too?:

https://community.linuxmint.com/tutorial/view/877

They sort of have the right idea in that guide, but they haven’t handled multi monitor setups at all well. This was my attempt at trying to explain an xorg.conf https://wiki.ubuntu.com/PowerPCFAQ#How_do_I_configure_an_xorg.conf_file.3F

@robwlakes, this may help in configuring your desired settings:

https://wiki.debian.org/XStrikeForce/HowToRandR12

Hope you find this useful!

1 Like

I’ve not seen that debian link before. It’s got a great explanation on how to set up an xorg.conf; much clearer than the link I gave.

It could do with some updating though (last edited in 2012). No mention of KMS!

The modern way is not to set up an xorg.conf and it should be avoided whenever possible. People are seemingly incapable of writing them. It’s not an exaggeration to say that nearly every example on the internet has something wrong with it!

The request in the opening post was to setup the mode as early as possible. This can be done through KMS. As I’ve previously said in this thread there is not great documentation on it, but I believe the video line I gave is about right (not on a Linux machine to test at the mo sorry).

I’ve had a bit of a play with my own computer to make sure I’m not talking rubbish.

First thing to note is that although xrandr uses VGA1, on the kernel command line it is probably VGA-1. I’ve edited my first post accordingly.

The ‘M’ seems to be redundant since a new timing seems to be worked out regardless. I’ve left it in anyway.

The frequency rate has to be a whole number (xrandr insists on this too if you specify a -r option).

You can probably shorten the thing to video=VGA-1:1280x1024

And if you just had the one monitor video=1280x1024

Hope that helps!

Hi folks,

Good news and bad news. Good news: my main system has a DVI->DVI cable and swapping it over to the eeePC fixed it completely. The monitor stops complaining about not using its “ideal” resolution of 1280x1024, and all screens from grub to login and logout are at the desired resolution 1280x1024, or at least fill the screen correctly. So that is a relief, however in the search for a DVI-DVI, I found I had 3 more VGA-VGA cables, and now a fourth one seeing I will have to replace it too, gggrrrrr. The bad news is I have been taking up your time excessively. Though I think without your comments I would not have got to the bottom of it as quickly as I did. I have tried some of the suggestions about changing Grub configuration files and had trouble finding the exact files (mentioned by veggrower) to change, and in researching editing Grub found a lot of material that was well over my head. So I think I will be leaving the current patch/kludge (in the lightdm files) as it is, and just ordering a DVI->DVI cable instead, and ripping the patch out when the cable arrives. I would have liked to have verified your advice veggrower as it looks tantalising “right”, but I think it is a bit beyond my skill level, thank you for support. Thanks for your time too Wolfman.

Conclusion: Don’t trust simple DVI-VGA adapters, as I think it was the real villain in my setup. And now I get 7 possible screen settings in the menu, so it all seems good.

Cheers and thanks again, Rob

1 Like

Hi @robwlakes,

well at least we now know what was causing the problem!. :thumbsup: I have marked it as solved unless you have any other business?. :smiley:

Well it is remarkably easy to test.

Turn computer on
Immediately hold down shift to get the grub menu.
Hit the ‘e’ key to edit the entry
Scroll down to the long line starting with the word ‘linux’ and ending in “quiet splash $vt_handoff”
That line is the kernel command line and you can add stuff to the end of it (separated by a space).
Once you’ve added your stuff, ctrl-x to continue the boot!

It it works then you can edit files…

1 Like

Yes please Wolfman. I think the problem was probably the eeePC looking for VGA but being wired for DVI, and the converter was too simple. So the protocol was being mangled some how. Probably too much to expect UMate to handle it when I should have doing right thing really. Anyway now using eBay to debug it!!! Cheers and thanks, Rob

1 Like