Screen flickering only when on battery skylake 16.04

It’s an HP gaming notebook.
Heres the lspci
00:00.0 Host bridge: Intel Corporation Sky Lake Host Bridge/DRAM Registers (rev 07)
00:01.0 PCI bridge: Intel Corporation Sky Lake PCIe Controller (x16) (rev 07)
00:02.0 VGA compatible controller: Intel Corporation Skylake Integrated Graphics (rev 06)
00:04.0 Signal processing controller: Intel Corporation Skylake Processor Thermal Subsystem (rev 07)
00:14.0 USB controller: Intel Corporation Sunrise Point-H USB 3.0 xHCI Controller (rev 31)
00:14.2 Signal processing controller: Intel Corporation Sunrise Point-H Thermal subsystem (rev 31)
00:16.0 Communication controller: Intel Corporation Sunrise Point-H CSME HECI #1 (rev 31)
00:17.0 SATA controller: Intel Corporation Sunrise Point-H SATA Controller [AHCI mode] (rev 31)
00:1c.0 PCI bridge: Intel Corporation Sunrise Point-H PCI Express Root Port #5 (rev f1)
00:1c.5 PCI bridge: Intel Corporation Sunrise Point-H PCI Express Root Port #6 (rev f1)
00:1c.6 PCI bridge: Intel Corporation Sunrise Point-H PCI Express Root Port #7 (rev f1)
00:1f.0 ISA bridge: Intel Corporation Sunrise Point-H LPC Controller (rev 31)
00:1f.2 Memory controller: Intel Corporation Sunrise Point-H PMC (rev 31)
00:1f.3 Audio device: Intel Corporation Sunrise Point-H HD Audio (rev 31)
00:1f.4 SMBus: Intel Corporation Sunrise Point-H SMBus (rev 31)
01:00.0 3D controller: NVIDIA Corporation GM107M [GeForce GTX 950M] (rev a2)
07:00.0 Unassigned class [ff00]: Realtek Semiconductor Co., Ltd. RTS522A PCI Express Card Reader (rev 01)
08:00.0 Network controller: Realtek Semiconductor Co., Ltd. RTL8723BE PCIe Wireless Network Adapter
09:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8101/2/6E PCI Express Fast/Gigabit Ethernet controller (rev 0a)

I noticed that TLP was installed on MATE, perhaps it has something to do with that? How can I disable it?

I see you have Nvidia graphics, have you installed the drivers for it?. :smiley:

Not sure about TLP?. :confused:

It’s for laptop power management. I did systemct stop tlp.service but when I rebooted it started up again :frowning: It did solve my when i disabled it.
PS: I have all my drivers set up!

Look for the command (TLP) and see if it is in “Startup Applications” and take it out!. :smiley:

OK, so instead of systemct stop tlp.service I tried systemctl disable tlp.service and it didn’t start up when i rebooted. So far so good. I hope this fix sticks!
Thanks for the help :slight_smile:

1 Like

If your issue is solved, please tick best answer (marks as solved) so it helps others, thanks and good luck!. :smiley:

Ok so I turn on my laptop and was greeted with a black screen. Not sure if it was because of disabling TLP service but I’m unable to login to my accounts. I reinstalled and i’m back to where I started. Time to reinstall :frowning:

Mate-power-manager? Its unique to mate.

I believe Unity uses gnome-power-manager.

You could try running the gnome package? Maybe just stopping the service would show you something. I cannot say, all untried by me.

The autostart package is located at /etc/xdg/autostart/mate-power-manager.desktop

This appears to completely resolve the problem for me!

Screen flicker on 16.04. Screen goes black for an instant intermittently. Not happening previously on 15.10. System was upgraded from 15.10, not a fresh install from ISO.

tlp settings appear to affect the problem. This worked for me:

In file /etc/default/tlp, change the following settings to match.


Run $ sudo tlp start

That should fix it.

Lots of trial and error, but this has fixed the problem completely for me. If someone can tell me how the USB controller is causing the screen to flicker black intermittently, I’d love to understand it better. :grin:

If screen flicker comes back after suspend/resume cycle, try:

$ sudo tlp init restart

and if that doesn’t work, try:

$ sudo tlp init force-reload

There are two systemd services around tlp: tlp.service and tlp-sleep.service. It appears that tlp-sleep.service is responsible for managing events around suspend/resume, so maybe something with that isn’t working quite right. I think we can tweak the sleep service and make this fix more robust. If someone else doesn’t do it first, I’ll post a fix back here when I find one.

If you were bitten by this issue, you probably have this one too: "Crackling" sound whenever sound starts to play

This issue seems also to be linked to some mouse/keyboard freezes I’ve been seeing. Since I applied the fix given here, I have not seen the mouse and keyboard freeze again.

1 Like

Ok so this solved the issue until I log out or put the laptop to sleep as well. Still kinda annoying since I’m constantly closing my laptop lid. Hopefully this gets fixed soon. But thanks for the fix :slight_smile:

You are welcome. Glad I was able to contribute something back to the community.

1 Like

Same problem, intermittent flickering on screen, driving me nuts, only on battery and not with Ubuntu 16.04. I did the following, sudo apt-get --purge remove tlp, problem solved. A sledgehammer approach, but it seems to have worked.

If the fix I posted above doesn’t work, I would choose the “sledgehammer” approach in a heartbeat! The screen flicker, frozen mouse, hang-on suspend, problems adding and removing a second monitor, and shut-down problems are just maddening. But of all of those, the flickering was the worst!

Since I tweaked the tlp configuration, all those problems have gone away for me, and battery life is still decent.

1 Like

I agree completely with the tweaking. The sledgehammer is for those of us with no patience. What is surprising is that I’ve been running my laptop all day and the absence of TLP, doesn’t seem to have made a jot worth of difference in terms of extended battery life. Not exactly a scientific approach, but I still got my 4 hours ten minutes under normal usage.


Good point. How much does tlp extend battery life?

Because tlp appears to cause multiple problems, especially for newer hardware, should it even be installed on Ubuntu by default?

This is definitely something that, were I a new user without means for recourse, would send me distribution hopping. We’ve got this nearly perfect, stable, time-tested platform and the battery-saver is (at least for the moment) breaking it in multiple ways.

Problems I have traced back to tlp:

  • Intermittent - very annoying - screen flicker.
  • Every system sound produces a loud crackle or pop.
  • (suspected) Freeze on suspend.
  • (suspected) Hang on shutdown.
  • (suspected) Freeze of keyboard and mouse.
  • Inconsistent state after suspend/resume, intermittent.

Every problem I have had since I installed 16.04 appears to be caused by tlp. Just wow. Maybe you are right. Perhaps it would be best for people to remove it entirely.

I do hope someone who knows more about this can look into it and get a fix out fairly soon - I want what tlp promises. :smile_cat:


Thanks man, just deleted TLP and the problem seems gone.

1 Like

I have problems like this on my new Lenovo Thinkpad T460 and these are indeed serious issues. I have briefly read through this thread but I am not sure if a solution to this has been found and what to do about it.

Shortly after the login screen appears the screen flickers very obviously one or two times and when on battery I notice intermittent screen flicker of the kind you have described. It does not happen very frequently but frequent enough to make serious writing tasks on this machine impossible. I also noticed vertical blurry stripes covering the entire screen that appear randomly and usually stay there for about five minutes until they disappear. The crackling start-up sound I can also confirm.

Upgrade your operating system to 18.04.