Screen resolution probken pls help me 😭

There is a command, inxi -F which will show the specs of your pc.
Please paste but format it with </>

Info: dual core model: Intel Pentium G2020 bits: 64 type: MCP cache:
L2: 512 KiB
Speed (MHz): avg: 1823 min/max: 1600/2900 cores: 1: 2021 2: 1626
Flags: acpi aperfmperf apic arat arch_perfmon bts clflush cmov
constant_tsc cpuid cpuid_fault cx16 cx8 de ds_cpl dtes64 dtherm dts epb ept
erms est flexpriority flush_l1d fpu fsgsbase fxsr ht ibpb ibrs lahf_lm lm
mca mce md_clear mmx monitor msr mtrr nonstop_tsc nopl nx pae pat pbe
pcid pclmulqdq pdcm pebs pge pln pni popcnt pse pse36 pti pts rdtscp
rep_good sep smep ss ssbd sse sse2 sse4_1 sse4_2 ssse3 stibp syscall tm
tm2 tpr_shadow tsc tsc_deadline_timer vme vmx vnmi vpid xsave xsaveopt
xtopology xtpr
hi thats what your command show me i only have a cpu without a gpu pci card .i hope that helps you to help me :sweat_smile:
i want stay on MATE but it makes me really hard the resolution is not the only proble what i have my wlan usb dont work also ,
i have the driver and i have the manual to install it but the make order dont will go

and sry for my bad englsih im still learning
im from germany

Try this command, inxi -G

example: My system ( formatted with </> )

I want to see the Graphics section, which driver you use.

  Device-1: driver: bochs-drm v: N/A
  Display: server: v: driver: X: loaded: modesetting unloaded: fbdev,vesa
    gpu: bochs-drm tty: 156x45 resolution: 1024x768
  Message: GL data unavailable in console. Try -G --display

Device-1: Intel Xeon E3-1200 v2/3rd Gen Core processor Graphics
driver: i915 v: kernel
Display: x11 server: X.Org v: driver: X: loaded: modesetting
unloaded: fbdev,vesa gpu: i915 resolution: 1024x768~60Hz
OpenGL: renderer: Mesa Intel HD Graphics 2500 (IVB GT1)
v: 4.2 Mesa 22.0.1

and i use this tft =

So the monitor can do 1280x1024 but your system shows 1024x768, right?

Right thats my problem yes

And i dont know how i resolve it

You are using this driver: i915 but I don't know of a way to improve it.

You might look at the Display settings and verify the sync is 60 Hz.

The hz is 60 they are all right thats why im so confuse

But why i use a arch treiber for ububtu ? The i915 driver is an arch treiber if i look in the internet

Is ubuntu mate baset on arch ?

No, arch is totally different.

Ubuntu Mate as the name says is based on Ubuntu.

Hello Linux noob

What type of cable are you using to connect the computer to the screen?
Welche Verbindungskabel setzen Sie ein, VGA oder ein andere?

LINK: VGA-Anschluss – Wikipedia

1 Like

I use a vga cable.bjt it must go with vga on my windows 10 i can run ot with my full resolution only on ubuntu mate i cant

First check if your computer knows about this resolution by typing this into a terminal: xrandr

You will get an output more or less like this:

Screen 0: minimum 320 x 200, current 1920 x 1080, maximum 16384 x 16384
DisplayPort-0 disconnected (normal left inverted right x axis y axis)
DisplayPort-1 disconnected (normal left inverted right x axis y axis)
DisplayPort-2 disconnected (normal left inverted right x axis y axis)
HDMI-A-0 disconnected (normal left inverted right x axis y axis)
DVI-D-0 connected primary 1920x1080+0+0 (normal left inverted right x axis y axis) 521mm x 293mm
   1920x1080     60.00*+  50.00    59.94  
   1600x1200     60.00  
   1680x1050     59.88  
   1280x1024     75.02    60.02  
   1440x900      74.98    59.90  
   1280x960      60.00  
   1280x800      59.91  
   1152x864      75.00  
   1280x720      60.00    50.00    59.94  
   1024x768      75.03    70.07    60.00  
   832x624       74.55  
   800x600       72.19    75.00    60.32    56.25  
   720x576       50.00  
   720x480       60.00    59.94  
   640x480       75.00    72.81    66.67    60.00    59.94  
   720x400       70.08

and the line: 1280x1024 60.02 (or something like that) should be in the list.

If it is not in the list, the system doesn't offer you the resolution you need.
The most common reason is that the monitor's EDID is wrong (in other words, your monitor is lying to your computer)
The best thing to do is add the resolution parameters yourself so the system can use it.

Follow the instructions of the first answer here (just replace the values in the example for your own values) and also read the comments:

So to summarize the above link, theoretically the following terminalcommand should fix the problem permanently:

cat<<SCREENFIX > "$HOME/.xprofile"
xrandr --newmode "1280x1024_60.00"  109.00  1280 1368 1496 1712  1024 1027 1034 1063 -hsync +vsync
xrandr --addmode VGA-0 "1280x1024_60.00"

Afterwards, logout and login again to activate this fix.
(and use xrandr to check if it worked)

But please read the linked article first.

good luck :slight_smile:

Yay, thank you from the bottom of my heart, it worked, I copied everything you wrote and pasted it into the terminal, I only had to change the number of the vga, in my case it was from 0 to 1, I only had to set the monitor manually because the aspect ratios weren't right and the auto mode from the screen doesn't manage to adjust the image to the new resolution. your tip solved my problem thanks also to (alpinejohn) and (pavlos_kairis)
my question is when my monitor is lying my computer why he not lie to my windows 10 system ?

TL;DR: Your monitor is also lying to your ms-windows , but your ms-windows knows about it by 3rd party info... :wink:

In the first decennium of this century, many, if not most, manufacturers produced computerdisplays with a buggy EDID (which often couldn't be updated with new firmware)

It is awful to say but it is pretty mainstream for a 2004-display to have a faulty EDID.

Therefore, manufacturers almost always had a "driver" or "display definition file" for microsoft windows (something like "Crestron_23QA7_rB.inf") that contained corrections or a complete replacement for the EDID submitted values.

These were often part of windows' updates because the manufacturers would do anything to get their products supported by microsoft and gladly pushed every inf/driver/update to redmond.

In linux we have to work around these kind of bugs manually if the manufacturer made a botchjob of its EDID firmware. But as you can see, it is relatively simple to correct it, although it is a bit outside the comfortzone for some users.

It is a bit silly actually, when you think about it.
EDID was invented to avoid manual configuration or any driver/inf-file hell :grin:

How about today ?
Anyway, that era has ended luckily. Pretty much all displays nowadays have a good working EDID and problems like this are mostly of the past :slight_smile:

1 Like

wow, i didn't know that at all.
thank you for explaining it to me in such detail
you never stop learning