Screen scaling option

Please, I'm a Linux newcomer, and start it with Ubuntu-Mate (A friend recommendation).

I'm trying to setup my work environment. And got stuck with this issue.

My notebook has a 4k screen, and my secondary monitor has 2k. Somewhere I learn that I can use a scale factor the correct the differences between them, using settings, displays and scaling. However, I don't have the 'scaling´ options! In another place I learned that this option must be activated. How can I do that?

Hi :slight_smile:
Welcome on ubuntu mate community ! :slight_smile:

Did you try to play around Mate tweak with HIDPI ?

1 Like

This section of the online guide might be helpful in explaining how the scaling setting (HiDPI) works.




After I changed the Mate Tweak to HiDPI, the things were from annoying (different thing sizes in the two monitors) to very bad.

The only change in the system before this was the Mate-Tweak 'auto-detect' to 'HiDPI'.

1- The computer now only starts in the 'recovery mode';

2- With 'HiDPI', first thing, the compute didn't detect the 2.nd monitor if I start with it disconnected. If I start with the 2.nd monitor connected, the system uses it as main one and don´t recognize the build-in monitor;

3- With 'HiDPI', and only the build-in, the things in the screen are absurdly big

4- Changing back Mate-tweak to 'auto-detect' did not return the thins as before. The computer don´t restart unless using the recovery mode. It finds one or other monitor, never both. The Build in has wrong resolution and no option to change in in the settings.

Very frustrating!

How can I recover the previous setting conditions? Or need to start from scratch the system installation? Or how can I fix this using the terminal!

1 Like

Strange ...
Can you check and share some logs from /var/log/boot.log and /var/log/syslog ?

Please, how can I do that? (I´m a really newcomer... still struggling to understand the basic things!)

I tried to reach them using 'double commander', but can´t open or copy to another directory to open.

I tried by terminal using 'cd var\log' but got

guto@GutoAsus:~$ cd var/log
bash: cd: var/log: No such file or directory

Hi, Here you are the 'bootstrap.log' and 'syslog' content copied to txt files.

(Attachment bootstraplog_20210211 is missing)

(Attachment syslog_20210211 is missing)


I'm going through the same problem. Please see -

HiDPi is not a solution for me, just another problem. I'm still trying to find a real working solution. Good luck and if I find a work-around, I'll let you know.

If Mate Tweak is set to HiDPI, set it to either Auto-detect or Regular. Mine is set to Auto-detect. Reboot.

In terminal I set the following: xrandr --output eDP-1 --scale 1x1 My laptop screen is the eDP-1 part and that command was done both with no exterior VGA monitor connected and with my VGA-1 monitor connected.

Changed fonts dpi from 96 to 120 (96x1.25=120). This does work to get a lot of what you use up to a recognizable situation. You can use MATE-Tweak to change the font dpi or right-click on the desktop to get the Appearance Settings.

Appearance Preferences, Fonts tab, click on Details..., Font Rendering Details - dpi set from 96 to 120

Please let me know if this of any help at all. @Carlos_Augusto_Franc

1 Like

Dear Michael,


The system becomes 'nuts' after I changed the Mate Tweak to 'HiDPI'... after that, it could recognize one or another monitor, and with the wrong resolution, and, worst, only started with the recovery mode. Maybe the log files help to understand why.

So, I made a fresh install (and accidentaly wipe out the windows, hopefuly for good :slight_smile: ), and this time I used the terminal as you suggested.

The xrandr --output eDP-1 --scale 1x1 command did nothing at all.

Then I tried xrandr --output HDMI-1 --scale 2x2 and finally I got what I wished... both monitores (Notebook 4k, Secondary 2k) are 'synchronized' in the sense that the pointer and letters have about the same size in both.


I find out I had two issues... a minor one, the screen scaling, and a bigger one, the boot! So, I guess the problem of the computer no recognizing monitors, wrong resolution, etc., is due I was starting with the recovery mode, and not related with the Mate Tweak.

Monitor scaling is solved, thanks. The 'boot' problem is not yet!

Hi :slight_smile:
Try this :
sudo cat /var/log/boot.log | grep -i Error and type your password

If nothing is getting out, try this one sudo cat /var/log/boot.log and paste all since last boot :slight_smile:
We will figure out :slight_smile:

Hi Olek,

After many (many!) trials... I guess the guilty is the external monitor. I posted another question (don't know how to find it now!) asking about that.

With the build-in only, the systems runs fine and re-boots fine. When I connect the external monitor, the boot fails (black screen), and works only in recovery mode. When I connect the external monitor after initialization, it works fine (with video-noveau driver, not with Nvidia driver), but I need turn it off before re-boot... or 'black screen'...

When I re-boot with the external monitor 'on', the system uses it as primary one (ASUS logo, etc..) and than 'black screen'!


I can advise you to open a bug. I guess, many others will face the same issue and it would be nice developers to be aware of that.

You can do it here :

After my many trials, I found out that

xrandr --output HDMI-1 --scale 2x2

Works fine to scale the external monitor when I using the xorg-video-noveau driver, but it doesn´t work with the Nvidia 460 driver.

1 Like