Scrolling problem in mate 16.10 for intel hd

Solution is to revert back to intel sna:

sudo mkdir /etc/X11/xorg.conf.d/ echo -e 'Section "Device"\n Identifier "Card0"\n Driver "Intel"\n Option "AccelMethod" "sna"\nEndSection' | sudo tee /etc/X11/xorg.conf.d/20-intel.conf

That's probably linked to your specific hardware.
Check it out using:

inxi -CG