Sdb1 not mounting

Sdb1 is not mounting ?

#!/bin/bash
# 
# 
thunar /media/andy/MAXTOR_SDB1/Linux_Files/

Contents of fstab

# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
# / was on /dev/sda1 during installation
UUID=ac6bf8cc-5bbc-44a6-a92f-0745372729f7 /               ext4    errors=remount-ro 0       1
UUID=b3b0f384-9e2e-45f5-8995-932f1113f59d      /SDB1_Mountpoint   ext3

Blkid

/dev/sda1: UUID="ac6bf8cc-5bbc-44a6-a92f-0745372729f7" TYPE="ext4" PARTUUID="cafc53cc-01"
/dev/sdb1: LABEL="MAXTOR_SDB1" UUID="b3b0f384-9e2e-45f5-8995-932f1113f59d" TYPE="ext3" PARTUUID="000f0791-01"
/dev/sdb2: LABEL="MAXTOR_SDB2" UUID="8adebdf0-6bc3-4eee-8363-3e9440688d42" TYPE="ext3" PARTUUID="000f0791-02"
/dev/sdb5: LABEL="MAXTOR_SDB5" UUID="fd00f2d7-d666-4614-885d-5ace942dd3f6" SEC_TYPE="ext2" TYPE="ext3" PARTUUID="000f0791-05"

I always install arios automount. This forces all internal and external media to be auto-mounted at login without having to touch fstab.

You can get it here:

https://sourceforge.net/projects/arios/files/repo/arios-automount-1.0_all.deb/download

I installed it.

It does not work.

Which version of UM are you using?

I ask because I am using UM 16.04.1. I can also confirm it works on 16.04.2. But, I have not yet tried out any later short term support versions versions of UM.

In any event, if you need to remove it, type the following command:

sudo apt-get remove arios-automount

Ubuntu-Mate 16.04.2 LTS xenial

What is frustrating is that it used to work.

My system got corrupted and I had to do a re-install.

Sdb1 is where I backup up impt files.

Have you already tried all the steps outlined here?

https://wiki.archlinux.org/index.php/fstab#External_devices

First thing to look at is when it doesn’t mount.

I’ve seen systemd get into what looks like a wait-for-already-done and totally skip some mounts.

I’ve plugged a USB device into a port and had to wait like, 30-60 seconds because apparently it’s polling instead of accepting interrupts.

There are reams of things that can go wrong; to help you find the problem folks have to be able to hook it to something.

Does it mount when you issue a “sudo mount” in a command window? I’d say that’s the first place to check, because any problems there are going to ripple everywhere.

jmo fwiw.

The problem is fixed.

I do not remember all the steps I took.

But I think I made a mistake in the mount point in fstab.

After adding entries to fstab you can test it with
# mount -a

1 Like

Thanks for the good tip.

i tend to “Like” posts with good tips, so thanks @cccplex.