>sh file brings up GUI to run but then doesn't execute


I created a .sh file and allowed it to be an executable file via the permissions tab in properties.

When I double click on it , it brings up the GUI asking to run in terminal. cancel, display and run.

When the GUI opens up. I hear 2 beeps.

I click on run (and also have tried run in terminal) but nothing happens. (two beeps again)

BTW, when I click on run in terminal it displays the terminal windows for a second and then closes.

If I open up a terminal window and run the command line at the command prompt, it makes the connection to my server.

I'm using xfreerdp to connect to a Server 2019 terminal server.

Here's the script without details:

xfreerdp /f /d:domain /u:username /p:password /v:terminalserver

Like I said, works fine at the command prompt.

What am I missing when I try to execute from the desktop.

BTW, I'm new to this.



Which version of freerdp do you have? I got 2.2.0 and tested it on UM20.04, it worked.

I created a desktop file steve.sh, edited with pluma, xfreerdp /d:lan /u:user /p:pwd /v:win10 Save, Quit. Right click Properties, click on Permissions, allow executing file. Close.

Double-clicked on the file, clicked run, it connects to my win10 system.

1 Like

Hi Pavlos,

I am actually using Xfreerdp not freerdp. Not sure if there's a difference.

I'm trying to duplicate some Raspberry Pi's that are using Xfreerdp. They all seem to work. Their OS is 16.x but wasn't sure if that was a problem.

Like I said, when running from a command line it works fine. When I double click on the file it doesn't as stated above.

Also, OS 20.x works way too slowly on my Pi 3 B+, that's why I'm using OS 18.x


Hi Pavlos,

Looks like I found the answer.

The file must have been corrupted somehow. I created a new .sh file and it worked fine.

Thanks for the input.