Silverlight knocked out my video

At least I think it did. I installed Ubuntu on Sunday, and everything was running fine until I attempted to install Silverlight last night. I never got it to work properly, and now I can’t watch videos of any kind without my computer shutting down. I can’t use VLC to watch videos, and I can’t watch Youtube videos. The videos will play, but after about a minute or two my computer will just shut down.

I decided to go all day without playing any videos to make sure that’s what was shutting my computer down. Sure enough, my computer shut down after I started playing a video in VLC. I had hoped it was just Youtube, since I think that Silverlight did this, but it seems to be an issue for any kind of video that I try to play whether it’s online or not.

I attempted to uninstall Silverlight, but the terminal prompt told me that it wasn’t installed and asked me if I wanted to install two other things that weren’t in use. I did that, but I’m still having this problem. Does anyone know how I can fix this?

Here are the commands that I used to install:

sudo add-apt-repository ppa:pipelight/stable
sudo apt-get update
sudo apt-get install --install-recommends pipelight-multi
sudo pipelight-plugin --update
pipelight-plugin --enable silverlight

Have you tried ppa-purge?

http://packages.ubuntu.com/xenial/ppa-purge

Or the GUI for it?

https://launchpad.net/~webupd8team/+archive/ubuntu/y-ppa-manager?field.series_filter=xenial

I checked synaptic package manager, and it looks as though ppa-purge is already installed on my system. I installed y-ppa-manager, but I don’t think that the update completed. Here’s the message that I got at the end of the attempted update:

E: Could not get lock /var/lib/dpkg/lock - open (11: Resource temporarily unavailable)
E: Unable to lock the administration directory (/var/lib/dpkg/), is another process using it?

Does that mean that it didn’t update at all? I just did a quick search, and it doesn’t look as if Y PPA Manager was installed at all.

If you have ppa-purge installed, the removal code is:

sudo ppa-purge ppa:pipelight/stable

Means you still have your package manager open and you need to close it.

Yes! That worked. Thank you. I can now play videos again without my computer shutting down on me.

I also installed Y PPA Manager. It looks good. Although, I’ll have to learn a bit more before I can take full advantage of it. I didn’t even really know what a ppa was until I looked it up just now. And now that I’ve done that, I realize that I probably shouldn’t have been trying to install silverlight in the first place, at least not this early into my Ubuntu/Linux journey. For the time being, I think that I’ll stick to the official repositories until I get my bearings. Any recommendations on books that I should be reading or websites that I should look up to start to get a handle on the basics for maneuvering around Ubuntu/Ubuntu MATE, particularly the commands? I know there’s a lot of information here; I’m just looking for something that lays out the foundational stuff, not necessarily the latest tricks.

1 Like

https://ubuntu-manual.org/

https://help.ubuntu.com/lts/ubuntu-help/index.html

Enjoy :slight_smile:

1 Like

Thank you. :grinning:

No idea if it relevant to you but there is also this on the pipelight FAQ
https://answers.launchpad.net/pipelight/+faq/2485

— Ubuntu 13.10 / Mint 16 —
Some newer distributions like Mint 16 don’t install recommendations automatically anymore - this means that specific packages might be missing, which reduce the functionality (like that it only works in non-embedded mode) or lead to other unexpected behaviour. To fix this issue, install wine-compholio like:

sudo apt-get install wine-compholio --install-recommends

1 Like

Thanks for the information, dom. I’ll probably save it for later. For the time being, I’m leaving pipelight/silverlight alone. Not being able to play videos on my computer was really irritating, and I don’t really want to mess around with it right now. I don’t actually need silverlight to do what I need to do, because apparently what I need is native to the Chrome (not Chromium) browser. So, I just use the Chrome browser when necessary. I may try this out a bit down the road once I’ve gotten more comfortable with this new system, because Chromium and Firefox do still need it, and I have a general preference for not using the Chrome browser unless I have to.