Software updater not actively searching for updates in welcome screen

When attempting to download software updates on four computers, there seems to be no activity for active searching? I know there are updates but there not all coming down, if that makes sense.

Hi @DE541,

change your software sources download location and try again!:

Have tried multiple servers including the highest rated one with no active searching noted.
I will attempt later in the day when most people are up and around to trouble shoot.


I’m not sure what you mean. Please can you clarify?

If some updates are not appearing on all computers, even when it’s software lists are refreshed, it could be related to Phrased Updates.

Software Updater vs. Synaptic

No matter which server I try i am stuck here?

I will try synaptic.

There’s an Apt process stuck in the background, and only one process can access the Apt database at a time. Does this happen on every boot?

To stop the process, open System Monitor, and locate the process, it could be apt-get or aptd.

If it’s not there or the process is ran by root, you’ll need to run System Monitor as root to kill it:

  • Press ALT+F2
  • Type gksudo mate-system-monitor
  • Then end/kill the process.

Synaptic will not update also. And software Updater is now stuck?

Actually, it could be an old process that didn’t remove the lock. This will fix it - run this in a terminal:

sudo rm /var/lib/dpkg/lock
1 Like

That fixed it !



1 Like