Software Updater Problems

When I run the Software Updater if cannot see my internet connection. It reports that I am offline when this is not the case

Some release details may help us understand.

You may find details in this thread (the askubuntu link for example, plus others) useful.

Personally I'd open a terminal (CtrlAltT) and use the command sudo apt update to update my software lists and scan the output.

If any issues are there (wrong entries added etc, that can prevent automatic tools from working), you'll see the errors/warnings and can thus fix them. You don't have to use terminal to do this, I just find terminal faster (I don't have to go looking for that output in log files).

I'd also scan for any release details that don't match your unstated release.

1 Like

Try changing your server location to somewhere else - open Software and Updates and click on Download from: select new server like - Server for the United States - or Main Server

Tried changing server. Ran routine to choose best server. Herewith the output;
This error could be caused by required additional software packages which are missing or not installable. Furthermore there could be a conflict between software packages which are not allowed to be installed at the same time.
Transaction failed: Package dependencies cannot be resolved
The following packages have unmet dependencies:

gir1.2-pluma-1.0: Depends: gir1.2-gtksource-4 but it is not going to be installed
mate-optimus: Depends: gir1.2-ayatanaappindicator3-0.1 but it is not going to be installed
pluma: Depends: gir1.2-pluma-1.0 (= 1.26.0-0ubuntu1~focal2.0) but 1.26.0-0ubuntu1~focal2.0 is to be installed
Depends: pluma-common (= 1.26.0-0ubuntu1~focal2.0) but 1.26.0-0ubuntu1~focal2.0 is to be installed
Depends: libc6 (>= 2.14) but 2.31-0ubuntu9.2 is to be installed
Depends: libenchant-2-2 (>= 2.2.3) but 2.2.8-1ubuntu0.20.04.1 is to be installed
Depends: libgdk-pixbuf2.0-0 (>= 2.22.0) but 2.40.0+dfsg-3ubuntu0.2 is to be installed
Depends: libglib2.0-0 (>= 2.37.3) but 2.64.6-1~ubuntu20.04.3 is to be installed
Depends: libgtk-3-0 (>= 3.21.6) but 3.24.20-0ubuntu1 is to be installed
Depends: libgtksourceview-4-0 (>= 3.23.90) but it is not going to be installed
Depends: libice6 (>= 1:1.0.0) but 2:1.0.10-0ubuntu1 is to be installed
Depends: libpango-1.0-0 (>= 1.42.0) but 1.44.7-2ubuntu4 is to be installed
Depends: libxml2 (>= 2.7.4) but 2.9.10+dfsg-5ubuntu0.20.04.1 is to be installed

gir1.2-pluma-1.0: Depends: gir1.2-gtksource-4 but it iavailables not going to be installed - gir1.2-gtksource-4 is available through the Synaptic Package Manager

mate-optimus: Depends: gir1.2-ayatanaappindicator3-0.1 but it is not going to be installed - gir1.2-ayatanaappindicator3.0.1 is also available through the Synaptic Package Manager

``` sudo apt-get install gir1.2-ayatanaappindicator3-0.1 gir1.2-gtksource-4

Some things will not install with other thing so you may nee to install them indiviually

Chris thank you. I have successfully updated and upgraded. Just had to find the right Mirror.

What a great community. What a great OS. Restored my faith in humanity