[SOLVED] How do I disable X zapping? (Ctrl+Alt+Bksp)

Hello - sorry if this is posted in the wrong section.

I have tried repeatedly to disable killing X server using Ctrl + Alt + Backspace in the Keyboard settings but it keeps getting re-enabled straight away (is this a known bug?) Is there another way I can disable X zapping? I keep repeatedly killing the X server on accident and I really would like to disable it if possible.

Running Ubuntu MATE 14.04 with the Marco window manager.

Disabling CTRL+ALT+Backspace is quite simple, it requires some work in the terminal, but that shouldn’t be too difficult.

Open MATE Terminal via Applications > System Tools > MATE Terminal and type the following:

sudo pluma /etc/X11/xorg.conf

Type your password and paste the following into the the new file:

Section "Serverflags"
        Option "DontZap"        "yes"
EndSection

Save the file, exit Pluma and close the terminal. Now hit CTRL+ALT+Backspace once again and that will be the last time it will work.

If anyone knows a better way, please let us know.

1 Like

Thank you. Worked perfectly.