[SOLVED] No brightness control in Ubuntu 15.04 MATE 32-bit

On my laptop I can’t get the brightness to work it’s to bright.

 Acer Aspire 5733Z-4851

 Processor Intel Pentium P6200 / 2.13 GHz ( Dual-Core )
RAM installed size 4.0 GB
Hard Drive 500.0 GB - Serial ATA-300
Operating System Microsoft Windows 7 Home Premium 64-bit Edition
Display Type 15.6 in TFT active matrix
Max Resolution 1366 x 768 ( HD )
Graphics Processor Intel HD Graphics Dynamic Video Memory Technology 5.0
Optical Drive DVD±RW (±R DL) / DVD-RAM

I got it working. here is what I did.

https://wiki.ubuntu.com/Kernel/KernelBootParameters

had to add acpi_backlight=vendor

Can’t make it permanent every time I reboot I have to set it again.

Hi,

did you read this section “Permanently Add a Kernel Boot Parameter” in your link?. :smiley:

I got it working all I did was change sudo gedit /etc/default/grub to sudo caja /etc/default/grub

Thanks for your time wolfman :smile:

1 Like

I tried both acpi_backlight=vendor, video.use_native_backlight=1 and acpi_osi=Linux but none worked.

I can change the brightness through the power manager, though. Do someone know any energy widget for mate?

Edit: I just found that Mate already come with an brightness widget:

Having the same or similar issue with Mate 15.10 where brightness is reset to max on every startup. I’m not really experience with linux so the instructions on the first to second post were a bit out of my reach. Anyone care to help. Also my GRUB menu is very dim.

Its weird I cant get the Brightness adjustment tool/widget to work or change the Brightness, also I was unable to install Intel Graphics driver tool. I restarted and bam the brightness came back