[SOLVED] Prevent gksudo prompt from dimming screen

Hi all!

Anyone know a way to turn off the automatic dimming of all other windows when an auth window prompt opens? I understand the purpose to get users attention and focus on the auth window, it’s not a big deal but I do find it annoying.

Thanks!

And… I answered my own question!

gconftool-2 --type boolean --set /apps/gksu/disable-grab "True"
1 Like

The only problem with disabling the grab is that this is a security feature. It grabs the keyboard to prevent any other application (eg malware) from being able to listen in on your keyboard (and hence your administration password). Not a good idea to disable this!

Better to ensure security by doing the following
gconftool --type boolean --set /apps/gksu/force-grab "True"

You may also need the following to set “sudo-mode” instead of “su-mode”
gconftool --type boolean --set /apps/gksu/sudo-mode "True"

If you want to know more about gksu type
man gksu

Wow! Appreciate the response Eleanor, though I’ve moved on since 2015! Running 16.04.3 these days and somewhere along the way I just stopped noticing the screen dimming! :slight_smile: