SOLVED - Problem setting and saving the proper refresh rate on an nVidia card

I am running Mint Mate 18.1 with an nVidia 610GTS graphics card on my HTPC. I am using the proprietary nVidia driver. The HTPC is connected to a Sharp LCD TV with a refresh rate of 60hz. The driver is automatically detecting the resolution properly, but not the refresh rate. I change the refresh rate to 60hz in the NVIDIA X Server Settings. I click “apply” and the settings remains until reboot. Once I reboot, the driver defaults back to 50hz.

What do I need to do to to have the driver display at 60hz after reboot?

Start by having a look here:

and here:

2 Likes

Thank you for the reply. The linked articles led me down the path to a solution. The best solution was to add the following to my xorg.conf file:

Section "Screen" Identifier "Screen0" Device "Device0" Monitor "Monitor0" DefaultDepth 24 Option "Stereo" "0" Option "metamodes" "1920x1080_60 +0+0" Option "SLI" "Off" Option "MultiGPU" "Off" Option "BaseMosaic" "off" SubSection "Display" Depth 24 EndSubSection The TV now displays the proper refresh rate after reboot. Thank you again for the help!