[SOLVED]Wont boot after fresh install (flashing questionmark) G5 Powermac

So I have an old g5 Powermac sitting here and I wanted to put it to use. I booted from the live DVD, and everything appeared to go without a hitch. However, when I attempted to reboot into the newly installed system, I got a flashing apple finder logo with a question mark on it.
It gets to the yaboot screen, and defaults to booting linux. it immediately starts flashing a finder questionmark, and after a few seconds the system reboots again. It’s getting really frustrating, and I’m really not all that good with PowerPC hardware. It does not boot to a point where I can type in any parameters, so the recommendations from other threads to use them wont help here.

On another note, the live CD doesn’t detect any sound hardware ,but I guess that’s an issue that can be solved later.

I really would rather not have to install mac osx or the impossible to use MorphOS on this machine.

Is there anything I can do? lubuntu is also suffering from the exact same problems in this case as well.

Take a look here:

https://wiki.ubuntu.com/PowerPCFAQ

I hope it helps. :smiley:

From the number of reports like this there is clearly a problem with the installer and G5 macs (or all PowerPCs???..)

Did the installer crash at the end? Can you boot a live DVD and look on the installed partition and see if there is a /etc/yaboot.conf file? Can you post the contents here please?

To get the installed system to boot you can work through this https://wiki.ubuntu.com/PowerPCFAQ#I.27ve_lost_yaboot.2C_what_can_I_do.3F

Nope, though webkit crashes part way through the install (I doubt that has any effect on the install process). The install completed just fine. I tried it multiple times with and without downloaded updates. It prompts to reboot the system and behaves perfectly.

I just tried using “boot hd:2,yaboot” on the openfirmware screen but I got an error:
No S-ATA: port=0 can’t OPEN: hd:2,yaboot
I’m unsure of what this means.

the forum would not let me upload the yaboot.conf file, so I’ve simply pasted it below. Thank you for helping btw. I’m really not great with PPC hardware.

> ## yaboot.conf generated by the Ubuntu installer
> ##
> ## run: "man yaboot.conf" for details. Do not make changes until you have!!
> ## see also: /usr/share/doc/yaboot/examples for example configurations.
> ##
> ## For a dual-boot menu, add one or more of:
> ## bsd=/dev/hdaX, macos=/dev/hdaY, macosx=/dev/hdaZ

> boot="/dev/disk/by-id/ata-ST3500630AS_Q_9QG97WBZ-part2"
> device=/[email protected],f2000000/[email protected]/[email protected]/@ffffffffffffffff/@0
> partition=3
> root="UUID=58d82d00-b140-4e61-8f9e-0475543633c8"
> timeout=50
> install=/usr/lib/yaboot/yaboot
> magicboot=/usr/lib/yaboot/ofboot
> enablecdboot

> image=/boot/vmlinux
>     label=Linux
>     read-only
>     initrd=/boot/initrd.img
>     append="quiet splash"

> image=/boot/vmlinux.old
>     label=old
>     read-only
>     initrd=/boot/initrd.img.old
>     append="quiet splash"

There are a couple of bugs already reported on this - https://bugs.launchpad.net/ubuntu/+source/yaboot/+bug/1400030 and https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=784387

Neither really provide a step by step guide to overcoming this, although we can now tell that your device line is wrong in your yaboot.conf. I would also suggest you need to add an ofboot line too.

It’s a bit tricky because your powermac doesn’t use the ‘normal’ hd alias for its hard drive. I’ve no idea what powermacs use, but from the debian bug report sd1 is a possibility. So from openfirmware the command to load yaboot would be

boot sd1:2,yaboot

However, this still isn’t going to boot the system because of the broken device line in your yaboot.conf.

What I would suggest you do is this:

From a live 16.04 DVD mount your installed root partition For example,

sudo mount /dev/sda3 /mnt

Then edit your yaboot.conf:

sudo nano /mnt/etc/yaboot.conf

Delete the device line completely and replace it with the following two lines

ofboot=&device;:&partition;
nonvram

Then run the ybin command, but specify the yaboot.conf to use:

sudo ybin --config /mnt/etc/yaboot.conf -v

It’s a bit of a bodge, but this should get the system to boot provided your root partition is on the same hard drive as your bootstrap partition.

If you can figure out the alias or full ofpath to your hard drive then you can edit the device= and ofboot= lines appropriately and get rid of the nonvram line. I would recommend you try to do this. e.g.

device=sd1:
ofboot=sd1:2

3 Likes

My friend, I cannot thank you enough! That worked perfectly! Your instructions were very easy to follow! The system boots now, and everything appears to be fine! Thank you SO much again!

1 Like

I’m glad that worked! It might be a good idea to mark this thread as solved, since I think its going to be a recurring question.

3 Likes