Source no longer works

My source command no longer works.

[email protected] ~> source ~/.bashrc
END: command not found

# ~/.bashrc: executed by bash(1) for non-login shells.
# see /usr/share/doc/bash/examples/startup-files (in the package bash-doc)
# for examples
# DO NOT FORGET TO DO THIS AFTER EDITING THIS FILE.

# source ~/.bashrc


# If not running interactively, don't do anything
case $- in
    *i*) ;;
      *) return;;
esac

# don't put duplicate lines or lines starting with space in the history.
# See bash(1) for more options
HISTCONTROL=ignoreboth

# append to the history file, don't overwrite it
shopt -s histappend

# for setting history length see HISTSIZE and HISTFILESIZE in bash(1)
HISTSIZE=1000
HISTFILESIZE=2000

# check the window size after each command and, if necessary,
# update the values of LINES and COLUMNS.
shopt -s checkwinsize

# If set, the pattern "**" used in a pathname expansion context will
# match all files and zero or more directories and subdirectories.
#shopt -s globstar

# make less more friendly for non-text input files, see lesspipe(1)
[ -x /usr/bin/lesspipe ] && eval "$(SHELL=/bin/sh lesspipe)"

# set variable identifying the chroot you work in (used in the prompt below)
if [ -z "${debian_chroot:-}" ] && [ -r /etc/debian_chroot ]; then
    debian_chroot=$(cat /etc/debian_chroot)
fi

# set a fancy prompt (non-color, unless we know we "want" color)
case "$TERM" in
    xterm-color|*-256color) color_prompt=yes;;
esac

# uncomment for a colored prompt, if the terminal has the capability; turned
# off by default to not distract the user: the focus in a terminal window
# should be on the output of commands, not on the prompt
#force_color_prompt=yes

if [ -n "$force_color_prompt" ]; then
    if [ -x /usr/bin/tput ] && tput setaf 1 >&/dev/null; then
	# We have color support; assume it's compliant with Ecma-48
	# (ISO/IEC-6429). (Lack of such support is extremely rare, and such
	# a case would tend to support setf rather than setaf.)
	color_prompt=yes
    else
	color_prompt=
    fi
fi

if [ "$color_prompt" = yes ]; then
    PS1='${debian_chroot:+($debian_chroot)}\[\033[01;32m\]\[email protected]\h\[\033[00m\]:\[\033[01;34m\]\w\[\033[00m\]\$ '
else
    PS1='${debian_chroot:+($debian_chroot)}\[email protected]\h:\w\$ '
fi
unset color_prompt force_color_prompt

# If this is an xterm set the title to [email protected]:dir
case "$TERM" in
xterm*|rxvt*)
    PS1="\[\e]0;${debian_chroot:+($debian_chroot)}\[email protected]\h: \w\a\]$PS1"
    ;;
*)
    ;;
esac

# enable color support of ls and also add handy aliases
# This shows directories and files in different colors
if [ -x /usr/bin/dircolors ]; then
    test -r ~/.dircolors && eval "$(dircolors -b ~/.dircolors)" || eval "$(dircolors -b)"
    alias ls='ls --color=auto'
    #alias dir='dir --color=auto'
    #alias vdir='vdir --color=auto'

    alias grep='grep --color=auto'
    alias fgrep='fgrep --color=auto'
    alias egrep='egrep --color=auto'
fi

# colored GCC warnings and errors
#export GCC_COLORS='error=01;31:warning=01;35:note=01;36:caret=01;32:locus=01:quote=01'

# some more ls aliases
alias ll='ls -alF'
alias la='ls -A'
alias l='ls -CF'

# Add an "alert" alias for long running commands.  Use like so:
#   sleep 10; alert
alias alert='notify-send --urgency=low -i "$([ $? = 0 ] && echo terminal || echo error)" "$(history|tail -n1|sed -e '\''s/^\s*[0-9]\+\s*//;s/[;&|]\s*alert$//'\'')"'

# Alias definitions.
# You may want to put all your additions into a separate file like
# ~/.bash_aliases, instead of adding them here directly.
# See /usr/share/doc/bash-doc/examples in the bash-doc package.

if [ -f ~/.bash_aliases ]; then
. ~/.bash_aliases
fi

enable programmable completion features (you don't need to enable

this, if it's already enabled in /etc/bash.bashrc and /etc/profile

sources /etc/bash.bashrc).

if ! shopt -oq posix; then
if [ -f /usr/share/bash-completion/bash_completion ]; then
. /usr/share/bash-completion/bash_completion
elif [ -f /etc/bash_completion ]; then
. /etc/bash_completion
fi
fi

Sets my prompt for Every mate terminal session

export PS1='\[email protected]\h \w> '

To use, countdown Number of seconds

countdown 300 for 5 mins and countdown 7200 for 2 hours

countdown 180 for 2 mins

countdown() {
start="$(( $(date '+%s') + $1))"

while
time=$(( $start - $(date +%s) ))
[ $time -ge 0 ]

do
printf '%s\r' "$(date -u -d "@$time" +%H:%M:%S)"
sleep 0.1
done
{
for ((volume = 35; volume <= 45; volume += 2)); do
amixer -D pulse sset Master ${volume}% > /dev/null
sleep .5
done

} &

cvlc --play-and-exit "/usr/share/sounds/My_Sounds/Alarm-sound-buzzer.mp3" > /dev/null 2>&1
#set back to original volume
amixer -D pulse sset Master %65
printf "Tea is ready.\n"
}

Is your hostname just the number 7 ? hostname should start with an alpha character.

it does start with an alpha char.

[email protected] ~>

your prompt is \u @ \h \w > ( username is andy, hostname is 7, working dir is ~ )

Ok, so how does that help me?

I do not understand.

It is quite possible that something in the .bashrc you posted is not ok, some quote, some bracket. I will not go through the whole code to find the mistake. Start with a basic .bashrc and test the command, source .bashrc As for why the hostname should NOT be a number, I leave it as an exercise.

Hi totally unskilled here but is this the same as in the discussion?
Just looking to understand and learn. Thanks in advance.

"You'll need to make sure your hostname meets the standards for FQDNs (Fully Qualified Domain Names). The ASCII letters a – z, the digits 0 – 9, and the hyphen ('-') are the only acceptable characters (however, the first character cannot be a hyphen). You may also find it necessary (or useful) to include the domain name, in which case you would also use dots (dots) to separate the host name and the domain name (and the top-level domain)."

Taken from here:
https://codepre.com/en/como-cambiar-el-nombre-de-host-en-ubuntu-22-04-lts.html

I will look for a basic .bashrc.

I replaced .bashrc with a virgin copy. No change?

Thanks for all the help from everyone.

I will just live with the issue.

you can find the default bashrc in /etc/skel/.bashrc

1 Like

I found the problem.

I found an END on a line by itself in .bash_aliases.
I removed it.

Problem solved. :slight_smile:

1 Like