Status of Ubuntu MATE 18.04 for Raspberry Pi 3 B & B+?

system
software

#81

I looked at it, first tried the ubuntu image, didnt work, then copied the files from XUBUNTU - it booted

didnt knew the password was ubuntu, took a few tries.

Desktop booted, after a brief BLANK/BALCK Screen - then the top/bottom panels were BLANK and never loaded any panels.

sudo raspi-config works, but didnt do some of the options I tried to change, Enable SSH, VNC and setting WIFI through it.

Right clicked on TOP bar, got the context menu, ADDED panels, Main menu and Network - WiFi worked, connected to network.

But now moving back to Pi 3B and Mate 16.04 - as I need to run ROS… :frowning:

Can check more and test more if you have some specific things to check.


#82

can I ask if there will be an official release iso, one that installs, operates just the same as that for 16.04

for 18.04, raspberry pi model b

before 16.04 runs out of support (april)


#83

According to the Arch Wiki, you can blacklist kernel modules. This means you could blacklist the experimental VC4 driver kernel module and continue using the generic kernel and GRUB2. I may take a look when I have time. Since debootstrap is failing me, I’ll use a premade Ubuntu ARM64 filesystem instead.

https://wiki.archlinux.org/index.php/Kernel_module#Blacklisting

http://cdimage.ubuntu.com/ubuntu-base/bionic/daily/current


#84

I’ll probably ditch raspi3-firmware in future releases of my Ubuntu images and switch to using u-boot and the linux-raspi2 kernel.


#85

Count me in on testing as well. Over the next week my Raspberry Pi Model 3B should arrive, and I can take it from there. Have a mouse and keyboard that work via USB and bluetooth audio I want to test with it.


#86

Welp. I’ve tried flashing the Ubuntu Mate beta using etcher, and it just boots to the rainbow screen of doom. Maybe someone more educated can help me somehow. I’d love to test, and just got the latest model. Raspbian runs fine through BerryBoot, and NOOBS ran on it as well. I don’t know why it’s not booting Ubuntu Mate or Windows 10 IOT Core when flashed directly to an SD card.


#87

You only get the rainbow screen for a few seconds on the 3B. If it’s hanging, you’re using a 3B+.


#88

It is hanging and yes I do have the 3B+. Is there any way around this behavior? Or something you plan to do to fix it? That way I can test.


#89

#90

safe to assume that it’s solved now?


#91

Any idea how to show arm64 packages by default?


#92

Had to delete all the files on the BOOT partition for MATE as there wasn’t enough free space and then I copied over all the stuff from the Xubuntu image. Now, there’s another problem. Bluetooth adapters don’t get picked up, nor does audio work. Only output I see is “dummy audio” output. Not good. Anything I can do to help debug? Also the whole UI tends to lock up even with compositing disabled, usually after using Firefox for a bit. Maybe some performance optimizations are also needed in time? By the way, USB keyboard and mouse combo works fine. Basic applications work pretty well save some issues with mate panel applets crashing when low on memory, which I guess can be expected. An update - I gave my micro SD card a generous 8GB swap partition and made sure to turn swap on in Gparted, and Firefox still freezes a lot. As in freezes the whole install.


#93

Also I’ve encountered another issue of sorts. I managed to create a swap partition, but it does not toggle to swapon at boot. Can I do anything to remedy this? It does not seem to stop the UI hard freezes, though. Is there anything I can do to debug the hard freezes of the UI? Can’t even get to a virtual terminal when they happen, which is quite often for me.


#94

Official server images for pi 2 and 3b/3B+ (armhf and arm64) http://cdimage.ubuntu.com/ubuntu-server/bionic/daily-preinstalled/current/

18.04.2 is released on the 7th Feb. Will appear here http://cdimage.ubuntu.com/releases/bionic/release/

No sign of a Mate image for the pi.


#95

I’m glad to hear that the Pi 3 is officially supported in Ubuntu Server now. I just don’t understand why there needs to be separate armhf images for the Pi 2 and 3. Debian provide prebuilt u-boot binaries for the Pi, including an armhf one that works on both the Pi 2 and 3.

https://packages.debian.org/buster/armhf/u-boot-rpi/download

I’ve tried the ARM64 server image and it uses u-boot to boot the Pi. However, on kernel update, raspi3-firmware overwrites the config.txt telling the Pi’s bootloader to boot the kernel directly instead of through u-boot.

As for the ‘eval: en: not found’ bug with keyboard-configuration, that seems to be fixed now, allowing me to resume building Ubuntu and Debian images for the Pi 3.


#96

This doesn’t happen anymore.


#97

That’s good to know.


#98

I donated $20 to the Ubuntu MATE project. I wonder if there's somewhere I can suggest the funds are redirected for Pi 3 development. Hopefully, there's a way to get the funds to reach here so development is a bit easier. EDIT: Added another $15 so that should subsidize most of the cost of the board. At least that's what I hope my donation goes to. On IRC ATM hoping I can get through to someone. Development would be so much easier if codexec actually had the device. I don't make much money myself, and I know this probably only helps a very small amount, but if you're interested I'm hoping the funds I sent in reach you or someone else interested.


#99

Awkward.

There are no recent accounts published as far as I am aware, but it used to be the case the U-M was well funded, the majority of donations coming from pi downloads.

Lack of funds is not the problem. It is trivial to produce a ubuntu mate image that works on the pi 3B+. What is required is more community involvement, particularly in how to deal with/replace the large number of packages in the ppa.

Throwing money at something is not always the answer, and I would argue has partly caused the stagnation of Ubuntu/Ubuntu-mate on the pi.


#100

It's not hard to create an Ubuntu image for the Pi 3B+. Simply use linux-raspi2, flash-kernel, and then instead of using raspi3-firmware (which is incompatible with flash-kernel), simply copy the latest bootloader files to the boot partition. Then copy the vmlinuz and initrd files from /boot to the boot partition, rename them to vmlinuz and initrd.img respectively, and edit the config.txt to boot from the kernel and initrd. flash-kernel will automatically copy the latest kernel and initrd to the boot partition in the future.