Sub-process /usr/bin/dpkg returned an error code (1)


#1

Hi to all, I am not able to solve the problem.
Thanks a lot in advance for your help.

Simone

[email protected]:~$ sudo apt-get update
[sudo] password di simone:
Trovato:1 http://it.archive.ubuntu.com/ubuntu xenial InRelease
Trovato:2 http://ppa.launchpad.net/ubuntu-mate-dev/welcome/ubuntu xenial InRelease
Trovato:3 http://it.archive.ubuntu.com/ubuntu xenial-updates InRelease
Trovato:4 http://it.archive.ubuntu.com/ubuntu xenial-backports InRelease
Trovato:5 http://archive.canonical.com/ubuntu xenial InRelease
Scaricamento di:6 http://security.ubuntu.com/ubuntu xenial-security InRelease [102 kB]
Recuperati 102 kB in 0s (148 kB/s)
Lettura elenco dei pacchetti… Fatto
[email protected]:~$ sudo apt-get dist-upgrade
Lettura elenco dei pacchetti… Fatto
Generazione albero delle dipendenze
Lettura informazioni sullo stato… Fatto
Calcolo dell’aggiornamento… Fatto
I seguenti pacchetti sono stati installati automaticamente e non sono più richiesti:
linux-headers-4.13.0-36 linux-headers-4.13.0-36-generic linux-image-4.13.0-36-generic linux-image-extra-4.13.0-36-generic
Usare “sudo apt autoremove” per rimuoverli.
I seguenti pacchetti saranno aggiornati:
avahi-dnsconfd
1 aggiornati, 0 installati, 0 da rimuovere e 0 non aggiornati.
È necessario scaricare 0 B/14,1 kB di archivi.
Dopo quest’operazione, verranno occupati 0 B di spazio su disco.
Continuare? [S/n] s
(Lettura del database… 288797 file e directory attualmente installati.)
Preparativi per estrarre …/avahi-dnsconfd_0.6.32~rc+dfsg-1ubuntu2.1_amd64.deb…
Job for avahi-daemon.socket canceled.
dpkg: attenzione: il sottoprocesso vecchio script di pre-removal ha restituito lo stato di errore 1
dpkg: viene provato lo script dal nuovo pacchetto…
Job for avahi-daemon.socket canceled.
dpkg: errore nell’elaborare l’archivio /var/cache/apt/archives/avahi-dnsconfd_0.6.32~rc+dfsg-1ubuntu2.1_amd64.deb (–unpack):
il sottoprocesso nuovo script pre-removal ha restituito lo stato di errore 1
Si sono verificati degli errori nell’elaborazione:
/var/cache/apt/archives/avahi-dnsconfd_0.6.32~rc+dfsg-1ubuntu2.1_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
[email protected]:~$


#2

See Avahi-dnsconfd update bug and workaround for workarounds until a proper fix has been released.


#3

See also:

:smiley:


#4

Now does it work. Thanks a lot