Swap file coming to 17.04 by default

I don’t know if its here or not or if this may be Ubuntu only. I upgraded my 16.10 to 17.04 which had a swap partition.

1 Like

I think it’s new installs only.

Yes I agree, just not sure if the Ubuntu flavors will also get this. When alpha comes out I plan on a fresh install and then I’ll see whats up. Unless you already have it on your install.

No, I haven’t installed 17.04 yet. I’m also curious about the same thing.

1 Like

Hi @anon42388993,

if you already have a swap partition it won’t really be of any use to anyone, I tend not to worry about swap but set up a partition nonetheless!.

I read about this new fangled swap thingy on:

1 Like

Hey wolfman :slight_smile:

Actually nothing new about a swap file, its always been a option.

Later :wave:

1 Like

Yep @anon42388993,

it was an option but most modern PC’s have so much RAM that it isn’t really necessary any more although the create a swap partition stills shows up when installing without first creating a swap partition!. AHHH, the good old days!. :smiley:

1 Like

They say the proof is in the (Christmas) pudding?! No, well? (sounds like Noel :smiley:)

Just performed a test clean install for you, using a Zesty image from few days ago, as long as no swap partition exists, then, same as with Ubuntu, a default 1GiB swap file is automatically created.

Benefit of a swap file, can be resized afterwards depending on needs.

Screen captures...

PS: Reason you see a 8.4MB (8MiB) partition, drive is set-up as gpt, so a tiny GRUB partition is required.


Good to know, thanks :slight_smile:

Hi !
I thougt Ubunut mate 17.04 will not use a swap partition when RAM >4GB.
My new installation (encrypted with default partition settings) creates a swap partition,

see /etc/fsatab:

/dev/mapper/ubuntu--mate--vg-root / ext4 discard,noatime,nodiratime,errors=remount-ro 0 1

/boot was on /dev/sda1 during installation

UUID=64f59812-dfa3-4df9-8417-6bad1fa84ebf /boot ext4 defaults 0 2
/dev/mapper/ubuntu--mate--vg-swap_1 none swap sw 0 0