Swap not available : ( unless swapped on manually after every boot

after all the joy i’ve had with ubuntu mate "> 3 months " i decided to install another linux dist along side with mate but then changed my mind and deleted it and now i’m facing a problem whenever i reboot my system i notice swap is off unless i swap it on manually in gparted …

/dev/sda1: UUID="0a30fdea-082c-45e7-ba31-6fce897367b2" TYPE="ext4" PARTUUID="00054b56-01"
/dev/sda2: UUID="f0e06947-efba-4a36-bb42-d254ccbea6fb" TYPE="swap" PARTUUID="00054b56-02"
/dev/sda3: UUID="d40a811a-d5ca-432d-add7-fbe46ea73c47" TYPE="ext4" PARTUUID="00054b56-03"

i searched for the problem but can’t find something similiar since my fstap seems to be okay !

# /etc/fstab: static file system information.
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
# / was on /dev/sda1 during installation
UUID=0a30fdea-082c-45e7-ba31-6fce897367b2 /               ext4    errors=remount-ro 0       1
# /home was on /dev/sda3 during installation
UUID=d40a811a-d5ca-432d-add7-fbe46ea73c47 /home           ext4    defaults        0       2
# swap was on /dev/sda2 during installation
UUID=ddb5ace1-7c19-4ca9-a5db-ae571403310a none            swap    sw              0       0

Looks like the UUID of your swap partition changed.
I’m not an expert or anything but I think you have to replace the UUID in your fstab:



didn’t notice ! i’ll try it

it did fix it :slight_smile: thanks

1 Like