Terminal window is way too small

A few days ago a friend installed Ubuntu 16.04 MATE on my laptop. I have
since encountered a problem with very small terminal windows, too small to
be useful.

The problem first manifested when I associated files ending in .txt with the
editor jstar (a variant of joe). When I double click a txt file, jstar
does come up, prepared to edit the specified file, but the terminal window
is very small, about 3-3/4" by 2-3/4". The text font in the window is also
quite small.

The default terminal profile I am using specifies a font of size 12 and a
window of size 82 columns by 43 rows. When I launch a terminal manually
from the Application Panel, a window of the right size comes up, with the
right font size. If I then invoke jstar manually, everything is fine.

I wasted a bit of time trying to figure out if jstar is the problem, but I
have satisfied myself that it is not. I wrote the following simple C++

#include <iostream>
using namespace std;

int main()
    cout << "This is output by test-tiny.cpp" << endl;
    cout << endl;
    cout << "Press Enter to quit:";

    char c[10];
    cin.get(c, 2);

I compiled it with this command:

g++ -o test-tiny test-tiny.cpp

Then I created a Launcher specifying the test-tiny executable as an
Application in Terminal. When I click on this launcher, a window opens and
test-tiny is run. But the window is tiny. So jstar has nothing to do with
the problem. For some reason MATE seems to be ignoring the default terminal

BTW, everything works fine on Ubuntu 12.04.

I tried using the --geometry option as described here:


But tiny windows still come up.

Any help will be appreciated.

Software Developer

Hi @rhouse, Here’s a discussion on what I think is your problem:

Basically, I’m sure you’re getting the tiny xterm terminal instead of mate-terminal. My link solution is one way to fix it that I use. Yeah, by default, xterm is teeny!


Thank you very much! The hard link solved the problem.

1 Like

I love it when a plan comes together. Thanks for confirming. :relaxed:

I tried to get someone to admit xterm was installed in 16.04 just to band-aide this upstream frustration issue. If xterm weren’t installed, it breaks getting any terminal at all! That was the condition in 14.04.

Thanks Bill. A small lifesaver this was…