The New 16.04 Gnome software center not working

@wolfman + @Robgoss When I searched on
I found this bug already reported on launchpad

1 Like

Oh ok thanks for letting us know

Please mark solved somewhere in this thread so others may benefit by not troubleshooting

Just to add, installing third party DEB files were also not working:

1 Like

I think the problems with Gnome Software is being worked on and is still not functioning correctly. Yeasterday I checked it out, especially the Installed portion and all seemd to be ok. Now, after reading @lah7 post I checked again and it never finished just produce a blank screen… I had updated and upgraded my computer minutes prior
syslog entries follow

Apr 28 10:08:45 Dell-1749 org.gnome.Software[2627]: (gnome-software:7894): GsPlugin-WARNING **: Failed to get changelog for ubuntu-mate-desktop version 1.154 from Cannot connect to destination
Apr 28 10:08:45 Dell-1749 org.freedesktop.Notifications[2627]: ** (mate-notification-daemon:14169): WARNING **: Couldn't connect to accessibility bus: Failed to connect to socket /tmp/dbus-0Fa9o5rU99: Connection refused
Apr 28 10:08:48 Dell-1749 dbus[782]: [system] Activating service name='org.freedesktop.fwupd' (using servicehelper)
Apr 28 10:08:49 Dell-1749 org.freedesktop.fwupd[782]: (fwupd:14187): Fu-WARNING **: Failed to coldplug: UEFI firmware updating not supported
Apr 28 10:08:49 Dell-1749 dbus[782]: [system] Successfully activated service 'org.freedesktop.fwupd'

I added these to the existing bug

I can only suggest that people change their software sources download location and switch to a different server mirror then update again!. :confused:

For anyone that doesn’t know how to do that, see the update guide:

IMHO since there’s an active bug it’s probably best not to fiddle with this and accept results.
Command line, and Software Boutique [version 16.04.10-xenial1.2] all seem to work for me without changing server source.

Synaptic returns these 2 errors, however Synaptic worked when I re-installed MATE Welcome
W: Signature by key 4CCA1EAF950CEE4AB83976DCA040830F7FAC5991 uses weak digest algorithm (SHA1)
W: There is no public key available for the following key IDs:

1 Like

There’s more than one issue with Software Center … read about here

1 Like

Hi Peter,

despite having marked this as solved, the problem came back to haunt me this morning!. :frowning:

Guten tag @wolfman - Interesting I just launched the tool to superficially test and it worked perfectly for me today.

I wonder if the fact that I did a manual update / upgrade earlier had any affect?

1 Like

Guten Morgen Peter!. :smiley:

Funnily enough, I just switched the box on, looked down on the bottom panel and there was Software Updater" blinking away, I clicked on it and it updated no problem, I did run updates yesterday so maybe they have fixed it now?. :smiley:

1 Like

Are you talking about the Software updater for Ubuntu mate16.04?

If you are talking to me Rob then yes!, I do mean the software updater in UM16.04!. :smiley:

I tried switching to the main ubuntu server in software sources and now it is working

1 Like

Yes, as far as I know it disappears once you’ve clicked it. Is there any way to unsubscribe to Welcome updates by another click? Not that I want to unsubscribe, but I just like to have the option to unclick a previous click. :grin:

Hi @maro,

you can't unsubscribe in the normal sense as far as I am aware, what you can do is open Control Centre > Administration > Software & Updates > Other Software and untick the boxes relating to Welcome or remove them completely, I have unchecked Opera, Google Chrome and Google earth because of the annoying messages I keep getting!:

Thanks @wolfman
This is very helpful.

1 Like

I am having the same issue. Here is all I get when it starts. You also cannot type in text as it either detects multiple keystrokes or erases everything.

I have a different experience … the software center is working perfectly for me now.
Perhaps you could try accessing menu System->Administration>Sowtware Updater
and try again after updating

Hello and welcome, is your system up to date I do believe it’s a work in progress mines seems to working better after a few update but it still loading slow

1 Like