Thunderbird with HUGE icons/emoticons (MATE 18.04)

(I am a longtime Ubuntu user but first time Ubuntu MATE user)
I installed Ubuntu MATE 18.04 on a separate partition.
After installing and configuring Thunderbird I see Huge icons/emoticons in the message listing pane for some e-mails. (see attachments)
For comparison I have added a similar screenshot made on Ubuntu(Unity) 17.10. In this screenshot you can see the icons/emoticons with the, expected, normal size.
Both, Ubuntu MATE 18.04 and Ubuntu/Unity 17.10 are running Thunderbird 52.6.0(64-bit)

Is this a problem I can solve by myself? I couldn't find any setting to correct the icon/emoticon size.



what are your formatting settings like?, they should be on default when you started the app!:


Having looked at mine, it only happens with messages from eBay so it may well be a problem related to their mail links/formatting but I am not sure?. :frowning:

Hi Wolfman,

Thanks for your reply.
The mentioned settings on both environments (Mate, Unity) are the defaults as showed above.
I have the same problem with MATE 18.04 on a other system (Laptop).

As I understand well, you have the same problem with some of your e-mails. I don’t think its directly related to these specific mails because the messages are listed correct in Unity. (It depends of course if the subject field contains such characters/icons.)

I also tried Thunderbird on Ubuntu KDE 17.10 and there it also is displayed correct, like the second part of my uploaded picture.

Perhaps there are some missing/wrong localization files?
(on request I can forward these e-mails for testing)

I copy-passed some of these icons into a separate e-mail (subject fields + body). The icons are too huge in both, subject and body.
Also copied it into text file with Pluma texteditor. In this editor the icons are sized correctly



I suspect it may be to do with with what theme we are using but I am not sure?, I removed all the eBay messages from my lnbox list and it doesn’t happen to any of the other mails?, I have also run updates again so something may have changed in the meantime as everything seems fine now?. :smiley:

Can you please tweak your appearance settings? (System -> Preferences -> Look & Feel -> Appearance) and try various themes other than Ambiant-MATE so we can narrow where the problem is coming from, or indeed if this is a theme issue or a thunderbird issue?

@wolfman, I ran the today’s updates with no effect. And of course, I will not see the huge emojis after deleting the messages with these emojis in the subject, but this will not really solve the problem…

@ouroumov, I tried all the different themes available but unfortunately without any effect on the huge emojis. I even rebooted the system several times and used two different user accounts on this system. But without any effect. Even changing the font/size does not help.

I will try to install Ubuntu 18.04 (Gnome shell) on a separate partition and see what happens.

1 Like

I ran Thunderbird on 2 different PC’s, one without the mails from eBay and the other untouched, in both cases the systems are fully up-to-date and the emojis are fine now so it may well be as @ouroumov suggests; a problem with the themes?. :smiley:

If possible, it’d be useful if you can save one of the mails as an .eml file (Save as…) and attach it to a post here.

@ouroumov, I have tried to attache a tar.gz file. But I am not allowed to attach other files than jpg, jpeg, png, gif, ico, svg, xcfbz2, xcfgz.
I tried to add the extension jpg to .tar.gz but that does not work either…

After installation of Ubuntu 18.04 (Gnome Shell) I see the same problem with huge icons in Thunderbird.
As already mentioned I don’t have this problem on Ubuntu 17.10 (Gnome Shell / KDE). So it looks like it has something to do with a change in Ubuntu 18.04 base in combination with Thunderbird 52.6.0…

I am on 18.04 and no longer have the problem, I suggest that you try playing around with Mate Tweak and disable compositing as I still think it is theme related!. :smiley:

@wolfman, thanks for helping to solve this problem. Unfortunately disabling compositing ( MATE Tweak -> Windows -> Window manager -> Marco (No compsitor)) did not help. Also tried different themes again, without any improvement.
But I will not give up trying other settings! :slight_smile:

1 Like

@ouroumov: Here are two sample .eml files. I hope you can use them and hopefully track the problem.

Confirmed in TB here with exactly the same setup, patched to tonight.

An easy reproducible way to demonstrate this is to subscribe to the Noticing newsletter (which is worth doing in any case). The newsletter contains an emoji in the subject line which displays at about 20 times the size it should be.

Interestingly, I have come across this issue in a couple of Android apps as well …

1 Like

I found a workaround by removing the fonts-noto-color-emoji
(apt remove --purge fonts-noto-color-emoji)

But this is not ideal because some emoji are now displayed as a kind of ‘not displayable’ character.

1 Like

@Wimpy please take a look at this when you have the time, I don’t know where this is coming from. :x

Please can someone file a bug for this on Launchpad as affecting thunderbird, firefox and fonts-noto-color-emoji and post a link here.

Those of you affected please the mark that bugs as “affects me”.

1 Like

I think that this bug is already reported now for U18.04.
Bug #1759286 (and Bug #1761844 is probably a duplicate)
Bug #1759286 gives as a solution to install Thunderbird 57.0b2 from Thunderbird PPA.

I have not yet tested it.

I have tested it. The problem is solved with TB 57.0b2. The icons are displayed in the right size.

(first reinstalled fonts-noto-color-emoji)
sudo add-apt-repository ppa:mozillateam/thunderbird-next
sudo apt-get update
sudo apt-get upgrade