Touchpad not working/recognised


I’m quite new to Ubuntu Mate and have ran into an issue which I think may relate to all flavours of Ubuntu, at least for my laptop (Packard Bell Easynote)

I installed Ubuntu Mate 16.04 on a spare laptop. The touchpad is not working. When I check it doesn’t appear to be recognised. I tested an earlier version of Mate with the same results and also other flavours of Ubuntu based on the 14.04 release.

I tried

-sudo apt-get upgrade
-sudo apt-get dist-upgrade
-sudo apt-get install xserver-xorg-input-synoptics

This didn’t help unfortunately. I also attempted to reset the touchpad drivers using the below with no effect.

sudo modprobe -r psmouse
sudo modprobe psmouse proto=imps

I happened to have a usb stick containing Cloud Ready, Neverwares Chromium OS and when testing in a live session, the touchpad works without issue.

Any idea/help would be appreciated!


Hi @Conor,

have you checked the FN + whatever key it is on your model to see if you have it deactivated?. :smiley:

1 Like

Haha, I wish that was it!

Sorry I should have mentioned that. I have tried the correct key with FN to make sure it wasn’t disabled this way. But the FN + key does nothing at all and it still remains non functional.

Try changing your software sources download location and updating again!:

1 Like

Thanks. I’ll give that a shot and let you know how it goes :slight_smile:


1 Like

good Help Me Thank you

Go into bios and change touchpad settings from advanced to basic