Trouble with 'wpa_supplicant' and 'rsyslogd'

Dear all, from the date 14.04 released I’m using Ubuntu MATE as my primary OS. I was very happy with it’s performance until now. Lately I’m finding that when I switch off WiFi button on my Dell Vostro 1500 laptop the CPU usage will be 88%. Process ‘wpa_supplicant’ consumed 58% and process ‘rsyslogd’ consumed 30%. But however, when I switch on my WiFi every thing will be normal; my CPU usage will be around 5%. Any help from learned members is greatly appreciated. Thanks in advance.

rsyslogd is a logging demon, it sounds like wpa_supplicant is having problems when the device “disappears” (as it’s a hardware switch) and outputs a lot of messages to the log. Might want to keep an eye on disk space in case the logs are piling up.

When this happens and goes back to normal again, what do you see in /var/log/syslog?

Respected lah7, thanks for the prompt reply. I use BleachBit at regular intervals, so haven’t faced any issue with log. Now ‘syslog’ is really big file to deal with, if your kindself guide me to what to look at will be great help.

If you don’t mind uploading the log during the time frame this happens, we’ll be able to take a look at what the problem is, if there is a fix/solution, and if there any other processes involved.

Pastebin: http://pastebin.com/

I can’t say I’m an expert with networking, but another user or myself may point you in the right direction after we see what the log’s rambling at us. :wink:

My dear Lah7, thanks again for fast and prompt reply. The file weighs somewhere around 400 MB so will do it when I’m free. (I’m running post to pillar for some registration work with Government)

400 MB is indeed very large - If the log contains a lot of repetitive lines, it could easily compress down to a few MBs.

Instead, I’d suggest creating a new log so we only capture the output caused by turning the Wi-Fi off via the hardware switch.

If you don’t mind the terminal:

cd /var/log
sudo mv syslog syslog.bak
sudo touch syslog

This renames syslog to syslog.bak (just in case, or it could be deleted)
touch creates a new empty file in its place.

After you turn off and on the switch that triggers this issue, and the CPU is back to normal, paste the log as-is or compress it and upload to a service like Dropbox or Google Drive.

Respected lah7
This is the log when WiFi switch is off:
Sep 27 20:00:02 Vostro-1500 wpa_supplicant[1089]: Could not set interface wlan0 flags (UP): Operation not possible due to RF-kill
Sep 27 20:00:02 Vostro-1500 wpa_supplicant[1089]: nl80211: Could not set interface ‘wlan0’ UP
Sep 27 20:00:02 Vostro-1500 wpa_supplicant[1089]: Could not set interface wlan0 flags (UP): Operation not possible due to RF-kill
Sep 27 20:00:02 Vostro-1500 wpa_supplicant[1089]: WEXT: Could not set interface ‘wlan0’ UP
Sep 27 20:00:02 Vostro-1500 wpa_supplicant[1089]: wlan0: Failed to initialize driver interface
Sep 27 20:00:02 Vostro-1500 NetworkManager[897]: [1443364202.80373] [nm-supplicant-interface.c:997] interface_add_cb(): (wlan0): error adding interface: wpa_supplicant couldn’t grab this interface.
Sep 27 20:00:02 Vostro-1500 NetworkManager[897]: dbus_g_proxy_cancel_call: assertion ‘pending != NULL’ failed
Sep 27 20:00:02 Vostro-1500 NetworkManager[897]: (wlan0): supplicant interface state: starting -> down
Sep 27 20:00:02 Vostro-1500 NetworkManager[897]: Trying to remove a non-existant call id.
Sep 27 20:00:02 Vostro-1500 wpa_supplicant[1089]: Could not set interface wlan0 flags (UP): Operation not possible due to RF-kill
Sep 27 20:00:02 Vostro-1500 wpa_supplicant[1089]: nl80211: Could not set interface ‘wlan0’ UP
Sep 27 20:00:02 Vostro-1500 wpa_supplicant[1089]: Could not set interface wlan0 flags (UP): Operation not possible due to RF-kill
Sep 27 20:00:02 Vostro-1500 wpa_supplicant[1089]: WEXT: Could not set interface ‘wlan0’ UP
Sep 27 20:00:02 Vostro-1500 wpa_supplicant[1089]: wlan0: Failed to initialize driver interface
Sep 27 20:00:02 Vostro-1500 NetworkManager[897]: [1443364202.81397] [nm-supplicant-interface.c:997] interface_add_cb(): (wlan0): error adding interface: wpa_supplicant couldn’t grab this interface.
Sep 27 20:00:02 Vostro-1500 NetworkManager[897]: dbus_g_proxy_cancel_call: assertion ‘pending != NULL’ failed
Sep 27 20:00:02 Vostro-1500 NetworkManager[897]: (wlan0): supplicant interface state: starting -> down
Sep 27 20:00:02 Vostro-1500 NetworkManager[897]: Trying to remove a non-existant call id.

This is the log when WiFi switch is on:
Sep 27 19:26:56 Vostro-1500 kernel: [ 19.408688] wlan0: associated
Sep 27 19:26:56 Vostro-1500 NetworkManager[942]: (wlan0): supplicant interface state: associating -> associated
Sep 27 19:26:56 Vostro-1500 NetworkManager[942]: (wlan0): supplicant interface state: associated -> 4-way handshake
Sep 27 19:26:56 Vostro-1500 wpa_supplicant[1378]: wlan0: WPA: Key negotiation completed with 5c:f9:6a:26:84:ec [PTK=CCMP GTK=CCMP]
Sep 27 19:26:56 Vostro-1500 wpa_supplicant[1378]: wlan0: CTRL-EVENT-CONNECTED - Connection to 5c:f9:6a:26:84:ec completed [id=0 id_str=]
Sep 27 19:26:56 Vostro-1500 NetworkManager[942]: (wlan0): supplicant interface state: 4-way handshake -> completed
Sep 27 19:26:56 Vostro-1500 NetworkManager[942]: Activation (wlan0/wireless) Stage 2 of 5 (Device Configure) successful. Connected to wireless network ‘ABBS’.

Thank you for posting the log. After looking up these errors, as I suspected, your particular network hardware is not properly informing the kernel after you toggle the wireless on/off.

This particular command outputs the soft/hard block states:

rfkill list

I apologize I won’t be much use here in actually fixing it, but I can suggest two workarounds:

  1. Disable networking from the network applet before switching Wi-Fi off from the hardware switch.

  2. If not running it already, try Ubuntu MATE 15.04 (in a live session) to see if a newer kernel resolves this bug. If it resolves the high CPU consumption and you’re using 12.04 LTS, you could install a newer kernel with the LTS Enablement Stack.

By any chance, do you have additional drivers available for the wireless?
(System → Preferences → Hardware → Additional Drivers)

Respected Lah7, at first I would like submit my appreciation for the time spent by you to try solve my issue. Please do not apologize, as suggested by you I will try the second method, or safely wait for Ubuntu MATE 16.04 LTS to be released.
By the way is it safe to delete /var/log/installer/syslog because the whole file is 1.4 GB and I think Mr. BleachBit is not doing any thing about it.

No worries. A newer kernel is usually a safer bet for these sort of issues, as starting to install different packages to important components like wpa_supplicant could potentially break the wireless on the system altogether. In your case, it’s working fine until the hardware switch is triggered.

Deleting huge logs in /var/log is OK, you’ll need to be root to do this.

sudo rm /var/log/<file>

My dear lah7 it is just to update the thread. Installing Ubuntu 15.10 have resolved the issue. Your words “newer kernel is usually a safer bet for these sort of issues” holds good. Thanks a lot friend.

1 Like