Trying to upgrade from 17.10 to 18.04


#1

Hello everyone I was wondering how would i upgrade my system from 17.10 to 18.04, I tried to follow the instructions on this page https://ubuntu-mate.org/blog/ubuntu-mate-bionic-final-release/ but for some reason it’s not working. I would hate to have to do a clean installation

Thanks so much


#2

Same for me. I tried the two suggested methods. The first one opened the box but stated that my software is up to date (it isn’t) and the second did nothing.


#3

If it doesn’t offer you to upgrade, try to force the Software Updater:

update-manager -cd

#4

Thanks, worked for me.


#5

Well, it doesn’t bring any result for me, here.

Should I try what’s in there ?
https://linuxconfig.org/how-to-upgrade-to-ubuntu-18-04-lts-bionic-beaver

Or is there any of the proposed lines that should be made slightly different ?

What works for Ubuntu should work UM…!

W


#6

Have you tried the command I gave?

You can try the solutions given in the page you link to though I’d be surprised if they worked better.


#7

I’ve tried to force the upgrade but that didn’t work also. Not sure why were not able to upgrade


#8

Tried your line - no result
Tried the solutions given in the page I linked and got a ‘no new release found’
!!!

Note: well… seems I got it by doing: sudo do-release-upgrade -d
it’s in the works now

Now I get this:
Updating repository information
No valid sources.list entry found
While scanning your repository information no entry about artful could be found.
An upgrade might not succeed.


#9

Don’t go further, it can’t find the Artful repos. Either your sources.list has already been changed by trying to upgrade, or it’s empty (which would be bad).

First, check the content of the sources.list:

pluma /etc/apt/sources.list

What do you have in the file?

Also, does cat /etc/lsb-release tell you that you’re on Ubuntu 17.10 or 18.04 (or other)?

What’s the version of the kernel given by the command uname -a ?


#10
# See http://help.ubuntu.com/community/UpgradeNotes for how to upgrade to
# newer versions of the distribution.
deb http://archive.ubuntu.com/ubuntu artful main restricted

## Major bug fix updates produced after the final release of the
## distribution.
deb http://archive.ubuntu.com/ubuntu artful-updates main restricted

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team. Also, please note that software in universe WILL NOT receive any
## review or updates from the Ubuntu security team.
deb http://archive.ubuntu.com/ubuntu artful universe
deb http://archive.ubuntu.com/ubuntu artful-updates universe

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu 
## team, and may not be under a free licence. Please satisfy yourself as to 
## your rights to use the software. Also, please note that software in 
## multiverse WILL NOT receive any review or updates from the Ubuntu
## security team.
deb http://archive.ubuntu.com/ubuntu artful multiverse
deb http://archive.ubuntu.com/ubuntu artful-updates multiverse
deb-src http://archive.ubuntu.com/ubuntu artful multiverse

## N.B. software from this repository may not have been tested as
## extensively as that contained in the main release, although it includes
## newer versions of some applications which may provide useful features.
## Also, please note that software in backports WILL NOT receive any review
## or updates from the Ubuntu security team.
deb http://archive.ubuntu.com/ubuntu artful-backports main restricted universe multiverse
deb-src http://archive.ubuntu.com/ubuntu artful main restricted universe

## Uncomment the following two lines to add software from Canonical's
## 'partner' repository.
## This software is not part of Ubuntu, but is offered by Canonical and the
## respective vendors as a service to Ubuntu users.
deb http://archive.canonical.com/ubuntu artful partner
deb-src http://archive.canonical.com/ubuntu artful partner

deb http://archive.ubuntu.com/ubuntu artful-security main restricted
deb-src http://security.ubuntu.com/ubuntu artful main restricted
deb http://archive.ubuntu.com/ubuntu artful-security universe
deb-src http://security.ubuntu.com/ubuntu artful universe
deb http://archive.ubuntu.com/ubuntu artful-security multiverse
deb http://archive.canonical.com/ artful partner
deb https://dl.bintray.com/resin-io/debian stable etcher
deb http://archive.ubuntu.com/ubuntu artful-proposed universe main multiverse restricted

and

DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=17.10
DISTRIB_CODENAME=artful
DISTRIB_DESCRIPTION=“Ubuntu 17.10”

and

Linux *** 4.13.0-39-generic #44-Ubuntu SMP Thu Apr 5 14:25:01 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux


#11

When it asked me to say (Y) to continue I mistyped…so the process stopped
so I started the “sudo do-release-upgrade -d” anew, but got the result above

p.s. maybe I should just reboot and try again…

W


#12

Please update your message and put the outputs (especially the content of the sources.list) as code (the sixth icon in the message toolbar). It’s to be sure that the file is valid as it seems ok except that it misses the # at the start of some lines and I’m not sure if it’s because the forum removed them (it’s likely) or if there’s a real problem with the file.


#13

I also get a
** (pluma:27985): WARNING **: Could not load Pluma repository: Typelib file for namespace ‘Pluma’, version ‘1.0’ not found

Don’t know what you mean - I posted the result of what I get


#14

Select the text in your post and press the </ > button on editing toolbar. This will format it as code so that all the characters are visible, lines aren’t wrapped, etc.


#15

Done

I tried again the " sudo do-release-upgrade " and it tells me " no new release found "


#16

I keep getting the same thing. Everything tells me there are no updates/no new release available apart from “sudo do-release-upgrade -d” which seems to be doing something now.


#17

Your sources.list is a bit of a mess, especially as you have the Proposed repo active (which you should never have) but it’s ok overall, I don’t understand why the upgrade says it can’t find artful repos or a valid sources.list.

Just in case, edit it as root:

sudo pluma /etc/apt/sources.list

And replace all its content by what I’ve put there: https://pastebin.com/j1k86xWz
Then, reload the sources:

sudo apt-get update

And try again to upgrade. Do you have the same error messages?


#18

Unrelated, but I got this:
E: The repository ‘http://ppa.launchpad.net/videolan/stable-daily/ubuntu zesty Release’ does not have a Release file.
N: Updating from such a repository can’t be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.


#19

To: sudo do-release-upgrade
I get:
Checking for a new Ubuntu release
No new release found.

To: sudo do-release-upgrade -d
I get:
Checking for a new Ubuntu release
Upgrades to the development release are only
available from the latest supported release.


#20

And with the command I gave above?

update-manager -cd