Trying to upgrade from 17.10 to 18.04


#21

It says:
“Failed to download repository information” and once OK, it gives “No software updates available”


#22

Maybe open a new dedicated thread so we can look into this more thoroughly.


#23

Anther thread also talks about difficulty or impossibility to upgrade.

Should I resolve scrapping what I have and reinstall from the ISO ? This means many hours for me…

I’ll stick with my 17.10 for a few days.


#24

If you can reinstall from scratch (backup your data first), it would be the easiest solution. But I suggested opening a dedicated thread for your setup so that we can look in details into the repos used, eventual PPAs, tidy the packages installed from the Proposed repository and such. Not sure it will work in the end but we can try.


#25

I too am having difficulty solving this conundrum!
I’ve tried everything in this thread, and nothing works at all.
I’m guessing that the problem may lie at MATE’s end and not ours.
Perhaps we just need to give it a couple days and see what happens.

If I have to re-install from the ISO, is there a way I can back up all my settings in this current install?
I just got this thing whipped into the shape I want it, I’d hate to have to start over from scratch!


#26

I also tried everything that could find on this community threads or elsewhere and nothing works at all. GUI, terminal, right left and center.
As KP (above) says, the problem may lie at MATE’s end and not ours, or maybe we need to give it a couple days and see what happens.
Like him, I’d hate to have to start over from scratch (!!) if having to re-install from the new ISO.

Note: I haven’t found on the 18.04 ISO I’ve installed on a flashdrive, any option to ‘upgrade’ by using it. The only option results into erasing the existing 17.10 , i.e. start-over.


#27

You may have to wait a few days to upgrade with software manager. From release notes:

Upgrading from Ubuntu 16.04 LTS or 17.10

Upgrades from 17.10 will not be enabled until a few days after 18.04’s release. Upgrades from 16.04 LTS will not be enabled until a few days after the 18.04.1 release expected in late July.


#28

This also from release notes:

There are no offline upgrade options for Ubuntu Desktop and Ubuntu Server.

Should apply to the flavors as well, since they use many Ubuntu packages.


#29

Web trapped. Thanks Spider.

Any idea how many days ? Maybe nobody knows, yet.


#30

Hey Folks!
Just a quick update: I finally got my system to Upgrade to 18.04 yesterday!
I went into my Control Center and clicked into Software & Updates then over to the Updates Tab.
Under “Notify me of a new Ubuntu version” I selected: “For any new version” in the dropdown menu.
(I had previously set it up only for Long Term releases, which covers 18.04, or so I thought!)
I then ran Software Updater and it notified me of the new version a few seconds later.
I was fully upgraded and ready to roll in about 2 hours!
(I still have a few minor bits & bobs to sort out, but so far it gets a thumbs up from me!)
Your mileage may vary, but might be worth a try if you’re still not there yet!


#31

If you did it in the same way than me:

  1. Install update-manager-core
  2. /etc/update-manager/release-upgrades is set to 'lts'
  3. do-release-upgrade

Then cat /etc/lsb-release , maybe it had already upgraded to Ubuntu18.04, this error seems to be cosmetic.