[Tutorial] - Activate OpenGL driver for ubuntu mate 16.04

drivers

#21

Hi,
Never because opengl 3.x+ is not support by GPU hardaware of vc4.
So you will have never more than opengl 2.1 with hardware acceleration so no support of vulkan neither.


#22

I edited the tutorial for kernel black screen issue.
It works with last beta kernel too but you have to edit some ld.conf files, there is some problem between opengl driver and some specific rpi librairies.
I read something interresting about enabling a mix driver (opengl and binary blob) at the same time.
I need to test it, I will report feedback here so we could have OpenGL driver and omxplayer working both :slight_smile:


#23

Thank you for your prompt help and updating the tutorial…


#24

You are welcome :slight_smile:


#25

Well I see a problem with GL driver, when it is activated the raspicam doesn’t work, I found a thread where it was advised to use dtoverlay=vc4-fkms-v3d instead of dtoverlay=vc4-kms-v3d. I tried the same on raspbian pixel and it worked, and I will testing the same with ubuntu too(Tested now but not working :(, same black screen issue) , but what I wanted to know is it advisable on ubuntu … So in nut shell in Ubuntu if we enable graphics driver then raspicam will not work :frowning:


#26

Hi,
Yes rapsicam don’t work with the new opengl driver because his support is not implemented yet by Eric Anholt (main opengl driver developer).
It is implemented only in the binary blob old driver with a lot of other things.
So Eric added a mixed mode to use opengl driver and a part of the binary blob waiting to implement all stuff in his driver. That is the fkms option.
Fkms support is only with latest firmware version and that cause a black screen.
But I know how to use it :wink:

sudo nano /etc/ld.so.conf.d/00-vmcs.conf
Add a # on the begging of line save and quit.

Now update to last firmware version :
sudo rpi-update

Then make change in config.txt for fkms and reboot !

Done.

Sorry to be quick I type it on my phone !

Enjoy


#27

This is a nonexistent directory, instead use this:

sudo nano /etc/ld.so.conf.d/00-vmcs.conf

#28

Thanks I edited my post. Sorry for the mistake I posted from my phone by memory without my pi :wink:


#29

Thanks for this tutorial. It would of taken me an age to find that fbturbo conf file that stops the system booting. Compiz is working pretty well!


#30

I fail to get an image showing on my TV screen. I see the the rainbow screen but then my TV alternates between “wide” and “auto” modes, not displaying anything. The Raspberry successfully booted as I am able to log in via SSH.

$ uname -a
Linux raspberrypi 4.9.13-v7+ #974 SMP Wed Mar 1 20:09:48 GMT 2017 armv7l armv7l armv7l GNU/Linux

$ cat /boot/config.txt | tail -n5
# OpenGL driver and GPU memory
dtoverlay=vc4-kms-v3d
gpu_mem=128

$ ls /usr/share/X11/xorg.conf.d/99*
/usr/share/X11/xorg.conf.d/99-fbturbo.conf.bak

Did anyone face this problem? Solved it?


EDIT

Solved it by using the stable kernel:

 sudo BRANCH=stable rpi-update

#31

Is this driver still in beta? Also, was wondering, does adding dtoverlay=vc4-kms-v3d disable the old driver?


#32

After enabling OpenGL with the instructions from the tutorial (above) I had success after the first boot only. On second boot, I get the rainbow screen followed by a black screen. Oddly if I plug the pi into another display, a have success upon the first boot only. Second boot provides a rainbow screen followed by black screen. If I change back to the original display the same success and failure.

I read abhisek-mishra’s post (above), “…use dtoverlay=vc4-fkms-v3d instead of dtoverlay=vc4-kms-v3d”

I made this change to the /boot/config file, and all seems to be working for me now.

I did not do any of aworan’s suggestions regarding editing the ld.so.conf… or updating the firmware.


#33

I’m excited to try this out but I have a few questions concerning the following:

Disable the old driver, open a terminal then :

cd /usr/share/X11/xorg.conf.d/
sudo mv 99-fbturbo.conf 99-fbturbo.conf.bak

Pardon me for being terribly new to this as I just got my Pi3 last month.
But…
Which driver(s) should be disabled, and where from?
I also cannot locate the 99-fbturbo.conf file, even within xorg.conf.d

Thanks in advance!


#34

Now you didnt nedd to follow my tutorial anymore.
Wimpy add a tool to do it automaticly !
Open a terminal then type :
sudo raspi-config
Then in Advanced options -> Activate opengl driver and reboot :wink: