[Tutorial] - Install working chromium 50

internet

#1

Hi,
There is a problem since months with chromium, standard installation don’t work !
There is an error launching chromium and it don’t start !
A bug report is open in launchpad but it isn’t fixed yet.
This is a workaround to install and have chromium working !

Remove chromium installation

sudo apt-get remove chromium-codecs-ffmpeg-extra chromium-browser chromium-browser-l10n

Next we have to download chromium for ubuntu 14.04, I know it is strange but the package for ubuntu 14.04 work with ubuntu mate 16.04 !
(I try to do a diff between the two version package but it is in the binary files).

Download the packages from launchpad

wget https://launchpad.net/~canonical-chromium-builds/+archive/ubuntu/stage/+build/9739240/+files/chromium-codecs-ffmpeg-extra_50.0.2661.102-0ubuntu0.14.04.1.1117_armhf.deb https://launchpad.net/~canonical-chromium-builds/+archive/ubuntu/stage/+build/9739240/+files/chromium-browser_50.0.2661.102-0ubuntu0.14.04.1.1117_armhf.deb http://launchpadlibrarian.net/259414466/chromium-browser-l10n_50.0.2661.102-0ubuntu0.14.04.1.1117_all.deb https://launchpad.net/~ubuntu-security/+archive/ubuntu/ppa/+build/8993250/+files/libgcrypt11_1.5.3-2ubuntu4.3_armhf.deb

Install the packages
> sudo dpkg -i libgcrypt11_1.5.3-2ubuntu4.3_armhf.deb
> sudo dpkg -i chromium-codecs-ffmpeg-extra_50.0.2661.102-0ubuntu0.14.04.1.1117_armhf.deb
> sudo dpkg -i chromium-browser_50.0.2661.102-0ubuntu0.14.04.1.1117_armhf.deb
> sudo dpkg -i chromium-browser-l10n_50.0.2661.102-0ubuntu0.14.04.1.1117_all.deb

Block updates on chromium packages

sudo apt-mark hold chromium-codecs-ffmpeg-extra chromium-browser chromium-browser-l10n

Then launch chromium :slight_smile:

Note - When a new working release will be available you can unblock packages updating with :

sudo apt-mark unhold chromium-codecs-ffmpeg-extra chromium-browser chromium-browser-l10n
sudo apt-get upgrade

Enjoy,

Aworan


[Tutorial] - Chromium & Youtube in 720p (and other videos websites)
[bug report] chromium crashes on start
About install google-chrome
Instalacion de chromium
Tips, Tutorials and Guides Index
Chromium segfaults
I can't intall google chrome on mate 16.04
Chromium crashes when starting. Segfaults?
#2

Hi, I tried it and it works thanks !

How will we know when a new version fixes the problem ?


Firefox Sync doesn't work properly in MATE
#3

I will try when new version of chromium go out and I will post here if it work :wink:


#4

Thanks, much appreciated ! :wink:


#5

Hi, i tried it , it works good.
thanks a lot!!


#6

sorry … i try to look a video on youtube and the sound work unlike the images…


#7

I don’t understand.
What do you mean ?
You have audio and not video ? Or audio and video are not synchronized together ?


#8

i have audio but not video…


#9

@aworan Hi, would upgrading to Ubuntu 16.04 solve the issue ?


#10

Thank you for the workaround! However it would be nice to be able to keep up with the latest versions of chromium. Do we know what could fix the underlying issue? Is this something that needs to be fixed in Chromium or in the Ubuntu Mate environment? Where could we solicit some support to get it done?


#11

Hi,
I will update links for version 51.
I don’t know what the problem is really because the build for 14.04 works and not the 16.04. I think the source code is very close … Just different build … A bug is open at launchpad but not solved yet. I see some people saying it would work on next releases … I hope it will


#13

@Adrien_Corre try with “–disable-gpu” - that brought the video for me


[Tutorial] - Flash Player for Chromium and Firefox
#14

Any progress on this? Can the latest Ubuntu Chromium build build be installed and will it work with Flash?


#16

Amazing!! It’s working now. Thanks a lot!


#18

I can’t seem to get Chromium to finish installing, I’m new to linux and as such am not understanding these error messages, can someone help interpret them for me?

sudo dpkg -i chromium-browser_50.0.2661.102-0ubuntu0.14.04.1.1117_armhf.deb
(Reading database … 165872 files and directories currently installed.)
Preparing to unpack chromium-browser_50.0.2661.102-0ubuntu0.14.04.1.1117_armhf.deb …
Unpacking chromium-browser (50.0.2661.102-0ubuntu0.14.04.1.1117) …
dpkg-deb (subprocess): cannot copy archive member from ‘chromium-browser_50.0.2661.102-0ubuntu0.14.04.1.1117_armhf.deb’ to decompressor pipe: unexpected end of file or stream
dpkg-deb (subprocess): decompressing archive member: lzma error: unexpected end of input
dpkg-deb: error: subprocess returned error exit status 2
dpkg: error processing archive chromium-browser_50.0.2661.102-0ubuntu0.14.04.1.1117_armhf.deb (–install):
cannot copy extracted data for ‘./usr/lib/chromium-browser/libs/libblink_web.so’ to ‘/usr/lib/chromium-browser/libs/libblink_web.so.dpkg-new’: unexpected end of file or stream
Processing triggers for desktop-file-utils (0.22-1ubuntu5.1) …
Processing triggers for bamfdaemon (0.5.3~bzr0+16.04.20160824-0ubuntu1) …
Rebuilding /usr/share/applications/bamf-2.index…
Processing triggers for mime-support (3.59ubuntu1) …
Processing triggers for man-db (2.7.5-1) …
Processing triggers for hicolor-icon-theme (0.15-0ubuntu1) …
Errors were encountered while processing:
chromium-browser_50.0.2661.102-0ubuntu0.14.04.1.1117_armhf.deb

dpkg: dependency problems prevent configuration of chromium-browser-l10n:
chromium-browser-l10n depends on chromium-browser (>= 50.0.2661.102-0ubuntu0.14.04.1.1117); however:
Package chromium-browser is not installed.
chromium-browser-l10n depends on chromium-browser (<< 50.0.2661.102-0ubuntu0.14.04.1.1117.1~); however:
Package chromium-browser is not installed.

dpkg: error processing package chromium-browser-l10n (–install):
dependency problems - leaving unconfigured
Errors were encountered while processing:
chromium-browser-l10n


#20

Trying to work through the root cause of this issue and I’m arriving at un-met dependencies. Thoughts on fixing these:

[email protected]:~$ sudo apt-get install -f
Reading package lists… Done
Building dependency tree
Reading state information… Done
Correcting dependencies… failed.
The following packages have unmet dependencies:
chromium-browser-l10n : Depends: chromium-browser (>= 50.0.2661.102-0ubuntu0.14.04.1.1117) but it is not installed
Depends: chromium-browser (< 50.0.2661.102-0ubuntu0.14.04.1.1117.1~) but it is not installed
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.
E: Unable to correct dependencies


#21

So multiple people have shown me some codes and they have not worked most of them were sudo apt-get install chromium and ive tried multiple times. Do you have to type in all the codes to work it cause on my raspberry pi3 it worked but my dad’s isn’t working at all?