U/M 20.04.2 + Zerotier = Fail

In recent times I did a bunch of upgrades from 18.04.5 to 20.04.2 .

Given that all the folks whom I assist live hundreds or thousands of miles from me, remote access is an utter necessity.

Prior to these upgrades, all had Zerotier-One & it was amazingly wonderful - fast response times & totally reliable.

Since the upgrades though - it has become totally unusable, which is highly disappointing.

The client PCs all show at the network's dashboard, here:
( https://my.zerotier.com/network )
But all connections are refused 100%.

Tried this:
sudo ufw disable

No change.

Tried doing the snap silliness on 1 PC as suggested here:

No improvements.

Totally purged all things Zerotier - reinstalled - same result.

Someone made this suggestion:

Which is above my experience level...

The ZT forum is zero help because it closes threads almost immediately, which is great for preventing discussion rather than for actually helping its users.

So - my query about this:
Has anyone here successfully gotten ZT to work with 20.04.2 either on the same local LAN or via internet - and if so - please explain how it can be done ??

Thanks for any helpful replies.

How annoyingly mysterious this has become !!

I've been re-checking for either (any...updated) mention of this problem, or for it to change in some manner - which it has.

Suddenly as of today those connections are working, so I'm guessing that it was a problem via their system itself since it acts as a middleman in the connection process.

In the meantime I also tried adding a Softether server remotely - which appears to be working just fine, but getting the Softether client to work under U/M is not working for me...yet, so I cannot connect to it.

The info found for making said connection for remote access is rather long & complicated:

And some bits here seemed helpful as well:

Has anyone here gotten Softether's client to connect via internet & if so, might you have any education about it to share ??