Ubuntu MATE 16.04 boots only in recovery mode after update/upgrade

Good day/night everyone.

Day before yesterday (2016/03/07) I downloaded the torrent for Ubuntu MATE 16.04 from the official MATE website, and yesterday I installed it in a Dell Inspiron 15-5548-B10 Laptop, in UEFI boot mode and four partitions: the first for the EFI boot, with a size of 512MB; the second for the base system, mount point /, with a size of 307200MB (300GB); the third for the /home directory, with a size of 102400MB (100 GB); and the fourth and last one for swap area, with a size of 16384MB (16GB, double of the laptop’s memory). All partitions were set as primary. Fresh install with official ISO image burned into an USB drive with Ubuntu’s Startup Disc Creator were successful.

BUT, after a few customizations in appearance (described below; I don’t know if they have anything to do with the issue), I did run Software Updater and Updated my system. After update, the Software Updater asked me to reboot the system, I did it, and after reboot the O. S. never booted correctly anymore. The loading screen is shown no more, and in its place the system is stuck on a black screen with borders in dark grey. I can boot in recovery mode normally.

The laptop has a dedicated graphics board of ATI, and the MATE’s driver manager (Additional Drivers) doesn’t recognize the ATI’s driver so I’m unable to switch between Nouveau’s driver and ATI’s driver. The software doesn’t recognize the integraded Intel’s graphics card too.


  • Top panel: some launchers and separators, bluetooth turned off, weather turned on (and localization of course);
  • Bottom panel: Eyes 1.12.1, Fish 1.12.2 and two separators;
  • Appearance: Windows titlebar buttons setted to Left.

I really loved Ubuntu MATE, that’s because I opened this issue instead of installing another O. S. in my laptop. Someone to save my user experience? :sweat_smile:

Thank you since now.


1, your root ( / ) partition is waaaaay too big, 20GB would have been enough!.

  1. try running “dpkg” per the update guide and see if that fixes the problem (a network cable connection is required!):
1 Like

This is a small point, consider this just a heads up :slightly_smiling:


I run a two gig swap partition with 24G of ram and never use it. Some processes use swap to store files, but this usually adds up to a few hundred Meg and no big deal. I have other installs on my box and I find it easier to just leave a small swap space.

I appreciate the suggestion and the quick answer, @wolfman, but did not fix the problem. :confounded:

dpkg, in same circumstances as the link, updated some packages and really appeared to work, but the problem didn’t seem to have anything about this.

Today, in a desktop computer, I installed 15.10 version, with default partition table of the Ubuntu Installer (“Erase disk and install Ubuntu MATE”), and checked the option “download updates while installing” and the installation went ok. After first boot, the first thing I did was to run Software Updater to test if everything would be okay. It was. After the restart, the system was functioning perfectly. The optional drivers appeared correctly and installed successfully… In my reply to @anon42388993 there are some extra information.

@anon42388993, swap space didn’t seem to have to do with this issue, because I tried a fresh install of the 16.04 release, after unsuccessfully tried @wolfman’s suggestion, and I put 20GB for / mountpoint, 100GB for /home mountpoint, 8GB for swap, the same 512MB to EFI and 200GB for /usr/local (I’d like to install some audio programs such as LMMS, Hydrogen, etc., as such as some developer tools for web and Android). For the remain installer options I used exactly the same as the desktop PC I commented in my previous reply. The result was the same as install freshly, without internet connection and after that update the O.S. with Software Updater: stuck before loading screen, with black screen with dark grey borders, and Driver Manager without knowing my graphics hardware. Weird! Sounds like is some bug of the release itself, or “its capacity” of “discovering” the drivers or some stuff like that… Thank both of you for the fast and useful responses, waiting for some more ideas…

I don’t think your customizations are a issue either.

One thing that happen during reboot is a kernel upgrade. Try going back to previous kernel at boot.

Hi @arphenius,

try a disk install if you can and burn the disk at the slowest possible speed to avoid read/write errors!. :smiley:

Wooow! That worked!

Buuuut, why did it happen? Would not be a better and/or more secure solution have the kernel updated? The nVidia’s neither Nouveau’s drivers still not appear in Additional Drivers, maybe this has nothing to do with the issue too.


@wolfman, my laptop doesn’t have a optical drive, but I’m going to buy an USB one, when I do this I’ll test in a not long future :grinning:

Thank you!

1 Like

It could be a kernel bug or a corrupted install. I would just stay with that kernel and wait for the next kernel upgrade. The few times I have had a issue, it was resolved with the next kernel upgrade.

As for Additional Drivers
Do you have it checked off?

And what are you running?

inxi -G

I had the same issue a few months ago. The next kernel update solved the problem.

Keep in mind we all have different hardware and some updates break something on one machine but not another.

1 Like

Sorry for the ultra-late reply, I was really too busy last month.

Well, the kernel update apparently solved the problem, but the graphics drivers are still not appearing in Additional Drivers. No I didn't check it off:

This is my output of inxi -G:

Graphics:  Card-1: Intel Broadwell-U Integrated Graphics
           Card-2: Advanced Micro Devices [AMD/ATI] Topaz XT [Radeon R7 M260/M265]
           Display Server: X.Org 1.18.3 drivers: ati,intel,amdgpu (unloaded: fbdev,vesa,radeon)
           Resolution: [email protected]
           GLX Renderer: Mesa DRI Intel HD Graphics 5500 (Broadwell GT2) GLX Version: 3.0 Mesa 11.2.0

Thanks to all of you for the help, but I guess it would be better if I open a new issue for the Additional Drivers problem, as per title of the issue this one should be marked as "solved" or something like that, doesn't it?

Yes, please do :slight_smile: It not always works, but one problem per thread reduces clutter and confusion.

Please read through this before you do!: