Ubuntu MATE 16.04 desktop unresponsive when Chrome is open - Fixed / Worked Around

I’m not sure if this is the best place to post this, but I’ve not found it in other posts and wanted to make others aware of my fix/workaround.

I’ve had problems with the desktop being unresponsive to mouse clicks. It took awhile for me to make the connection that it only occurs when Chrome, installed from the Software Boutique, is open. I do not have the problem on my laptop, it has Chromium. Both open the same 4 home tabs at start-up and have the same add-ons.

I installed Chromium with Synaptic and the problem does not occur. With Chromium minimized I open Chrome and the desktop becomes unresponsive to mouse clicks again.

So at this point I have migrated my settings and add-ons to Chromium and uninstalled Chrome.

Core i5 machine, 64-bit, 4GB RAM, 1 TB SATA, Ubuntu MATE 16.04, LastPass, uBlock Origin

1 Like

Hello and Welcome

This is likely to be a hardware specific issue since a lot of people are using Chrome without troubles.
Can you please post the output of the following command in a terminal (CTRL+ALT+T):

inxi -MCG

Cheers

1 Like

Sure

[email protected]:~$ inxi -MCG
Machine:   Mobo: Intel model: DH55TC v: AAE70932-206
           Bios: Intel v: TCIBX10H.86A.0048.2011.1206.1342 date: 12/06/2011
CPU:       Dual core Intel Core i5 660 (-HT-MCP-) cache: 4096 KB 
           clock speeds: max: 3326 MHz 1: 1197 MHz 2: 1197 MHz 3: 1197 MHz
           4: 1197 MHz
Graphics:  Card: Intel Core Processor Integrated Graphics Controller
           Display Server: X.Org 1.18.3 drivers: intel (unloaded: fbdev,vesa)
           Resolution: [email protected]
           GLX Renderer: Mesa DRI Intel Ironlake Desktop
           GLX Version: 2.1 Mesa 11.2.0
1 Like

What Window Manager from the MATE Tweak? I had some weird problems with chrome and compiz.

1 Like

I have the same issue. It only happens when I have compiz activated. It seems to be a problem with chrome’s custom window decoration.
You can work around the issue by turning off chrome’s custom title bar and using the system’s title bar instead.

3 Likes

ThanosApostolou It is Compiz (Advanced GPU advanced desktop effects), which was the default install.

Rion96 Thank you!

If you guys have a clear path to reproduce can you please file a bug report up on launchpad?

Default WM option at install is “Marco (Software Compositor)”

1 Like

I suppose some package I installed, may have depended Compiz and switch to it. I’m confident I did not explicitly turn it on.

Regardless, I an no longer able to duplicate it after uninstalling Chrome thru the Software Boutique. This evening I downloaded and installed from Google the .deb with GDebi; the desktop remained responsive. I noted the version number, 53.0.2785.116 (64-bit), uninstalled with GDebi, went back to Software Boutique and installed from there. It also installed 53.0.2785.116 (64-bit), and did not make the desktop unresponsive either. So at this point I’m not sure whether a buggy prior version was installed via the Software Boutique that left some settings remnants in successive updates; a remnant that was removed when I uninstalled the package, such as what Rion96 referred to.

At this point I consider the system fully operational and am enjoying MATE. MATE runs very nicely on the older hardware I have lying about. Thanks to all who responded.

1 Like

Rion96’s post worked for me too, on Mate 16.04, Desktop Envir 1.12.1, 09/2017.

Yes yes, and yes. This was the issue. I turned on system title bar and all is well again. The whole desktop becomes unresponsive to clicks if the chrome window was maximized. AKA, only the area that chrome window was open/sized to, would be the area of desktop that would be unresponsive, once minimized, of course. Switching to an alternate workspace was a lazy workaround for a while. Thank you for this.