Ubuntu MATE 16.04 laptop brightness not preserved

A quick solution is to add the brightness applet to the top panel and then pull the slider down!.

Right click top panel > Add to Panel > Brightness Applet > Add:

Hi Wolfman, Thanks for the reply. I have this slider on the desktop. It makes no difference when changing the slider. Not even after a reboot.

Hi @Tuihanti,

did you not put it on the panel?. :confused:

Hi Wolfman, yes i did put it on the panel.

I also remember that it was working ok before maybe mate 1.12. something. But it is broken now. Changing brightness with function keys was changing the brightness on ac slider value before. I have also reported a bug on github.

6 posts were split to a new topic: Laptop screen brightness

I am using the proprietary graphic drivers now and i am able to change the luminescence now. Not the way i want but it works. Still need to figure out how to color calibrate the monitor.
Let’s hope these problems can be solved.

This version works as expected, mate-power-manager_1.12.0.1-1+rosa_amd64, which I downloaded from mint repository for linux mint rosa. But versions after that does not work, nor 1.12.1, neither 1.14 or 1.16.
Thanks in advance.
I am using xfce-power-manager as a work around.

Hi all. I tried to use Ubuntu 16.10 with Mate 1.16. I seem to have very bad screen brightness problems on a Thinkpad with Intel HD 520. The brightness jumps all over the place and in general it is way too bright and literally hurts my eyes. Was so disappointed because I really wanted to switch over to Mate. Not sure if this is the same as the above problem but essentially I had no option but go back to Gnome. Didn’t have this problem on Gnome, KDE or Cinnamon

A possible work-around - did you check brightness options in your BIOS?

Stock Ubuntu or Xubuntu works fine. So I am sure it is mate-desktop related.

After reading this thread I don’t understand why we still don’t have a solution. I’m on MATE 16.10 with Intel graphics and have to adjust the backlight via panel applet after every boot and resumption from sleep.

@jawz101 that’s what I can’t seem to understand too. If this problem exists from 1.14 why has this not been fixed especially with common hardware like Intel graphics. Maybe there are workarounds for this but one shouldn’t have to go through all this trouble if the KDE, Gnome. Cinnamon etc don’t have this issue.

I think remember this bug from mate 1.8. It was fixed at - which I checked on Linux Mint Rosa - but then I think something went wrong and that fix was lost. I think it does not get enough attention/complaint from users. I hope @Wimpy will fix it soon. They might be busy with gtk3 migration. At least now it is confirmed that this is a “problem”.
This is the issue I opened at github:

No attention there.

If I set the brightness by the command;
gsettings set org.mate.power-manager brightness-ac 60 it is preserved after restart.

I’m facing a similar issue as OP, but I don’t have cpufreqd installed. However, I do have cpufrequtils package installed. Do you think removing that package might help?

@prahladyeri can you confirm if the solution works? I am desperate to use Ubuntu Mate but can’t because of this bug

@Simon_Morgan What worked for me was something else. What I did was put the following two lines in the /etc/rc.local just before the exit 0 statement:

#Added by Prahlad:
echo 46 > /sys/class/backlight/intel_backlight/brightness


However, this solution may or may not work for everyone. The /sys/class/backlight/intel_backlight seems to be specific to some vendors, make sure the folder is available on your system before proceeding with this.

Great thanks. Do you mind explaining to me what this line does exactly for learning purposes. Also double checking, you said two lines but it is only one…

thanks so much

I am currently on Unity until a fix is found. I do see that my system also uses the intel_backlight files

Sure. All this code does is set the brightness to 46 level. This is a vendor-specific attribute so test this line using sudo beforehand to ensure that the brightness level is exactly what you want. On my laptop, 46 is the level at which the brightness seems optimal, on your device it could be something else, so set it accordingly.

And yes, its just one line of code. I had counted the comment I had placed as another line :slight_smile:.