Ubuntu Mate 19.10 and Clock/inet/other


I seem to be in a quandry. After updating to 19.10, the clock is fixated to April 11, 2019 12: 28 PM. Setting the GUI to get from the servers does nothing. Using ROOT: NTPD -q goes into an endless loop of Soliciting Pool Server. Once set, the clock is current. Upon reboot, the April 11, 2019 12:28 PM is back and ROOT: NTPD -q again.

With NTPD, all inet devices are queried. With -4, this makes queries against lo, wlan0, eth0:0 and eth0:1. I would like it to query 1 eth0.

Changes through Control Panel and applets, apperances, and settings are not remembered.

Overall, 19.10 is where I would like to stay.

maybe sudo dpkg-reconfigure tzdata might help.

Hello pavlos,

Thank you for your suggestion. -reconfigure or --reconfigure is not a valid dpkg option. At this present time, ntpd still has not resolved the date and time.

dpkg-reconfigure is one word

$ whereis dpkg-reconfigure
dpkg-reconfigure: /usr/sbin/dpkg-reconfigure /usr/share/man/man8/dpkg-reconfigure.8.gz

Hello Pavlos,

Thank you for your patience. Yes, this does work but just for the session. Alas, reboot starts the process all over again. Date = April 11, 2019 Time is 12:30PM. This is not the time. Something appears to be hardwired and not fixable with dpkg-reconfigure. This appears to be a feature.

In fact, dpkg-reconfigure tzdate does not fix the date and time. I have to use time-admin under sudo to set this manually. Selecting Keep Syncronizing does nothing. Reboot and back to hardwired.

Attempting to set the time via clock preferences for the desktop produces an error and restart of Clock. The best way to set the time for the session is Sudo TIME-ADMIN. Nothing else works.

can you try

  sudo hwclock --adjust
  sudo hwclock -hctosys --debug

the first should adjust the clock from the hardware clock
the second should set the hardware clock to system with debug info

Hello Pavlos,

Neither commands work on 19.10 of Ubuntu-Mate for Raspberry PI 3b+. RTC does not exist either. /dev/r* shows no RTC.

Looks like we are striking out with RPI 3B+.


I found the issue. Apparently, an old chrony version was left over from an OS upgrade from 19.04 to 19.10. When I googled "clock time ubuntu mate", I came to this site, https://vitux.com/keep-your-clock-sync-with-internet-time-servers-in-ubuntu/. I attemtped the chronyd command and received an error. I installed and then attempted the Chronyd -q command.

I received an error that another ChronyD was running, /run/chronyd.pid. I deleted it and reran ChronyD -q. Now, time is working. Issue is closed.