Ubuntu MATE 19.10 Beta Testing

Check out this page - 19.10 - fix screen tearing after upgrade on Nvidia systems by removing the proprietary driver

Due to of some changes in bash-completion and/or maybe mawk our LiveCD and installed system are affected by the following bug:

auto-completion of umount /dev/ with Tab does not work and gives error instead of completion:

$ umount /dev/awk: line 18: function gensub never defined
awk: line 18: function gensub never defined

I have already reported it as bug

https://bugs.launchpad.net/bugs/1845529

but the reaction on launchpad is very disappointing, no one wants to take responsibility and recognize a bug in some package.

Please do the following:

  1. open terminal on live or installed UM 19.10
  2. type umount /dev/ and then press Tab to confirm the error
  3. visit corresponding bug page on LaunchPad to indicate that you are affected by this bug: click Does this bug affect you? and then Yes, it affects me.

Note: installation of gawk package fixes the issue, but it is not installed by default.

Going back to noveau is not an option for many, unfortunately. The performance gap (especially on non-Kepler GPUs, which can't even be re-clocked manually) is just way too large.
I would recommend adding this to the 19.10 release notes, though, just so people are aware of this limitation.

Unfortunately right now you have to opt between a nice screen tearing free desktop experience or high performance games/ professional 3D modeling with tearing.
As I do not run games, and professional 3D can be used on Microsoft Windos if necessarily, I don't need Nvidia proprietary driver, and I enjoy Tear Free Mate Desktop/Firefox Browser on it entirely. And desktop /Browser run fast like on Proprietary Nvidia.

You can fix the screen tearing on the proprietary NVidia drivers as well, but it requires extra steps:

  • open nvidia-settings
  • select X Server Display Configuration
  • click "Advanced..."
  • check "Force Full Composition Pipeline"
  • click "Save to X Configuration File"
3 Likes

@maximuscore thanks for the tip, I will give it a try, as proprietary driver keeps my video card at low power use than nouveau at common desktop use (as I see a small difference in fan speed).
I tested in the past different guides from internet, none of them work with Marco, the only thing that work it was called "Compiz", but it has small glitches on Mate, while Marco run absolutely perfect.

Hi from first-time poster

I've just installed 19.10 beta on my Asus Transformer and the screen is in portrait mode and does not make use of the accelerometer to rotate the screen and touchpad. This is not a regression it also happens with other older versions of Ubuntu main and flavours.

But I'd like to try to see if we can get it fixed.

Thanks to this post: https://linuxappfinder.com/blog/auto_screen_rotation_in_ubuntu

I found that by installing iio-sensor-proxy inotify-tools and running this script (slightly modified from the example) it both switches to the correct orientation and adjusts to future changes.

#!/bin/sh
# Auto rotate screen based on device orientation

# Clear sensor.log so it doesn't get too long over time
> sensor.log

# Launch monitor-sensor and store the output in a variable that can be parsed by the rest of the   
# script
monitor-sensor >> sensor.log 2>&1 &

# Parse output or monitor sensor to get the new orientation whenever the log file is updated
# Possibles are: normal, bottom-up, right-up, left-up
# Light data will be ignored
while inotifywait -e modify sensor.log; do
 # Read the last line that was added to the file and get the orientation
 ORIENTATION=$(tail -n 1 sensor.log | grep 'orientation' | grep -oE '[^ ]+$')

 # Set the actions to be taken for each possible orientation
 case "$ORIENTATION" in
 normal)
 xrandr --output DSI-1 --rotate normal ;;
 bottom-up)
 xrandr --output DSI-1 --rotate inverted ;;
 right-up)
 xrandr --output DSI-1 --rotate right ;;
 left-up)
 xrandr --output DSI-1 --rotate left ;;
 esac
 done

Is it possible to include something of this kind into the image? I realise that DSI-1 is specific to my Asus setup so some detection would be required for this to apply to all units with an accelerometer.

Thanks in advance
Tim

1 Like

No, you don't.

I know you're thrilled that the new compositor in marco fixes YOUR tearing, and that's great, but (a) it doesn't work for at a minimum some Intel IGPs; and (b) there's nothing stopping people from using Compton (or even Compiz, if they want that) just the same as before, and if that means not losing half the performance of their very expensive video cards it's a more than valid reason for them to do so.

I noticed that the icon of the "Advanced Mate menu" can no longer be changed and is now set to the icon provided by the theme as "start-here".

The change was asked here as "an option":

https://github.com/ubuntu-mate/mate-menu/issues/45

start-here

The problem I have is that I want to use "Numix circle" as my theme, but I don't want to have a red circle with an "n" in the panel (the left part of the image is my current setup and the right one is UM19.10 running in a VM).

Numix is a theme that can be applied to many distributions. They provide a generic "start-here", a version for Arch ("start-here-arch"), a version for KDE ("start-here-kde" and a symbolic version "start-here-symbolic".

If they decide to make a version for mate, it will not be used unless they called it "start-here" or I overwrite the icon.

I think this option is fine only for themes made specific for Mate.

see also:

You know @arQon maybe you are not so thrilled about this Marco tearing free experience in 19.10 but I really am. I am not a programmer, just an engineer, but I own two workstations one desktop one laptop and a netbook that I run quite often of course I own another desktop use by my mother, and another laptop and netbook that I use really rarely, plus another 3 32bit laptops that are almost no more used, plus two home servers and 3 raspberry pi. All of them have Ubuntu Mate.
From My main PC's use, all of them except the netbook (not counting pi and servers) have screen tearing fixed with Marco. My old laptop have an ATI video card, on that one is not fixed, I don't care as I can use Compiz on it, and is also very rarely used.

The workstation for my use are quite kick as both have some old nvidia quadro GPU's and 6 core xeon processors but if scrolling in firefox is shi... (using a logitech free scroll wheel) video run like garbage with screen tearing on Nvidia Quadro what the fu..., I don't give a... on video performance as the all desktop experience it was junk.... so use Compiz witch solve those issues but bring others, (Compton was worse )... so in the end every time I found myself switching between Marco and Compiz, and in the end for my workflow remain most of time with Marco as it work perfect except screen tearing.

I don't know how you see this but right now my main system desktop run marvelous with Marco and I don't give a shi.. that my Quadros run almost on idle, I just enjoy the smooth desktop experience in 19.10. Quadros was intended for Windows professional apps, some run also under wine, but not as good and also without "space mouse" devices.

You wont both, there is another option, is called KDE, that is not a Linux desktop (neither Windows), you can install it on Linux but is not intended for Linux users as is hard to do basic Linux staffs like running scripts, ssh automatic key authentication does not work without extra manual configuration,.....
I don't say that maybe in the future Mate will use video acceleration by using OpenGL ore something else but is not the case now, and I am really happy that it works very good now, this desktop is almost perfect.

Regarding the start-here button, we could submit one for start-here-mate to the numix project. We can change the icon to load that one with fallbacks. GTK allows you to load icon fallbacks by removing hyphen parts: start-here-mate -> start-here -> start -> missing-image, so this should satisfy pretty much all themes.

As to why we changed it, the old icon didn't adapt to theme changes, and so we had to include an icon for light and one for dark themes. Plus a bunch of code to support this option. Using this new icon removed like 500 lines of code, if I remember correctly, and now it correctly matches most themes (numix being an exception here, thanks for pointing this out).

Would you mind filing an issue about the numix icon, so that we can track it?

Like I say, it's great that you're so happy with it. You seem to have missed that part. I'm just pointing out that you saying his ONLY options are "Switch to Nouveau and take a massive performance hit, or put up with the tearing" is flat out incorrect. The improvement to Marco does not in any way invalidate the options that existed before that change and still work better for many cases, including his.

YOU may not care about the performance, but you are not him. Different people have different priorities, and while your evangelism of the new compositor is helpful to some of them, it's not helpful to people who have already explicitly stated that the prerequisites for getting it to work are not acceptable to them, or that it doesn't work on their hardware. I'm just asking you to keep that in mind, instead of advocating that Marco's compositor is the One True Way no matter what. Okay? :slight_smile:

OK. I wasn't sure where to put this. Thanks.

Numix has an icon called "desktop-environment-mate" with the mate logo they can link to "start-here-mate" I think ...

Hi There!
I have a problem with mesa-opencl-icd
I used Mate 19.04 and earlier without a problem, but with 19.10 Beta, it fails.

Details:
I use mesa-opencl-icd and the [email protected] project (app) within BOINC to process data on my Radeon/ATI 7750 Card.

The process starts up OK - but I get an error in less than a minute.
The error is reported on https://einsteinathome.org/task/888883349,
I will try to copy and summarize here...

# Task 888883349
Name: LATeah1062L07_332.0_0_0.0_15029665_1
Workunit ID: [422265218](https://einsteinathome.org/workunit/422265218)
Created: 11 Oct 2019 5:53:25 UTC
Sent: 11 Oct 2019 6:09:52 UTC
Report deadline: 25 Oct 2019 6:09:52 UTC
Received: 11 Oct 2019 6:13:27 UTC
Server state: Over
Outcome: Computation error
Client state: Compute error
Exit status: 11 (0x0000000B) Unknown error code
Computer: [12201025](https://einsteinathome.org/host/12201025)
Run time (sec): 14.36
CPU time (sec): 12.53
Peak working set size (MB): 117.97
Peak swap size (MB): 1430.13
Peak disk usage (MB): 0.02
Validation state: Invalid
Granted credit: 0
Application: Gamma-ray pulsar binary search #1 on GPUs v1.18 (FGRPopencl1K-ati)
x86_64-pc-linux-gnu
||--------------------------------------------||
### Stderr output
||--------------------------------------------||
......skipping......
ac_rtld error: shdr->sh_size & 3
ELF error: invalid section index

-- signal handler called: signal 1
4 stack frames obtained for this thread:
Frame 14:
	Binary file: ../../projects/einstein.phys.uwm.edu/hsgamma_FGRPB1G_1.18_x86_64-pc-linux-gnu__FGRPopencl1K-ati (0x48b101)
	Source file: hs_boinc_extras.c (Function: sighandler / Line: 291)
Frame 13:
	Binary file: /usr/lib/x86_64-linux-gnu/gallium-pipe/pipe_radeonsi.so (0x7f1affad4e21)
	Offset info: +0x14ce21
Frame 12:
	Binary file: /usr/lib/x86_64-linux-gnu/gallium-pipe/pipe_radeonsi.so (0x7f1affad4e21)
	Offset info: +0x14ce21
Frame 11:
	Binary file: /lib/x86_64-linux-gnu/libMesaOpenCL.so.1 (0x7f1b049b319b)
	Offset info: +0x37319b
Frame 10:
	Binary file: /lib/x86_64-linux-gnu/libMesaOpenCL.so.1 (0x7f1b049b3bbf)
	Offset info: +0x373bbf
Frame 9:
	Binary file: /lib/x86_64-linux-gnu/libMesaOpenCL.so.1 (0x7f1b049b0815)
	Offset info: +0x370815
Frame 8:
	Binary file: /lib/x86_64-linux-gnu/libMesaOpenCL.so.1 (0x7f1b049b0fa3)
	Offset info: +0x370fa3
Frame 7:
	Binary file: /lib/x86_64-linux-gnu/libMesaOpenCL.so.1 (0x7f1b0499f39d)
	Offset info: +0x35f39d
Frame 6:
	Binary file: ../../projects/einstein.phys.uwm.edu/hsgamma_FGRPB1G_1.18_x86_64-pc-linux-gnu__FGRPopencl1K-ati (0x48fe01)
	Offset info: opencl_setup_photon_pairs_array+0x4c1
	Source file: unknown (Function: opencl_setup_photon_pairs_array / Line: 0)
Frame 5:
	Binary file: ../../projects/einstein.phys.uwm.edu/hsgamma_FGRPB1G_1.18_x86_64-pc-linux-gnu__FGRPopencl1K-ati (0x47480d)
	Offset info: setup_photon_pairs_array+0x36d
	Source file: HSgammaPulsar.c (Function: setup_photon_pairs_array / Line: 2107)
Frame 4:
	Binary file: ../../projects/einstein.phys.uwm.edu/hsgamma_FGRPB1G_1.18_x86_64-pc-linux-gnu__FGRPopencl1K-ati (0x47e28e)
	Offset info: MAIN+0x4dee
	Source file: HSgammaPulsar.c (Function: MAIN / Line: 4866)
Frame 3:
	Binary file: ../../projects/einstein.phys.uwm.edu/hsgamma_FGRPB1G_1.18_x86_64-pc-linux-gnu__FGRPopencl1K-ati (0x46c06f)
	Offset info: main+0x5ff
	Source file: hs_boinc_extras.c (Function: worker / Line: 833)
	Source file: hs_boinc_extras.c (Function: main / Line: 1039)
Frame 2:
	Binary file: /lib/x86_64-linux-gnu/libc.so.6 (0x7f1b05d871e3)
	Offset info: __libc_start_main+0xf3
Frame 1:
	Binary file: ../../projects/einstein.phys.uwm.edu/hsgamma_FGRPB1G_1.18_x86_64-pc-linux-gnu__FGRPopencl1K-ati (0x46e569)
	Source file: unknown (Function: _start / Line: 0)

End of stacktrace
02:10:13 (5107): called boinc_finish
Warning:  Program terminating, but clFFT resources not freed.
Please consider explicitly calling clfftTeardown( ).

</stderr_txt>

=================================================================
About the hardware....
Boinc lists harware and drivers in its log.. Here is the start....

    Sun 13 Oct 2019 01:14:37 PM EDT |  | Starting BOINC client version 7.16.3 for x86_64-pc-linux-gnu
    Sun 13 Oct 2019 01:14:37 PM EDT |  | log flags: file_xfer, sched_ops, task
    Sun 13 Oct 2019 01:14:37 PM EDT |  | Libraries: libcurl/7.65.3 OpenSSL/1.1.1c zlib/1.2.11 libidn2/2.2.0 libpsl/0.20.2 (+libidn2/2.0.5) libssh/0.9.0/openssl/zlib nghttp2/1.39.2 librtmp/2.3
    Sun 13 Oct 2019 01:14:37 PM EDT |  | Data directory: /var/lib/boinc-client
    Sun 13 Oct 2019 01:14:37 PM EDT |  | OpenCL: AMD/ATI GPU 0: AMD VERDE (DRM 2.50.0, 5.3.0-18-generic, LLVM 9.0.0) (driver version 19.2.1, device version OpenCL 1.1 Mesa 19.2.1, 2048MB, 2048MB available, 512 GFLOPS peak)
    Sun 13 Oct 2019 01:14:38 PM EDT |  | [libc detection] gathered: 2.30, Ubuntu GLIBC 2.30-0ubuntu2
    Sun 13 Oct 2019 01:14:38 PM EDT |  | Host name: pc-14
    Sun 13 Oct 2019 01:14:38 PM EDT |  | Processor: 8 AuthenticAMD AMD FX(tm)-8150 Eight-Core Processor [Family 21 Model 1 Stepping 2]
    Sun 13 Oct 2019 01:14:38 PM EDT |  | Processor features: fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush mmx fxsr sse sse2 ht syscall nx mmxext fxsr_opt pdpe1gb rdtscp lm constant_tsc rep_good nopl nonstop_tsc cpuid extd_apicid aperfmperf pni pclmulqdq monitor ssse3 cx16 sse4_1 sse4_2 popcnt aes xsave avx lahf_lm cmp_legacy svm extapic cr8_legacy abm sse4a misalignsse 3dnowprefetch osvw ibs xop skinit wdt fma4 nodeid_msr topoext perfctr_core perfctr_nb cpb hw_pstate ssbd ibpb vmmcall arat npt lbrv svm_lock nrip_save tsc_scale vmcb_clean flushbyasid decodeassists pausefilter pfthreshold
    Sun 13 Oct 2019 01:14:38 PM EDT |  | OS: Linux Ubuntu: Ubuntu Eoan Ermine (development branch) [5.3.0-18-generic|libc 2.30 (Ubuntu GLIBC 2.30-0ubuntu2)]
    Sun 13 Oct 2019 01:14:38 PM EDT |  | Memory: 11.61 GB physical, 48.83 GB virtual
    Sun 13 Oct 2019 01:14:38 PM EDT |  | Disk: 133.57 GB total, 124.69 GB free
    Sun 13 Oct 2019 01:14:38 PM EDT |  | Local time is UTC -4 hours

================================================================
Question: Any ideas?
Go back to 19.04 or 18.04?

T H A N KS in advance,
Jay

Looks like one of the libs has bad alignment. And, jep, Phoronix mentions one of the Mesa devs implementing a new scheme for shader loading in May - https://www.phoronix.com/scan.php?page=news_item&px=AMD-Mesa-Real-Runtime-Linker - so the timescale fits.

Blow away the shader cache - I suspect it's stale, and old ones are definitely not going to be compatible (though it's hard to believe Mesa didn't version things properly and handle that case, so I'm not too confident in that guess). Worth a shot though. Or if you're using pre-compiled shaders that you DL'd from somewhere, get new ones.

  • In 3 years Mate Panel Layout change remain the same shi... and unreliable as in the following picture. (Configuration continue to be done in two files that look similar)
  • Panel indicators in 3 years has been changed up and down, and it continue to be shi..., giving me the impression that 16.04 have the best indicators.

Even until now I manage to solve it, it looks like the panel issue is no more correctable if I remove par example one of mate menu almost all icons on left vertical bar disappear.

Picture is taken from a new install,install was done using scripts that copy also those panel config files, but change was not reliable in Mate Tweak, and I was struggling wit it (until I manage to bring my app icons on left panel by switching around different layouts.)

I don't know what to say maybe this distribution is really in lack of developers, the developers that exist can only do small patches to existing bad coding as no one have time for a code rework. This is my feeling, and somehow I am sad about it ...

maybe this distribution is really in [lack] of developers, the developers that exist can only do small patches to existing bad coding as no one have time for a code rework

And you'd be correct! Ubuntu MATE (and MATE upstream, they're very much related) is a very small team of volunteers. Some contribute in the evenings, some in the weekends, and others sneak in some code in between meetings at their day job. Bugs, issues, and feature requests pile up much higher than there is time to take care of them. There's also testing, documentation, managing the releases themselves, reviewing all the patches, etc.

Even then, the team still manages to rewrite parts as needed when time allows, and each new release is better than the last, so there's that!

Also keep in mind that developers rarely follow the forum to determine what needs to be fixed. So if you find an issue filed for this already, make sure you add to it as much information as you can to help the developers. If there's no issue filed, then make sure you do it, so that developers are aware.

Lastly, some bugs, even if they seem small from the outside, are incredibly hard to figure out and fix. This might be one of those, for all we know :confused:

5 Likes

Hey I had few small issues at first but they went away, though I don't switch layouts often, it often seems to help if you switch to several built in layouts before switching to a custom layout(or a built in layout that is giving you trouble

edit: I just tried switching and mostly it worked flawlessly, until I moved back to my custom layout, then it repeated the brisk menu, besides that it was fine.(I also tried it several more times and while I got it to do it once, after I modified it correctly and saved it under a new name, it worked perfectly even switching from layouts that had the brisk menu) so it seems to be more a problem with custom layouts than built in ones, also in all my testing the panel applets I have had the most trouble with in 19.10 are the brisk menu and mate dock applet, however over all it seems far more solid than previous releases

I know @vkareh that software programing is not easy, I am not a programmer, but I have dome some programing lets say in more common languages like PHP/html and I know what you mean, when app became complex you fix something and broke something else, or if after sometime I have to modify it I am struggling my head to understand what I have coded there. Fortunately I have done this just for myself couple of years ago making an web app for my inventory list.

As I mention above the issue with panel layout change consistency. On the same PC I have another issue and I confirm right now that is specific to Ubuntu Mate, as tested a live image of Lubuntu on it (that somehow was already available on a stick used for install on a windows tablet) and the issue is non existent, or both issues are non existent.

As I need a small mobile server for my car/caravan and intended some raspberry 4 for it I just found something interesting on flow market .. an "HP ProDesk 600 G2 Desktop Mini" that looks like in this picture:

190107223412_HP%20Prodesk%20600%20G2

The issue with it is the video outputs on Ubuntu Mate.
As it can also be seen in the picture this has two display ports and one VGA.

  1. First issue, if I boot using VGA connection boot process stall immediately after grub menu. (On Lubuntu 19.04 it boot OK), I don't know if this issue is kernel related or not, I will investigate more.
  2. Second issue If I use simultaneously both display ports I get inconsistent Mate desktop detecting of monitors. Sometime are detected both and mate load correctly on both. Sometime either the one or the other monitor are not detected so it load on that monitor corresponding low resolution or sometime either the one or the other monitor are not detected and both monitor are loaded with same low resolution or even same content. If i disconnect the corresponding cable and reconnect it the monitor is correctly detected. Sometime I just have to go to mate tweak and change resolution back higher. This is somehow wired as neither of other system that I have have this issue (of course most used with two monitors are just two dell workstation with Nvidia Quadro graphics).

This is not a big deal to me as Intended as server, but because of these dual display ports I might rethink it for desktop use, but on Mate is not reliable for now...