Ubuntu MATE 20.04 Pre-release Testing

Hi again,

returning to a redundant separator in nm-applet: I have launched this applet in Gnome Shell (Ubuntu 20.04 daily). Surprisingly, I see no extra separator lines. MATE, however, shows something like an empty menu item at the very bottom.
gnome mate
Can anybody reproduce and confirm this?


I'm running Ubuntu mate with kernel 5.5.10. I keep getting an internal error. Help.....

Welcome. I'd recommend to run the current LTS kernel on 20.04 especially in a per-production release.

You may want to check /var/crash for crash logs. If they are there remove them and see if your pop-up is going away.

Does anyone's automatic updates work? Here's what I usually set:

I don't boot into 20.04 for very long but I'm used to other versions checking immediately first thing when it hasn't been up in a few days. So far it has NEVER EVER checked for updates on dozens of boots. It's manual updating only.

I made some progress on your attempt at fixing unfocused desktop labels bug.

This was your initial unsuccessful attempt:

.caja-desktop.view :selected:backdrop {
    background-color: @theme_unfocused_bg_color;
    color: @theme_unfocused_fg_color;

The problem with that is that in gtk-main.css @theme_unfocused_bg_color is set to @bg_color which in turn happens to be #f2f1f0, i.e. that white-ish background we're seeing.

So... experiment 1 - this gives a red background color for unfocused desktop items:

.caja-desktop.view :selected:backdrop {
    background-color: #ff0000;
    color: @theme_unfocused_fg_color;

18.04-ish fix (which makes unfocused background same as focused one as in 18.04):

.caja-desktop.view :selected:backdrop {
    background-color: @theme_selected_bg_color;
    color: @theme_unfocused_fg_color;

I inserted those before the MATE-Panel section in mate-applications.css, in case it matters.

I hope this helps.

Oh and btw. if you pick a color like @dark_bg_color instead it looks strange if you have the desktop item in rename mode and then lose focus.

Thanks for having a look, I committed a fix not too long ago - back to how it was in 18.04!

Found another theming issue which I'm hunting down:


Edit: Fixed.


Has anyone had an issue with celluloid rendering when it is loading, on my system the menubar and something else is transparent for a fraction of a second before it is loaded, but once loaded it is fine it appears to only happen with celluloid

p.s. not a big deal just looks weird

Hi @Bernie,

I have just checked this in virtualbox and can confirm that menubar and bottom toolbar are transparent on loading. However, if I switch on client-side decorations in preferences, it loads without glitches. In this case menu is integrated in headerbar (therefore no separate menubar) and bottom toolbar seems to load instantly.


1 Like

@Bernie @ironfoot would one of you file a bug against celluloid please. If you could throw a screenshot of that happening in the report that would be helpful.

If I get time and can find it, will do. Also the indicator date time refuses to work I'll upload the error message when I'm at my computer

Hi @franksmcb,
shall this be filed against celluloid taking into consideration that I was unable to reproduce the issue in vanilla ubuntu? I attach a screenshot from ubuntu mate below. @Bernie feel free to use it in report since you are an original poster. I'll check this thread and report tomorrow if necessary.

1 Like

Trying to get x-tile running on 20.04 (If there is a substitute please let me know)

Building and running x-tile from https://github.com/giuspen/x-tile.git

Using python2, this builds without error but at runtime get

 `File "/usr/bin/x-tile", line 29, in <module>
   import gtk
  ImportError: No module named gtk`

For this I believe I need python-gtk2. However this is not in the repository. Has it been removed or is this omission an oversight.

Many Python 2 related stuff was removed from 20.04 LTS. So this seems to be expected.
We can try to ask @giuspen about porting X-Tile to Python 3. I have written message to him via launchpad. Update: Giuseppe responded with willing to do so.


There are some dependency issues in Welcome - Software (Boutique)

Play on Linux can't be installed: Depends: python2: any, but it's virtual package (or something like that, half is translated)

Can't uninstall TuxPaint: Package tuxpaint-config isn't installed.

In getting started program for Blu-ray and dvd support, gets error: Package libdvdread4 isn't available

When installing/removing stuff in welcome in notification bar that announce changes things are written in english, even if other language is selected and used in Welcome. (this worked fine in 16.04).

I register there, but the Start new translation, has crossed red circle when hover over and can't be pressed. I don't think I'm skilled enough to do the other way. :frowning:

Also ubiquity-slideshow-ubuntu still isn't updated with latest strings to translate it.

if you turned client side decorations of in vanilla ubuntu would it do it?

Here is the error messages the indicator date time gives me on 20.04 and recently started on my 19.10 machine as well

    ** (process:9862): WARNING **: 09:19:40.210: could not find the desktop file for 'org.gnome.Calendar.desktop'

(process:9862): Indicator-Datetime-WARNING **: 09:19:40.405: Unrecognized TZID: 'Etc/Utc'

(process:9862): Indicator-Datetime-WARNING **: 09:19:40.407: Unrecognized TZID: 'Etc/Utc'

(process:9862): Indicator-Datetime-WARNING **: 09:19:40.421: Unrecognized TZID: 'Etc/Utc'
Indicator-Datetime:ERROR:/build/indicator-datetime-SpDTj1/indicator-datetime-15.10+20.04.20200217/src/date-time.cpp:171:GDateTime* unity::indicator::datetime::DateTime::get() const: assertion failed: (m_dt)
Bail out! Indicator-Datetime:ERROR:/build/indicator-datetime-SpDTj1/indicator-datetime-15.10+20.04.20200217/src/date-time.cpp:171:GDateTime* unity::indicator::datetime::DateTime::get() const: assertion failed: (m_dt)
Aborted (core dumped)

@Bernie, it worked seamlessly in vanilla ubuntu with both client-side decorations on and off. By default they were off like in ubuntu mate (menubar was displayed). My ubuntu vanilla installation was updated daily 20.04 in virtualbox.


1 Like

I wonder if it perhaps is a Marco issue, though it doesn't happen on 19.10 with 0.16

Unfortunately I have no 19.10 installation to test. @franksmcb any ideas?

Please file a bug report against marco