Ubuntu MATE 20.04 Pre-release Testing

I'm running 20.04 on a couple of laptops and one desktop and posting from the laptop I upgraded using the sudo do-release-upgrade -d command from 19.10 last night. I just opened the Welcome app and experienced no crash. Thought you might like to know that.

I just cloned a perfectly functioning Ubuntu MATE 19.10 VM (virt-manager) and upgraded using sudo do-release-upgrade -d. Now, when I start Ubuntu MATE Welcome, the system crashes -- just like the clean install.

I think it might be your virt-manager. I'm on my old (relatively speaking) laptop and Welcome never crashed it. Looks like I removed it (being useless at the moment) but when I opened it upon first reboot and once again, nothing squeaked or crashed. This laptop has 8 Gb ram and the previous one probably did too.

Updating here as well.

Everything worked on bare metal. I tested it with virt-man with 2GB and it crashed as Larry described. I will do some more testing tomorrow.

In the mean time can you install VirtualBox and install there for testing?

As this is more in-line with pre-release testing let's move this discussion over to Ubuntu MATE 20.04 Pre-release Testing thread.

Thanks

1 Like

I can switch to Virtual Box. Thanks for the help on this.

Additional note: When I use the same virt-manager image that crashes when booting from the virtual hard drive, and I boot instead from the CD image as though I were going to re-install, I can use the "Try Ubuntu MATE" option and everything works without crashing. I was beginning to think that it was virt-manager (or QEMU which virt-manager uses) but this wrinkle seems to point elsewhere.

Also, my older virtual machines of previous releases all function fine.

Is there an alternate down load file, burnable to USB?
I downloaded from the provided link. file is not recognized
by usb creator package. using 8 G stiks process worked
fine with download of 18.04 the beaver!

If you click the link above, you should be taken to a page from which you can choose the image that fits your hardware. For example, if your computer is an Intel or AMD 64-bit device, then this image is what you need: focal-desktop-amd64.iso

Ok, here's first official post

  1. test box has no optical drive. had to burn cd on wife's pc then pull the drive
    for install in test box, she was'nt happy but install went ok.

Test platform ASUS P5K-E MB
Q6600 C2D
8 g Ram
Video = EVGA GTX760

  1. Software boutique shows nothing can't locate T Bird
    2 Printer ADD panel will not configure. the panel shows the HP 8210
    at 192.168.1.69 but I can't select it, will not configure to system

Firefox seems fine, system found it's way through my switch / Router combo

I am able to mount all shared drives from 3 Win 7 Boxes
via the smb:// xxxxx/x route

I'm only on my 3rd week with ubuntu, so if feedback needs to be formatted
differently, I'll try to do better next time

1 Like

Thanks for the report. You don't have to go to such extremes to test :grinning:

You can use Etcher to "burn" the ISO image to a USB drive and boot from that USB drive and install.

It's normal for the Software Boutique to not show any available applications at this stage of the developmental process.

It's great to have "new" users giving us feedback. And you did fine on your first time!

1 Like

I upgraded my laptop on 19.10 to 20.04 because 19.10 was locking up so far so good, but I haven't used it on the web where 19.10 was locking up, but in all that I have used it it works perfectly as well as 19.10

update:did clean install of the jan 17 daily. the add printer still throws
a CUPS error.
Just an observation, I did a line by line comparison between the 20.04
manifest and the manifest for 18.04

The majority of the packets for 18.04 = 2.2.7-1 ubuntu 2.7

while 20.04 = 2.3.0-7 ubuntu1

  1. why the difference?
    2.printer install in 18.04 was smooth & painless, why fix something that is'nt
    broken

I have the same issue on my side.
Virtualbox: 5.2.36
Installed UM 19.10 a few weeks ago on a 20 GB new VM. I use Redmond UI.
Upgraded to UM20.04 this morning using update-manager - cd (means the latest version must be installed).
Result: system launches fine because Welcome screen is disabled
I clicked in Control Center/ Mate Menu on Software Boutique, and I'm in the system's log in window.
Desktop is ready again.
By default, I have an automated login.
I restarted the system and automated login works fine.
System has a problem "Report the problem" appears.

Created a new VM just for the today downloaded UM 20.04 from official link here in forum.
First, I chose Try Ubuntu Mate and Welcome screen launches fine.
I then clicked on Install.
Left the system as it is after the installation.
Control Center is also affected as well as Software Boutique, a click on both and I'm back in the login screen.
From now on, I can't do anything, I'm asked to report a problem, and I'm back in the login screen.
Reason: the Welcome screen wants to load.

About crash on loading of Ubuntu MATE Welcome we have bug-report on LaunchPad - it is https://bugs.launchpad.net/ubuntu/+source/xorg-server/+bug/1796437 .
For me it crashes using all versions of VirtualBox with 2 Gb RAM and default video adapter (16 Mb VRAM). See comment 16 in the bug-report for details about reproducibility. I suppose that some component from ubuntu-restricted-extras or ubuntu-restricted-addons cause the crash of Xorg.
My daily driver laptop is still running Ubuntu 16.04.6 LTS, so I use VirtualBox 5.1.38 here (from Oracle repository, but really it does not matter).
Just ended the test with 20200118 ISO using default VM settings and Xorg crashed.
Will investigate further.

I'm testing UM Focal on virtualbox. System in general is stable. I tried mate-tweak and see only two options GNOME2 and openSUSE. Redmond, Cupertino, Mutiny, Familiar etc. are not available. If I choose either of them the bottom panel goes below top panel and clock/indicator applets go missing.

I found the real reason for the crashes of Ubuntu MATE Welcome on both QEMU/KVM (Virt-Manager) and VirtualBox.

The problematic package is the gstreamer1.0-vaapi (see https://packages.ubuntu.com/focal/gstreamer1.0-vaapi).
It is a dependency of ubuntu-restricted-addons (see https://packages.ubuntu.com/focal/ubuntu-restricted-addons).

So ubuntu-mate-welcome and for example Cheese may be fixed by removing this package with

sudo apt-get purge gstreamer1.0-vaapi
sudo apt-get autoremove --purge # to remove libgstreamer-plugins-bad1.0-0 (is not a problem)

So this is not our bug.

3 Likes

@Norbert_X and everyone, I can confirm that using the two commands you provided to remove gstreamer1.0-vaapi eliminated the problem on the existing 20.04 installation in a virt-manager VM. Yelp and Cheese no longer crash the system. I also reinstalled ubuntu-mate-welcome and now it behaves as it should.

2 Likes

@OldNavy I agree with @franksmcb that you could have burned the ISO to a USB drive. If you would like some help, feel free to download one of the PDF books from this site. https://goinglinux.com/articles/UbuntuMATEBook_en.htm The "Upgrading from Windows or macOS" book includes installation instructions and both include lots of information for getting started with Ubuntu MATE. (The downloadable PDFs are earlier versions of the ones for sale on Amazon. Full disclosure: I am the author.)

I think it was more of an issue with the USB tool
I got from Pendrivelinux.com.It would not recognize the ubuntu file.
I ran it through Fedora Media Writer 4.1.4 it was more than willing
to accept ubuntu iso, I used it to install the 1-17 daily.
I'm currently chasing another rabbit hole, AVHI is throwing a network error
something about an unacceptable domain apparently it thinks my
router's ip has to have " .router.local" appended to it . So I'll be going
in circles for the next 12 hrs.

I'm dual-booting with Manjaro MATE and Ubuntu MATE 20.04, and, interestingly, I haven't gotten so much as a program error from apport.

In other words, it's running perfectly.

1 Like

Hello @franksmcb, how are you doing? I created a bootable flash drive and used it to boot my computer with UM 20.04 so the test was as accurate as possible because it was on an actual machine. The only point I want to raise here is that when I reached Martin wimpress out back at the 19.10 release and btw this is on the release notes as well, he told me that users would be able to ALT+TAB and then click on the application one would like to restore.

Just like the "vanilla" Ubuntu where not only you can do that but also if you press the "Super" key, all open applications are shown and again, one can click on one of them and restore it. And this feature wasn't present on the October release and it is nowhere to be found on 20.04 as well.

When one opens some applications, minimizes them and then presses ALT+TAB, one is not able to click on any of the open applications and as a final result, restore it. I just want to know why is it.

It would be nice if this feature will be present on this coming release because it's a really handy one. If you want me to send you a video of me using it, I will do.

Other than that, tearing is really gone, except some small stuttering here and there but that's fine by me and stability overall is great too. Thank you :+1: