Ubuntu MATE 20.04 Pre-release Testing

I installed 20.04 in Virtualbox (Host: Arch Xfce) and everything works great. Did full-upgrade and all is well. Ubuntu MATE is my go-to distro for anyone wanting to try Linux, starting them out on a great, super solid operating system. Keep up the fine work, guys.

I've managed to mess up with the updates on my PC running Ubuntu MATE 19.10... nothing seemed to be able to fix the situation... The PC worked but, for example, Wine was uninstalled, trying to re-install it via Synaptic signalised that a lot of other things will be uninstalled (caja, caja plugins, Brave browser, etc.)

Well, I thought it might be a good idea to try to update to Ubuntu MATE 20.04 before re-installing Ubuntu MATE 19.10 from scratch...

And... MAGIC !!!

  • WineHQ 5.0 installation works (I use it for Notepad++ and HeidiSQL)
  • re-enabled and re-configured the repositories in "Software & Updates" one by one
  • apt update / installation issues went away (after several updates / upgrades and re-boots)
  • Ubuntu MATE 20.04 runs with Linux Kernel 5.5.2 (after adding some missing i915 firmware files)
  • VirtualBox 6.1.2 from virtualbox.org works as expected
  • etc.


  • all the programs I use work as expected (GIMP, Krita, LibreOffice from PPA, Softmaker Office, Remmina form PPA, Clemetine, Vivaldi, Firefox, Thunderbird, Brave, VLC Media Player, MediathekView, Notepadqq, AnyDesk, Eclipse, ukuu, Kindle, KeepassXC, balenaEtcher, etc.).

The issues I've found during the last 6 hours after upgrading to UM 20.04:

  • Software Boutique is empty - each category
  • Software & Updates - issue reported here gi.repository.GLib.GError: pk-client-error-quark: ... and here software properties gtk crashed... => I made the changes in the "apt" list files and in the "Software & Updates" window, but used the Terminal for "sudo apt update", etc. to avoid the issue
  • I had to remove and re-install "Notepadqq" to be able to see the content of the files (the tabs were shown, but not the content)
  • Peter Levi's "Variety" - the "Text font" for "wise quotes" was set to "No font" -> fixed by selecting a font from the list

I am very impressed by the upgrade from UM 19.10 to UM 20.04 (even if still in development) :clap::clap::clap:
It was the first upgrade (using UM since 16.04) that went really SMOOTH and FIXED all the issues I've encountered due to my mistakes by messing up with "apt". THIS IS SOOOOOOO GREAT :+1::+1::+1:

Thank you all involved into the development! YOU ARE GREAT :hugs:

Looking forward for the final UM 20.04 version :heart_eyes:


Hello, I was messing with the new 20.04 daily builds of Ubuntu MATE in GNOME Boxes and I have found a major issue. The Ubuntu MATE Welcome app will freeze the desktop and send the user back to the Lightdm login screen. However, this is especially critical as:

  • The Ubuntu MATE Welcome app is packaged as a Snap, meaning that this issue will affect other versons of Ubuntu MATE (18.04, 19.10, etc).

  • The application will run on login by default, meaning that the only way to be able to safely uninstall it without being immediately kicked out of the desktop is to run sudo snap remove ubuntu-mate-welcome through a TTY.

  • Snaps auto-update, meaning that there is no way for a user to easily prevent an issue like this from happening from what I know.

I have reported this here and I think this is an extremely critical problem!

Try this and see if it works:


Huh, it works but seeing as this was almost a month ago I think it's still important to see about getting this fixed in some way.

Tested Daily (10/02/2020) on old Dell Core2 as Live USB. No issues. So installed over 19.10 root folder (including a format) with home left as-is. Then ran Software Updater.

I had a Brisk has quit unexpectedly message as soon as I opened the menu, which always seems to happen on this device on all recent releases, but I (auto-)reported as Bug 1862623 anyway.

But the upgrade issue I want to report here is probably not a bug per se, but could be an issue for upgraders. I use Compiz (for mouse switching of workspaces and placement of opening windows on specific monitors), and Compiz is no longer installed in Ubuntu MATE.

What happened without Compiz in place was that all windows opened without any windows management decoration. That's hard enough to deal with, but font sizes are affected too (way too large) and lots of minor issues. Solution is to enter MATE Tweak.

In MATE Tweak > Windows > Windows Manager selection was set to [blank] and a message in red displayed that the current window manager was unknown. Selecting either of the Marco entries brings everything back under control.

I would strongly suggest that the current warning in red remains displayed in MATE Tweak until the user's first visit to MATE Tweak, but that - in addition - one of the Marco WM's is temporarily selected for the user. The message could be updated to also indicate this action.

Leaving the WM as 'unknown' doesn't do anything for the user, who is either going to have to select something else or install Compiz without any WM, so it might be better to include a Macro WM in the meantime? It is a trade off decision between making it easier for those not confident in diagnosing and installing Compiz via Terminal by making it straightforward for less experienced users to install via Software Boutique then Synaptic, vs adding an extra step - of changing the MATE Tweak selection - for the Terminal user .

8 posts were split to a new topic: Grub menu remains hidden in 20.04

I tried to file a bug on this but it is a long an winding road through the dark so I'll raise the issue here.

I have NM stopped and disabled on my system but the release upgrader enables and starts NM. Not a huge deal but it is irritating, disconcerting when it takes the time to say hi.

Been playing with U-MATE 20.04 from 1/19/20 possibly daily bare metal install in '12 MacPro and overall it's fine . . . however a day or so back I was trying to upload a photo via Chromium in my IG account and it "didn't work."

Today, I reviewed the YouTube videos on how to upload a photo from your PC to Instagram using "Chrome" and toggling the "user agent" so that it looks like the PC is a "mobile device" . . . and the key to "success" is that the mouse cursor turns into a grey circle and a "+" loads into the IG toolbar . . . .

So I have "chromium" installed in both a U-mate & Lubuntu 20.04 installs, and I get the "+" sign to load into my IG window, when I click on the plus an "open file" window opens, if I click on the user home directory, the sub-directories load, but if I then select a sub-directory, in this case "Downloads" . . . none of the files in that directory show up, yet alone are able to be selected . . . meaning that no photo can be uploaded.

I tried this in Lu this morning before running any updates, then I rebooted into U-MATE system that upgraded perhaps 800+- packages yesterday and tried the same process in again "Chromium" . . . and that failed there as well. Then I rebooted into OSX 10.13 where I have "Chrome" installed and ran through the process, and that succeeded . . . so I don't know if it's the "Chrome" aspect, or the "OSX" aspect that got it through to upload.

After I did that I rebooted back into Lu, ran 240 upgrades, including a new "chromium" upgrade and restarted . . . trying again brings the same trouble with the "open file" window not loading sub-directory files . . . ????

I found some other issue as well the other day, but didn't seem to find it in my notes, this issue was time consuming in trying over and over to try to get the "open file" window to recognize "files" . . . ???? Is this a bug? don't know, it's a "glitch" that seems to be happening in both of my "ubuntu 20.04" systems . . . .

If you're using an alternative and you are really sure, you should mask the NetworkManager service, after stopping and disabling it:

sudo systemctl stop NetworkManager && sudo systemctl disable NetworkManager && sudo systemctl mask NetworkManager
1 Like

Just upgraded my Ubuntu-MATE 18.04 to 20.04 and found that the "python" command is missing: I realise that Python 2 is being deprecated in20.04, but there should be a default "python" command, so I added a Debian alternative:

update-alternatives --install /usr/bin/python python-interpreter /usr/bin/python3 90

Also hit a snag trying to install "Mendeley Desktop" bibliography software:

gdebi mendeleydesktop_1.19.4-stable_amd64.deb
Reading package lists... Done
Building dependency tree        
Reading state information... Done
Reading state information... Done
This package is uninstallable
Dependency is not satisfiable: python

Changed the dependency to python3 in the binary deb:

diff -Naur mendeleydesktop_1.19.4-stable_amd64/DEBIAN/control mendeleydesktop_1.19.41-stable_amd64/DEBIAN/control
--- mendeleydesktop_1.19.4-stable_amd64/DEBIAN/control	2019-04-08 13:20:54.000000000 +0100
+++ mendeleydesktop_1.19.41-stable_amd64/DEBIAN/control	2020-02-16 23:36:24.862104104 +0000
@@ -1,6 +1,6 @@
 Package: mendeleydesktop
-Version: 1.19.4
-Depends: libc6, python, gconf2, desktop-file-utils
+Version: 1.19.41
+Depends: libc6, python3, gconf2, desktop-file-utils
 Architecture: amd64
 Section: science
 Priority: extra

The deb now installs correctly and Mendeley works



Several days ago, with the arrival of the 5.4.0-14 kernel I began to see what might be a new feature for the lower panel (probably Window List).

As I mouse over each of the links on the lower panel, they display a sort of thumbnail. Cute if not especially useful. I'm sure that I'll come to like them in time however.

1 Like

That's part of MATE 1.24 :grinning:

1.24 is now included in the current daily ISO. If you have an older 20.04 install, you will see 1.24 when you update.


The Software Boutique has not yet been stocked for 20.04 so what you are seeing there is expected.

Thanks for the testing and the reports.


think this bug report applies to your case: https://bugs.launchpad.net/ubuntu/+source/python3-defaults/+bug/1863532

Please feel free to add to it.

I've wanted those thumbnails for a while they are useful when you have multiple windows of the same application open but cannot tell which ones are which the popup often lets you see without having to click all the windows

If we were provided with a way of turning tool tips off in the lower panel, I'd feel a lot better about the new visual thumbnails. For instance, the rather complete tool tip for this subject reads as "Ubuntu MATE 20.04 Pre-release Testing - Development Discussion - Ubuntu MATE Community - Basilisk" right now.


Unfortunately there's still video tearing, even on my old Intel Sandybridge card. I noticed it full screen and it happens on Debian as well.

Can't use the intel driver with the Tearfree option because that apparently clashes with Firefox, which won't start up properly.

Had to resort to the Marco + Compton solution to fix.

EDIT: Marco Adaptive + Intel Tearfree with forced hardware acceleration disabled in Firefox (about:config) works ok.

1 Like

We can turn off the thumbnails if that's what you mean it's in preferences, but as far as the descriptions or whatever they're called I don't know of a way, but they don't show up with thumbnails on my system if I remember right

7 posts were split to a new topic: Wi-fi problems in MATE 20.04

have not played in a while, did fresh install of the 2-19 daily.
FF still connects to the internet ok. I can still mount all my windows drives via SMB. but it appears there has been a step backward.
the add printer app is back to throwing CUPS errors.
the panel shows my OJP8210 at
but the panel freezes up & after a few minutes the cups error msg appears.