Ubuntu-mate for raspberry pi 3 model b+

Finally I find a working workaround!

Start Ubuntu Mate from “old” Pi 3 Model B and run the command

sudo BRANCH=stable rpi-update

This will install the needed files in /boot/ with the same kernel version of raspbian stretch.

The integrated wifi will not work because the correct firmware is not present in Ubuntu Mate i think;
I solved with a simple copy&paste from a fresh Raspbian Stretch SD.
Not knowing exactly wich are the missing files I simple did a join of the two folders /lib/firmware/brcm


why not buy a banana pi :banana:instead of a raspberry pi [you have to add a raspberry emoji :grin:]?

Note the original poster did not have a 3B+ back in January. A more recent thread on this problem is here 16.04.2 Won't boot on RPi 3 Model B+

Although it doesn’t really matter, rpi-update is frowned upon. To do similar with packages you could do:

sudo apt update sudo apt install raspberrypi-bootloader raspberrypi-kernel

Glad you got it working! Thanks for sharing your workaround.

Thank you very much.

We got it working in this thread on the RPI official forums too:


I posted this in another topic, but I guess it’s relevant here too:

I was able to make a bootable USB image of Ubuntu Mate for the Raspberry Pi 3B & 3B+ with this thread on the raspberrypi.org forums.

I made torrents of the images:


Thanks for the effort!

I am getting connection refused errors for the torrent downloads, can you please fix that/provide an alternative?

Thanks in advance.

@Terminator_NL They appear to be working at the moment. Can you try again?

I cant seem to get it to work. :confused:

Welp! I got them! Thank you so much.

How did you get it to work? Another browser?

I had to download it through a VPN. Looks like the (reasonably crappy) network I am on blocks downloading .torrent files.

Presumably because the url ends with .torrent, and the page wasnt retrieved using https.

But I’m flashing it right now! Fingers crossed.

Thank you so much

It worked right off the bat! (SD)

You’re amazing.

[quote=“Terminator_NL, post:16, topic:15867, full:true”]
I had to download it through a VPN. Looks like the (reasonably crappy) network I am on blocks downloading .torrent files.

Presumably because the url ends with .torrent, and the page wasnt retrieved using https.
[/quote]Thanks for letting me know :slight_smile: I’ll also put them in a .zip next time.

[quote=“Terminator_NL, post:17, topic:15867, full:true”]
It worked right off the bat! (SD)

You’re amazing.
[/quote]Thank the Raspberry Pi forums, it’s the amazing people over there that gathered the instructions on how to make it work :wink:

This WILL NOT make Ubuntu MATE boot with the Pi3B+ - this is the correct method to update kernel and firmware, BUT will only update to those in the repository WHICH HAS NOT BEEN UPDATED.

Incidentally the “current” version is 16.04.4, although there is no matching image - BUT you can upgrade from 16.04.2

Thanks for pointing that out. I don’t use Ubuntu-mate (or raspbian for that matter) on my pi so it is always a bit of a risk posting anything on here.

Sorry if I wasted your time or anybody else’s with those commands. Updated packages can be found here http://archive.raspberrypi.org/debian/pool/main/r/raspberrypi-firmware/

Thanks for creating the images, sadly they don’t work for me. As it starts up there is an error that flashes up saying unable to load kernel modules. It continues on but then the install/config fails

Ok so ignore that. It seems the error during setup was down to the wifi config. I skipped that and the setup completed. Load kernel modules error is still visible on boot but seems to be carrying on ok

Thanks from me, too! :grin: Works perfectly and after a big dissapointment realizing that my RPi 3+ will not work with Ubuntu Mate, you made my day. Maybe this is obvious to those mastering Linux, but to save others’ time and nerves: it is worth noting that any subsequent software update should be done with caution. Firstly , boot partition is too small for upgrades and needs to be resized. And, firefox, for instance, did not work after upgrading. I didn’t bother downgrading it, but rather reinstalled the whole OS anew.
All in all, it serves it purposes as it is.

Please just give us some feedback on:

A) that someone is actually working on an 18.04 raspberrypi release
B) if so, approximately when will it be released