Ubuntu Mate Pi - Unable to Log into SIM7600 HAT via UART

Ubuntu Mate Pi - Unable to Log into SIM7600 HAT via UART. Have tried Putty. No success. Have tried minicom. No success. Have tried ttyS0-4. No success. Have tried ttyUSB0-5. No success. Have tried ttyAMA0. No success. I think it may be tied to disabling bluetooth but no sure.

Welcome, @TD365.

(First of all, a note to others who looked at the title of this topic and was puzzled: The SIM7600 HAT is a 3G / 4G LTE cellular modem manufactured by a company called Waveshare. It is specially designed to fit over the GPIO pins of a Raspberry Pi, and uses the UART connection to the Raspberry Pi as a means of communication -- normally, the Pi's UART is merely for boot-up debugging purposes. In other words, this is basically an RS-232 serial device, it appears.)

I took a look at this PDF and pages 18-24 contain semi-detailed (but barely readable) instructions on how to use the device on a Raspberry Pi. I think the most important part of the document is that you have to open raspi-config and enable the serial port hardware and disable the serial port login shell (page 19). The guide also says that there's a special shell script you need to download and execute to initialize the device properly, then you need to reboot for the changes to take effect. I don't own this device myself, so I can't help you in that regard. But you might want to look over that PDF and make sure you've done all of those steps.

All of that is great insight but unfortunately I am running Ubuntu Mate Pi. The instruction set is for Raspberry Pi OS. I want it to run on Ubuntu Mate Pi. I'll keep digging. Thanks for your efforts gordon.

Oops. I forgot that raspi-config is available only in Raspbian.